KDE 3.4.2 : problème mot de passe


#1

Je précise tout de suite que ce problème ne concerne pas la V 3.3, qui, elle fonctionne parfaitement.
J’aimerais l’avis et les essais des amis qui ont installé KDE 3.4.2 sur une Debian, par l’intermédiaire de ce portail en ‘unstable’ :
deb pkg-kde.alioth.debian.org/kde-3.4.1/ ./
Quand je veux ouvrir :
Centre de config / administration du système / gestionnaire de connexion
pour modifier les données, il faut cliquer sur :
mode superutilisatuer (logique)
là, il est demandé le pass de root (logique)
Je tape mon mdp et au bout de qq seconde, je suis de retour vers la fenêtre bleue (version, utilisateur, etc. et explication de ce que l’on doit faire)
donc, un chien qui se mord la queue.
Si je tape en console ce qui est indiqué ds la fenêtre de demande de mdp :
kcmshell kdm
j’ai un msg d’alerte :
problème de communication avec DCOP - … vérifiez que le programme dcopserver fonctionne.
Voilà ce qui est indiqué sur la console :

[code]ricardo:/home/ricardo# kcmshell kdm
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed

It looks like dcopserver is already running. If you are sure
that it is not already running, remove /root/.DCOPserver_ricardo__0
and start dcopserver again.

DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
WARNING: DCOP communication problem!
kdeinit: Communication error with launcher. Exiting!
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
[/code]
Si je clique sur OK ds ce msg d’alerte, la bonne fenêtre s’ouvre bien et je peux modifier ttes les données normalement mais avant de se fermer, la console ajoute ça :

I couldn't enable notifications at the dcopserver! I couldn't enable notifications at the dcopserver! QImage::smoothScale: Image is a null image QImage::smoothScale: Image is a null image QImage::smoothScale: Image is a null image ricardo:/home/ricardo#

Tout ça n’est ptet pas très clair mais le plus simple, serait que ceux qui tournent sous KDE 3.4 fasse l’essai et me disent s’ils obtiennent le m^ rslt.
Merci à ts.


#2

Dans une console utilisateur essaye de taper ceci :

$ xhost +
$ su
Password: [ton mdp root]
# kcontrol

Attend un peu et tu devrais avoir un centre de contrôle root KDE de lancé (attention étant donné qu’il doit faire un kdeinit en root faut être un peu patient mais si dix minutes après tu as rien tu peux dire que ça marche pas)


#3

salut Ricardo,
bon avec les mêmes sources que toi, (ça tu savais deja), j’ai aussi “un chien qui se mord la queue”, enfin presque. Qd je tapes kcmshell kdm, une nouvelle fenetre de config de kdm s’ouvre, me demande mon mot de passe root, mais de nouveau “un chien qui se mord la queue”. Et en console j’ai le même message que toi, à savoir: QImage::smoothScale: Image is a null image

Bref, j’ai quasi les mêmes symptomes que toi!


#4

Bizarre bizarre votre truc. Je viens de faire le même test chez moi, et ça marche. Alors, pour commencer, as tu dans ton home directory un fichier qui commence par .DCOPserver. Normalement, il doit contenir le pid du DCOPserver.
Ensuite, il parle d’un fichier /root/.DCOPserver_ricardo__0, t’as vérifié si ce fichier éxiste?


#5

c’est la 3.4.1 qui est proposée dans ce dépot.

de plus la 3.4.2 est maintenant disponible en testing …

j’ai personnellement fait la mise à jour pour les quelques applications que j’utilise.

j’ai recontré un seul souci au niveau d’une librarie (kdelibs4 / kdelibs4c2 ??) qui m’a forcé à installer K3b et Kaffeine à partir du dépôt unstable. j’etais pas sur de mon coup mais ça fonctionne bien comme ça. voili voilà.

a bon entendeur …


#6

moi j’ai souvent eu ce problème de mot de passe mais je le contournai avec la méthode que j’ai dit plus haut : lancer kcontrol en tant que root… j’ai une question : est-ce que quand on tape son mot de passe root dans la centre de contrôle il fait un kdeinit en root ou il réutilise la session courante?


#7

Salut BobX, et à tous,
voila ce que contient le .DCOP de mon home: local/madebian:/tmp/.ICE-unix/dcop4345-1131303491
4345
Et pas de fichier .DCOP dans le repertoire root.


#8

[quote]Dans une console utilisateur essaye de taper ceci :
Code:

$ xhost +
$ su
Password: [ton mdp root]

kcontrol [/quote]

Oui, ça fonctionne mais il y a quand m^ des erreurs ds la console.
Je n’ai pas besoin de faire xhost car il est déjà installé en fixe

[quote]Bref, j’ai quasi les mêmes symptomes que toi![/quote] Ça me rassure un peu, je ne suis pas seul :wink:

[quote]Bizarre bizarre votre truc. Je viens de faire le même test chez moi, et ça marche[/quote] Tu as bien la 3.4 Bobx ?

[quote]as tu dans ton home directory un fichier qui commence par .DCOPserver. Normalement, il doit contenir le pid du DCOPserver. [/quote]Oui, ds le m^ genre que Yo4

local/ricardo:/tmp/.ICE-unix/dcop4655-1131316068 4655

[quote]Ensuite, il parle d’un fichier /root/.DCOPserver_ricardo__0, t’as vérifié si ce fichier éxiste?[/quote]Là non, je ne l’ai pas celui-ci :cry: Il faut que je vérifie s’il existe sur ma Debian avec kde 3.3.

PS :
il n’existe pas non plus sur la Debian kde 3.3 et pourtant, je n’ai pas ce problème avec celle-là


#9

Oui, je suis en 3.4.2. Par contre, je suis en sid, alors que à ce que j’ai compris, tu as installé des packages sid alors que le reste de ta distrib est en Etch (ou en Sarge, je sais plus)


#10

Pour KDE, la 3.4.2 est aussi pèchée en sid car je crois me souvenir qu’en testing, elle n’est pas présente.


#11

je ne sais pas pourquoi mais j’ai comme l’impression que tu ignores completement mes posts :cry:

c’est la 3.4.1 qui est proposée dans ce dépot.

de plus la 3.4.2 est maintenant disponible en testing

j’ai personnellement fait la mise à jour pour les quelques applications que j’utilise.

j’ai recontré un seul souci au niveau d’une librarie (kdelibs4 / kdelibs4c2 ??) qui m’a forcé à installer K3b et Kaffeine à partir du dépôt unstable. j’etais pas sur de mon coup mais ça fonctionne bien comme ça. voili voilà.

a bon entendeur …[/quote]

( cfr. forum.debian-fr.org/viewtopic.php?p=9688#9688 )


#12

Oui, tu as raison mais on ne se rappelle pas facilement de tout.
Sory :blush:


#13

[quote=“ricardo”]Oui, tu as raison mais on ne se rappelle pas facilement de tout.
Sory :blush:[/quote]

c’est bon pour une fois! :laughing:


#14

Je déterre ce topic car sur ma nvelle install de Sid, j’ai encore le m^ problème, seulement là j’ai un msg qui va ptet vs dire qq chose.
Comme la fenêtre ne s’ouvre pas en graphique, je passe par la console :laughing: et je peux modifier ce que je veux mais avec ce msg :

ricardo@ricardo:~$ sudo kcmshell kdm Password: Error: "/var/tmp/kdecache-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/var/tmp/kdecache-root" kcmshell: WARNING: user(s) 'sync,identd,sshd,jabber' have unknown GID 65534 QImage::smoothScale: Image is a null image QImage::smoothScale: Image is a null image QImage::smoothScale: Image is a null image Error: "/tmp/ksocket-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/tmp/ksocket-root" Error: "/var/tmp/kdecache-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/var/tmp/kdecache-root" Error: "/tmp/kde-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/tmp/kde-root" ricardo@ricardo:~$
Apparemment, une histoire de droits et d’IUD qq part. Que faire ?


#15

[quote=“ricardo”]Je déterre ce topic car sur ma nvelle install de Sid, j’ai encore le m^ problème, seulement là j’ai un msg qui va ptet vs dire qq chose.
Comme la fenêtre ne s’ouvre pas en graphique, je passe par la console :laughing: et je peux modifier ce que je veux mais avec ce msg :

ricardo@ricardo:~$ sudo kcmshell kdm Password: Error: "/var/tmp/kdecache-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/var/tmp/kdecache-root" kcmshell: WARNING: user(s) 'sync,identd,sshd,jabber' have unknown GID 65534 QImage::smoothScale: Image is a null image QImage::smoothScale: Image is a null image QImage::smoothScale: Image is a null image Error: "/tmp/ksocket-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/tmp/ksocket-root" Error: "/var/tmp/kdecache-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/var/tmp/kdecache-root" Error: "/tmp/kde-ricardo" is owned by uid 1000 instead of uid 0. Link points to "/tmp/kde-root" ricardo@ricardo:~$
Apparemment, une histoire de droits et d’IUD qq part. Que faire ?[/quote]
C’était pas exactement le même message que j’avais eu mais ca y ressemble: http://forum.debian-fr.org/viewtopic.php?t=1644&highlight=
En résumé, pour moi c’étaient les droits sur /tmp qui avaient changé …


#16

Meri Jabba mais j’avais déjà fait la manip mais : néant.