Konqueror mode superutilisateur repart


#1

salut
je viens d’installé debian sarge 3.1 , j’ai ensuite utilisé konqueror root et j’ai interdit l’acces aux groupes et autres du fichier passwd ,puis je suis passé en utilisateur .
j’ai voulu ensuite reprendre konqueror en root et celui ci se mettait dans la barre des taches avec le sable en attente .Au bout de plusieurs secondes (je m’attendais qu’il s’ouvre )mais il disparu sur le champ.
j’ai reéssayé , c’est idem . donc je ne peux utilisé konqueror depuis demarrer /konqueror mode superutilisateur .

ca doit venir de ma modification du fichier cité + haut .
maintenant comment faire pour retrouvé konqueror root comme avant ?
ne dois je pas autorisé ou refuser au groupes et autres par cette methode ?


#2

[quote=“allman”]salut
je viens d’installé debian sarge 3.1 , j’ai ensuite utilisé konqueror root et j’ai interdit l’acces aux groupes et autres du fichier passwd ,puis je suis passé en utilisateur .
j’ai voulu ensuite reprendre konqueror en root et celui ci se mettait dans la barre des taches avec le sable en attente .Au bout de plusieurs secondes (je m’attendais qu’il s’ouvre )mais il disparu sur le champ.
j’ai reéssayé , c’est idem . donc je ne peux utilisé konqueror depuis demarrer /konqueror mode superutilisateur .

ca doit venir de ma modification du fichier cité + haut .
maintenant comment faire pour retrouvé konqueror root comme avant ?
ne dois je pas autorisé ou refuser au groupes et autres par cette methode ?[/quote]
1/ne JAMAIS utiliser le compte root pour ouvrir une session graphique
2/avec ‘su’ dans une konsole de ta session normale, tu tapes “su” et le password de root et tu sera root. Tu pourra rechanger les droits sur les fichiers.
3/non, il n’y a rien de particulier à configurer pour protèger les fichiers critiques contre les maladresses des utilisateurs. Tout est déjà sécurisé au maximum. Et ce n’est pas comme ça non plus qu’on donne des droits aux utilisateurs.
4/Lis un peu de documentation sur ce que tu manipules. 'man ’ pour commencer sur l’usage d’une commande.


#3

je découvre debian .
je te remercie MattOTop .


#4

Ce qu’a écrit MattOTop est aussi valable pour les autres distrbutions Gnu/Linux, même si certaines, telle que Mandriva, permettre la connexion root en graphique (Debian ne l’a permet pas par défaut).

Même Windows XP prend la précaution de masquer les dossiers systèmes aux utilisateurs.


#5

quote="Korben Dallas"Même Windows XP prend la précaution de masquer les dossiers systèmes aux utilisateurs.[/quote]Sauf que linux a une logique différente: tous les fichiers sont visibles et accessible directement quand on connait leur chemin, mais pas toujours lisible (fichier) ou parcourable (rep) par tout le monde.


#6

Korben Dallas a ecrit :

non pas toutes les distributions.
avec mandriva on accede en root en graphique mais egalement avec suze .


#7

De plus Korben, ce que tu dis régulièrement à ce propos m’etonne: je ne me souviens pas de m’être trouvé embeté sous debian pour ouvrir une session root sous X.
Mais c’est vrai que je ne l’ai pas fait depuis trés longtemps, alors peut être que c’est verrouillé maintenant.
Maintenant, ca n’empêche pas, quelle que soit la distrib d’eviter de le faire, même si c’est possible. On peut toujours faire autrement, et c’est dangereux…


#8

[quote=“allman”]Korben Dallas a ecrit :

non pas toutes les distributions.
avec mandriva on accede en root en graphique mais egalement avec suze .[/quote]
Euh, je suis sûr qu’on dit la même chose :slightly_smiling: ou alors je comprends mal le français (c’est ma langue maternelle).


#9

GDM ne le permet pas “par défaut”. Bien sûr, on peut passer outre en décochant l’option ad’hoc de GDM, mais en toute connaissance de cause.

Je ne sais pas si c’est la même chose avec KDM ou encore XDM et je n’ai pas envie de tester (ça ne me semble pas vital).

Cela dit, ça ne sert à rien, donc autant laisser tel quel comme tu le précises aussi.


#10

J’ai découvert avec la distrib ubuntu, une commande qui existe pour se passer de root et ainsi diminuer les risques de gaffes à répétition pour les débutants c’est la commandes “sudo” .

Mais elle n’est pas installée par défaut.

ensuite lancer une commande qui nécessite les privilèges root avec sudo
par exemple :


#11

KD: evidemment, je n’ai qu’une machine sous gdm, et je ne passe que rarement sous linux avec. Je comprends mieux.
dexmon: tu oublies de préciser qu’il faut configurer sudo pour donner des droits aux utilisateurs que tu souhaites (sinon, tout le monde serait root).


#12

Je ne suis pas sûr que vs parliez ts les 2 de la m^ façon de vs connecter sous root en graphique.
À partir de kdm, on ne peut pas se connecter sous root.
Par contre, à partir du mode texte (en rescue, par exemple) c’est possible.
Ce qui est possible aussi et à partir de kde, c’est d’ouvrir un navig de fichier en tant que root.


#13

si si, mais je ne savais pas que kdm interdisait la connection root. Ca doit etre changeable dans kdm.conf, mais pas dans le panneau de config kde.
Pour dire que je fais souvent des tentatives de connection sous root :wink: