La qualité du son me rend dingue


#1

Bonjour a tous,

Deja merci de me lire :slightly_smiling:

Voila, ca va faire maintenant 4 mois je pense que je suis passé de windows a linux. J’en suis vraiment tres content. J’arrive a me passer totalement de windows, ca me fait tres plaisir d’utiliser tout plein de softs en open source.

J’ai reussi a me debrouiller en general grace a l’aide des forums. A chaque fois j’y ai trouvé toutes mes reponses sauf pour la question que je vais poser… forcement.

donc je suis tres content d’etre sous linux mais il a quelque chose que je regrette sous windows: la gestion du son, ou sa qualité plustot.

En fait je n’arrive pas avoir un son aussi nickel que sous windows (que ce soit des wav, des ogg etc…)
J’ecoute bcp de musique, alors ca me gene beaucoup.
J’ai l’impression que mon son sature toujours un petit peu. Je précise que j’ai bien alsa de configurer, que sous amarok, j’ai essayé a la plupars des moteurs de son… mais ca ne change pas beaucoup.
J’ai aussi bien sur ‘joué’ avec Kmix… et meme si je baisse bcp le voume du master et du PCM, soit j’entend presque pas et sa sature un tout petit peu, soit le volume est correct et sa sature beaucoup.
J’ai aussi joué avec les equalizer, sans plus de resultat…
Je précise aussi enfin que je fais tous mes tests avec VLC et AMAROK et que j’ai testé avec ma carte son intégré AC97, et ma PCI: fortissimo 2

Ha oui et peut etre le principal: je suis sous Debian Sarge

Si vous avez quelque conseil pour moi, je suis preneur.
Bonne journée merci


#2

salut je pense devancer les autres membres en te disant d etre plus precis :slightly_smiling:

probleme sous les jeu ??
tu utilise alsa?? oss?? probleme lier a la frenquence du son ??

tips: a tu fixer l agp/pci a 66Hz/33HZ dans ton bios ???
cela a pour effect de fixer les frequence interne de l orloge de ton pc (je dit ca au cas ou tu a overclocker ton pc)

salut et bienvenu sur debian-fr.org
:stuck_out_tongue:


#3

voilà ce que j’avais fait à l’époque:

#root> apt-get remove --purge alsa-base alsa-utils #root> apt-get install alsa-base alsa-utils #root> alsaconf

et aussi:

editer le fichier /etc/esound/esd.conf
et y remplacer auto_spawn=0 par auto_spawn=1

maintenant, cela dépend un peu de ton environnement et de ta config aussi.

sous KDE par exemple, je sais que pas mal de personnes jouent avec kcontrol, dans l’onglet “son & multimedia” et y changent les valeurs “buffer” et “auto-suspend”; à voir avec les spécialistes KDE sur ce site …

il y a aussi un topic très interessant et complet sur la configuration du son sur le forum français de Ubuntu, qui est en tout point identique pour Debian; à lire! ça se passe ici: forum.ubuntu-fr.org/viewtopic.php?id=2969

bonne chance et tiens nous au courant!

PS/ je suis d’accord avec toi, le son en général sous Linux demande à être simplifié, uniformisé car reste relativement trop complexe; ALSA, ESD, ARTS, GSTREAMER, … j’imagine et j’espere qu’avec le temps, tout cela evolura dans le bon sens tel que déjà beaucoup d’autres aspects de Linux! en attendant, il faut “chipoter” un peu pour obtenir les resultas escompés …


#4

Bon, moi aussi, j’ai ce problème de qualité du son, donc j’ai suivi les instructions de forum d’Ubuntu, … et j’ai perdu le son :angry:
Bon, j’ai désinstallé alsa-base et alsa-utils, lancé alsaconf pui alsamixer, et j’ai retrouvé mon son… toujours aussi pourri :unamused:
Pourquoi ça marche si mal le son sous Debian ?? :cry:


#5

Bon :
:arrow_right: étrange, la qualité du son est meilleure avec rythmbox qu’avec xmms ! Je dirai même qu’elle est satisfaisante… pas parfaite, car il subsiste un crachouilli en arrière plan.
:arrow_right: J’ai perdu le mixer qui permettait de régler le son dans ma barre gnome :frowning:


#6

[quote=“Korben Dallas”]Bon :
:arrow_right: étrange, la qualité du son est meilleure avec rythmbox qu’avec xmms ! Je dirai même qu’elle est satisfaisante… pas parfaite, car il subsiste un crachouilli en arrière plan.
:arrow_right: J’ai perdu le mixer qui permettait de régler le son dans ma barre gnome :frowning:[/quote]

  1. le son est parfait chez moi avec XMMS; as-tu changé le “Output Plugin” dans les préférences? Chez moi, j’ai mis “ALSA 1.2.10”; je me rapelle avoir eu du son pourri avec les autres.
    aussi, as-tu réglé Gstreamer? Desktop / Preferences / Multimedia Systems Selector (ou gstreamer-properties dans un terminal) et tu y mets tout en “ALSA”.

  2. bouton droit sur le panel (barre gnome), “Add to panel” et là tu choisis l’applet “Volume Control” dans la foulée.

c’est mieux?


#7

Bon merci pour vos reponses, mais apres avoir essayé tout ca, ca ne changes tj pas :frowning: mais j’ai trouvé plein de topic qui parle des pb que j’ai avec la fortissimo.

De plus le driver ne permet pas te regler les basses et les aigus pour l’ensemble des applis. Ca me saoul

ALors j’en ai eut marre et je suis allé m’acheté une audigy 2 ZS…
Je viens de l’installé, j’ai reconfigurer alsa mais ca marche pas :slightly_smiling:
Apres encore pas mal de temps passé sur google je me suis appercu que plein de gens ont des pb avec leur audigy 2 ZS avec le noyau 2.6.12 et qu’avec le 13 ca marche sans pb. Moi j’ai le 2.6.8…
Alors je voudrais passer en 2.6.13 (ou meme 2.6.14 si possible) mais j’ai pas trop envis d’essayer de recompiler mon kernel tout de suite, je me sens pas encore de niveau. Je préferais donc essayer un kernel précompilé mais je ne trouve pas ou en telecharger un 2.6.13 ??

quelqu’un pourrait-il m’aider pour cela?

merci des vos reponses en tout cas.


#8

[code]Package linux-image-2.6.14-1-386

* unstable (base): Linux kernel 2.6.14 image on 386-class machines
  2.6.14-2: i386

[/code]

Tu peux l’installer par apt-get install linux-image-2.6.14-1-386Mais il ne faut pas oublier de mettre l’accès au package unstable dans ton source.list :slightly_smiling:


#9

[quote=“atlas”]Bon merci pour vos reponses, mais apres avoir essayé tout ca, ca ne changes tj pas :frowning: mais j’ai trouvé plein de topic qui parle des pb que j’ai avec la fortissimo.

De plus le driver ne permet pas te regler les basses et les aigus pour l’ensemble des applis. Ca me saoul

ALors j’en ai eut marre et je suis allé m’acheté une audigy 2 ZS…
Je viens de l’installé, j’ai reconfigurer alsa mais ca marche pas :slightly_smiling:
Apres encore pas mal de temps passé sur google je me suis appercu que plein de gens ont des pb avec leur audigy 2 ZS avec le noyau 2.6.12 et qu’avec le 13 ca marche sans pb. Moi j’ai le 2.6.8…
Alors je voudrais passer en 2.6.13 (ou meme 2.6.14 si possible) mais j’ai pas trop envis d’essayer de recompiler mon kernel tout de suite, je me sens pas encore de niveau. Je préferais donc essayer un kernel précompilé mais je ne trouve pas ou en telecharger un 2.6.13 ??

quelqu’un pourrait-il m’aider pour cela?

merci des vos reponses en tout cas.[/quote]

alors, je vais te casser je pense: j’ai une Audigy 2 ZS et elle fonctionne sans probleme sur le 2.6.12 :slightly_smiling:

es-tu sur d’avoir installé tous les packages necessaires (alsa, gstreamer, …)?


#10

[quote=“ghostintheshell”]1. le son est parfait chez moi avec XMMS; as-tu changé le “Output Plugin” dans les préférences? Chez moi, j’ai mis “ALSA 1.2.10”; je me rapelle avoir eu du son pourri avec les autres.[/quote]Oui. J’ai testé plusieurs options. Aucune ne me satisfont. Remarque importante, finalement, sous rythmbox, le son n’est pas vraiment meilleur. Je me suis fait avoir car j’avais testé en écoutant une musique assez dynamique qui a tendance à masquer les crachouillis :frowning:

[quote=“ghostintheshell”]aussi, as-tu réglé Gstreamer? Desktop / Preferences / Multimedia Systems Selector (ou gstreamer-properties dans un terminal) et tu y mets tout en “ALSA”.[/quote]Je n’ai pas d’autres choix que Personnalisé (Alsa n’apparaît pas ! ). Comme Pipeline, j’ai osssink pour la partie “Sink” et osssrc pour la partie “Source par défaut”. Je suppose qu’il me faut changer ça, mais quoi mettre ?

[quote=“ghostintheshell”]2. bouton droit sur le panel (barre gnome), “Add to panel” et là tu choisis l’applet “Volume Control” dans la foulée.[/quote]Oui merci, j’avais trouvé juste après avoir posté. Je suis un âne de ne pas y avoir pensé avant !


#11

[quote=“Korben Dallas”][quote=“ghostintheshell”]aussi, as-tu réglé Gstreamer? Desktop / Preferences / Multimedia Systems Selector (ou gstreamer-properties dans un terminal) et tu y mets tout en “ALSA”.[/quote]Je n’ai pas d’autres choix que Personnalisé (Alsa n’apparaît pas ! ).[/quote]gstreamer0.8-alsa n’était pas installé, donc ça ne pouvait pas aller. Je viens de l’installer, et le son n’est pas meilleur :frowning:


#12

[quote=“ghostintheshell”]
alors, je vais te casser je pense: j’ai une Audigy 2 ZS et elle fonctionne sans probleme sur le 2.6.12 :slightly_smiling:
es-tu sur d’avoir installé tous les packages necessaires (alsa, gstreamer, …)?[/quote]

Bah je sais pas, moi j’ai vu ca sur plusieurs topic.
Mais je précise que moi je n’ai meme pas le 2.6.12, je n’ai que le 2.6.8 …

EDIT: mais ca ne craint pas que j’install un packgae unstable alors que tous mes autres packages sont stable?
Est ce que je peux mettre juste le noyau en unstable et ensuite enlever la source unstable de mon source list?


#13

oui tu peux mais tu peux aussi travailler avec les preferences tu gardes tes sources unstable dans ton sources.list mais tu rajoute un fichier preferences dant /etc/apt/ a l’intérieur duquel tu met que tu veux les paquets stables mais que pour les noyaux tu veux les paquets unstable ou testing

[code]Package: *
Pin: release a=stable
Pin-Priority: 990

Package: *
Pin: release a=apt-build
Pin-Priority: 990

Package: *
Pin: release a=testing
Pin-Priority: 66

Package: *
Pin: release a=unstable
Pin-Priority: 33

Package: *
Pin: release a=experimental
Pin-Priority: 15

Package: linux-source-*
Pin: release a= testing
Pin-Priority: 500

[/code]


#14

Ha ok merci, je ne savais pas.
C’est bien pratique.

Donc je viens d’installer le noyau précompilé 2.6.14 i386
L’install a bien fonctionné sans pb, il m’a bien modifier le fichier list de mon grub pour pouvoir booter dessus. Donc je reboot, arrivé a grub, je selectionne le nouveau noyau, et la, ca bloque, ca s’arrete a a ligne ‘boot’.

je crois que ca s’arrete juste a grub quoi… Pourtant j’ai bien le fichier vmlinuz-2.6.14-1-386 dans mon repertoire boot…

Alors j’ai redemarré avec l’ancien noyau, et l’a j’ai essayé d’installer le noyau précompilé 2.6.14-1-k7 vu que j’ai un athlon (un 32bit)
Mais cela me fait la meme chose. Je ne comprend pas, ca bloque du boot.
Et donc aucun message d’erreur qui pourrait me donner un petit indice.

:open_mouth:


#15

pour info, je n’ai pas eu le temps d’insister, mais ma machine aussi refuse de booter en 2.6.14, et je reste pour l’instant en 2.6.12 :confused:


#16

aie, ca bloque aussi au boot?

bon ok je voudrais quand meme au moins tester avec le 2.6.13 ou meme 2.6.12, mais je comprend pas pkoi je trouve pas le kernel image 2.6.12 ou 2.6.13 dans synaptic alors que j’ai bien le 2.6.14 ?? :blush:
Je suis un peu perdu…

EDIT: honte a moi! en fait ma audigy marche tres bien avec le noyau 2.6.8 :blush: Y a tellement de bordel en ce moment sur mon bureau que je m’ettais trompé de cable :unamused: :blush: :laughing:

Et en tout cas, entre la fortissimo et celle ci, c’est le jour et la nuit. Plus du tout de pb de saturation du tout. Je peux (enfin) regler les aigus et les basses pour l’ensemble :slightly_smiling: , ca fait du bien :slightly_smiling:

En tout cas merci pour toutes vos reponses. Et j’essairais quand meme de comprend pkoi les autres noyaux n’ont pas booté…


#17

[quote=“atlas”]EDIT: honte a moi! en fait ma audigy marche tres bien avec le noyau 2.6.8 :blush: Y a tellement de bordel en ce moment sur mon bureau que je m’ettais trompé de cable :unamused: :blush: :laughing:

Et en tout cas, entre la fortissimo et celle ci, c’est le jour et la nuit. Plus du tout de pb de saturation du tout. Je peux (enfin) regler les aigus et les basses pour l’ensemble :slightly_smiling: , ca fait du bien :slightly_smiling:[/quote]
Ha ça veut donc dire que ma carte son toute pourrie (AC97 sur carte mère) pourrait être la cause de mes résultats médiocres ?
Je vais casser ma tirelire si ça continue : pour pas trop cher, quels modèles me conseillez-vous pour ma Testing ?


#18

quote=“atlas”

bon ok je voudrais quand meme au moins tester avec le 2.6.13 ou meme 2.6.12, mais je comprend pas pkoi je trouve pas le kernel image 2.6.12 ou 2.6.13 dans synaptic alors que j’ai bien le 2.6.14 ?? :blush:
Je suis un peu perdu…[/quote]

j’utilise le 2.6.12 qui est dispo en “Testing”.
au passage, je rappelle que l’ “unstable” est … instable.

a bon entendeur …


#19

[quote=“Korben Dallas”][quote=“atlas”]EDIT: honte a moi! en fait ma audigy marche tres bien avec le noyau 2.6.8 :blush: Y a tellement de bordel en ce moment sur mon bureau que je m’ettais trompé de cable :unamused: :blush: :laughing:

Et en tout cas, entre la fortissimo et celle ci, c’est le jour et la nuit. Plus du tout de pb de saturation du tout. Je peux (enfin) regler les aigus et les basses pour l’ensemble :slightly_smiling: , ca fait du bien :slightly_smiling:[/quote]
Ha ça veut donc dire que ma carte son toute pourrie (AC97 sur carte mère) pourrait être la cause de mes résultats médiocres ?
Je vais casser ma tirelire si ça continue : pour pas trop cher, quels modèles me conseillez-vous pour ma Testing ?[/quote]

une Audigy 2 ZS :smiley:


#20

[quote=“Korben Dallas”]
Ha ça veut donc dire que ma carte son toute pourrie (AC97 sur carte mère) pourrait être la cause de mes résultats médiocres ?
Je vais casser ma tirelire si ça continue : pour pas trop cher, quels modèles me conseillez-vous pour ma Testing ?[/quote]

En fait je pense que oui, car avant de mettre ma fortissimo, j’avais ma carte son intégré AC97… Et vu que c’etait vraiment pourrie le son, j’ai essayé avec ma fortissimo, et c’etait vraiment pas mieux. Alors je pensais que ca venait d’un pb logiciel…

Et je m’appercois que non vu qu’avec la audigy 2 ZS, comme je dis plus haut, c’est le jour et la nuit :slightly_smiling:
Je l’ai payé 75$ en OEM ici au canada, mais je suis sur qu’a mongallet, en OEM non plus elle ne doit pas etre super cher…

Et puis plus j’y pense plus je me dis que c’est pas la fortissimo le pb, c’est son driver… Il doit etre moins bien fait que celui des creatives. Surrement moins d’info de la part du constructeur pour le faire et surrement moins de gens qui en possede une qu’une creative!