Le retour après réinstall


#1

Bonjour à tous :smiley:

Bien, me revoici après une réinstall de Debian. J’ai du chercher une nouvelle image “ISO”, l’ancien CD ne pouvant pas faire l’install entièrement. Il bloquai à 77% du chargement des composants

Les problèmes sont quand même nombreux.Bon, pour le moment j’arrive à avoir le son, Mais je suis obligé après chaque démarrage de réactiver le controleur de volume qui revient à zéro systématiquement. Problème que j’avais déja avant. De plus, après remise à jour:

je ne retrouve plus ifconfig

ma connexion à internet arrive à ce bloquer

je peu constater dans les messages de démarrage que la carte eth0 a du mal à être activée. Et parfois, à l’ouverture de session je ne puis me connecté. Je suis en DHCP avec un routeur.

Dur dur de trouver une stabilitée en ce moment. Je n’ai pas encore eu le temps de tester la gravure, je vous tiendrai au courant pour savoir s’il y a de l’amélioration de ce côté.

Je suis sous Gnome, je ne pense pas que cela en soit la cause!! :laughing:

Par contre, j’ai eu la surprise de constater que OOo v2 a été intégré dans la config.

Jean :wink:


#2
  1. Pour ifconfig il faut être en root pour avoir accès à la commande. Si ça ne fonctionne toujours pas il faut installer ou reconfigurer le paquet net-tools.

  2. Quels sont exactement les messages (dmesg) renvoyés par la carte eth0.

  3. Pour le son essaie la commande #alsactl store question de savoir si la fonction de storage fonctionne.


#3

Bonsoir rdc,

Effectivement, ifconfig fonctionne sous root maintenant, alors qu’à l’installation avant mise à jour, la commande pouvait encore ce faire en simple user.

Pour la carte eth0 je dois redémarrer pour relever le message, j’ai l’impression que cela bloc uns fois sur trois.

Quand à #alsactl store:

mariniere:/home/jeantux# alsactl store
bash: alsactl: command not found

Sinon, j’ai installé à nouveau gnomebaker, mais toujours pas moyen de graver, ni d’effacer un disque réinscriptible.

J’en suis arrivé à me demander si je n’aurai pas intêret à installer la version stable en attendant que la unstasble soit un peu plus au point. Bon,là je suis sur un disque d’essai en attendant que mon disque 160 Go revienne de réparation. Alors, je fais encore quelques tests avant de me décider pour l’une ou pour l’autre. Ce qui est important pour moi, c’est de pouvoir utiliser openoffice v2 sur l’une ou l’autre distribution, car mes documents sont sous la version 2 et l’on ne peut les ouvrirs sous la version précedente.

Voila pour la petite histoire et merci pour ta réponse.

Jean
:wink:


#4

Pour la question des versions de Debian. Sur un poste de travail, tu peux très bien utiliser la version testing sans encombre. La testing est généralement déjà plus stable que la majorité des autre distributions Gnu/Linux officiellement stables. Les critères de Debian sont très élevés et la version stable est vraiment conçue pour un usage militarisé. Quant à la version SID (unstable) c’est vraiment préférable de ne pas trop jouer dans ce domaine sans être un vrai expert de Debian. La SID est constamment en mouvement et les règles changes rapidement. Dès que l’on utilise une SID on en vient rapidement à un problème de gestion des dépendances et c’est le crash assuré du gestionnaire de paquet. Habituellement, le tout se résume par un beau “segmentation fault” sur apt et c’est la panique totale et la réinstallation du système.

C’est un fait que vue le nombre de problèmes que tu as présentement le plus simple reste de réinstaller le système à partir d’un disque bien “Sarge” et ensuite upgrader doucement vers testing en modifiant le source.list et lancer la commande :

#aptitude dist-upgrade


#5

Ho, pardon, j’ai indiqué que j’utilisai la version unstable alors que je suis sous la testing.

Sinon, je ne me souviens plus, en partant de la stable, on peu revenir façilement à testing ou c’est l’inverse ?

Voici le résultat de dmesg pour eth0

[quote] eth0: Identified chip type is ‘RTL8169s/8110s’.
eth0: RTL8169 at 0xf8966000, 00:0d:61:7c:9b:24, IRQ 209
ACPI: PCI Interrupt Link [APC3] enabled at IRQ 18
ACPI: PCI Interrupt 0000:01:06.0[A] -> Link [APC3] -> GSI 18 (level, high) -> IR Q 217
eth1: RealTek RTL8139 at 0xa000, 00:30:bd:1a:fd:c1, IRQ 217
eth1: Identified 8139 chip type 'RTL-8139C’
Intel 810 + AC97 Audio, version 1.01, 12:46:38 Sep 27 2005
8139cp: 10/100 PCI Ethernet driver v1.2 (Mar 22, 2004)
usb 1-2: new full speed USB device using ohci_hcd and address 2
Adding 979924k swap on /dev/hda6. Priority:-1 extents:1
EXT3 FS on hda1, internal journal
ieee1394: Host added: ID:BUS[0-00:1023] GUID[00308d0236bd3f1d]
ieee1394: Node added: ID:BUS[0-01:1023] GUID[00308d023ebd3f1d]
eth1394: $Rev: 1247 $ Ben Collins bcollins@debian.org
eth1394: eth2: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
eth1394: eth3: IEEE-1394 IPv4 over 1394 Ethernet (fw-host1)
ieee1394: Host added: ID:BUS[1-00:1023] GUID[000d6100006c7760]
SCSI subsystem initialized
sbp2: $Rev: 1219 $ Ben Collins bcollins@debian.org
kjournald starting. Commit interval 5 seconds
EXT3 FS on hda5, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
NET: Registered protocol family 17
r8169: eth0: PHY reset until link up
r8169: eth0: PHY reset until link up
r8169: eth0: PHY reset until link up
r8169: eth0: PHY reset until link up
r8169: eth0: PHY reset until link up
r8169: eth0: PHY reset until link up
NET: Registered protocol family 10
Disabled Privacy Extensions on device c030c060(lo)
IPv6 over IPv4 tunneling driver
nvidia: module license ‘NVIDIA’ taints kernel.
ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [APC4] -> GSI 19 (level, high) -> IR Q 201
NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7174 Tue Mar 22 06:44: 39 PST 2005
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:02:00.0 into 8x mode
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:02:00.0 into 8x mode
r8169: eth0: PHY reset until link up
eth0: no IPv6 routers present
r8169: eth0: PHY reset until link up
r8169: eth0: PHY reset until link up
NTFS driver 2.1.22 [Flags: R/O MODULE].
NTFS volume version 3.1.
r8169: eth0: PHY reset until link up[/quote]

Merci de m’indiquer si tu vois une possibilité d’améliorer quelques choses.

Jean :wink:


#6

Oui, je viens de voir plusieurs petites choses. Mais je dois sortir pour l’instant donc, je repasserai un peu plus tard.


#7

Tu dois avoir /sbin dans ton PATH:

burp:~# which ifconfig /sbin/ifconfig burp:~#
Pour alsactl, tu dois installer le package alsa-utils:

burp:~# apt-file search alsactl alsa-utils: usr/sbin/alsactl alsa-utils: usr/sbin/alsactl alsa-utils: usr/share/man/man1/alsactl.1.gz alsa-utils: usr/share/man/man1/alsactl.1.gz burp:~#

Pour vérifier que ton graveur est bien reconnu:

[code]burp:~# cdrecord -scanbus dev=ATA
Cdrecord-Clone 2.01.01a01 (i686-pc-linux-gnu) Copyright © 1995-2004 J\uffffrg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
and thus may have bugs that are not present in the original version.
Please send bug reports and support requests to cdrtools@packages.debian.org.
The original author should not be bothered with problems of this version.

cdrecord: Warning: Running on Linux-2.6.14perso-20-12-05
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
scsidev: 'ATA’
devname: 'ATA’
scsibus: -2 target: -2 lun: -2
Warning: Using badly designed ATAPI via /dev/hd* interface.
Linux sg driver version: 3.5.27
Using libscg version ‘schily-0.8’.
scsibus1:
1,0,0 100) 'TDK ’ 'DVDRW0404N ’ ‘1.08’ Removable CD-ROM
1,1,0 101) *
1,2,0 102) *
1,3,0 103) *
1,4,0 104) *
1,5,0 105) *
1,6,0 106) *
1,7,0 107) *
burp:~#[/code]

Ca serait bien, surtout si tu commences sur Debian… :wink:

Non, non pas besoin ! Il faut juste que /sbin soit dans le PATH de l’utilisateur ou alors préciser le chemin de la commande:

[code]jeannot@teloche:/freevo/TV$ /sbin/ifconfig eth0
eth0 Lien encap:Ethernet HWaddr 00:02:B3:CC:E4:2D
inet adr:192.168.0.10 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::202:b3ff:fecc:e42d/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8805400 errors:4 dropped:0 overruns:0 frame:4
TX packets:24480318 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:602087099 (574.1 MiB) TX bytes:2329155642 (2.1 GiB)

jeannot@teloche:/freevo/TV$ [/code]

Pour voir et détecter les caractéristiques de ton matos, installes les outils suivants:
pciutils usbutils hwtools scsitools discover kudzu hdparm (je les ai plus tous en tête …)

Voilà bonne nuit
:wink:


#8

Racontes pas de conneries, sinon je te présente la délicieuse princesse Lea. Je te taquine! :laughing:

Si le paquet net-tools n’est pas installé ou bien défectueux pour quelques raisons. Même si tu PATH l’user ça ne fonctionneras pas. D’autre part, ce n’est pas très sécuritaire de permettre aux users d’accèder au /sbin. Certes que sur un poste de travail à la maison c’est moins grave mais c’est quand même ouvrir la porte au système.


#9

Pour en revenir aux cartes réseau

D’après le dmesg je vois que la machine possède deux cartes eth0 et eth1. La carte eth0 renvoie le message r8169: eth0: PHY reset until link up ce qui n’est pas normal. J’ai jeté un coup d’oeil rapide sur le net mais je n’ai rien trouvé. Si tu n’utilise pas les deux cartes peut-être simplement penser à utiliser eth1 en dhcp. il suffit de modifier le fichier /etc/network/interfaces et de relancer le réseau par la commande /etc/init.d/networking restart


#10

:open_mouth:
Euh… Tu en connais beaucoup toi des distribs qui sont capables de fonctionner correctement sans un outil de base tel que ifconfig ?
En tout cas, en X années passées sous divers unix ou linux, je n’ai JAMAIS rencontré d’installation fonctionnant sans les outils de gestion réseau…
Pour tout dire, il est même probable que Xwindow refuse carrément de démarrer, ou alors démarre de travers … Xwindow étant un logiciel client-serveur, il a forcément besoin d’une couche réseau minimale pour démarrer correctement, donc au minimum ça:

[code]luciole:~# ifconfig lo
lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14900 errors:0 dropped:0 overruns:0 frame:0
TX packets:14900 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:19746785 (18.8 MiB) TX bytes:19746785 (18.8 MiB)

luciole:~#[/code]
Si au minimum cette interface là n’est pas RUNNING, dans le meilleur des cas, ton Xwindow tournera extrêmement lentement.

Mais bon, je t’accorde au moins ce point là: il se peut que le paquet net-tools soit dans un état bizarre…

Sinon, la princesse Leïa, je veux bien (quoique elle doit avoir veilli, depuis le temps … ou peut-être Amidala ?)

Ca, c’était pas vraiment utile de le préciser, hein …


#11

Bien, je viens de refaire deux installations, sur 2 disques différents, l’un avec testing, l’autre avec stable.
La stable fonctionne impécable avec OOoV2 installé.
La testing, c’est encore pire qu’hier. Bon, peut être à cause de paquets qui ne sont pas installés. Je n’ai pas xscreensaver, toujours pas de son et pas d’internet.
C’est pas mal, je fais une netinstall, après je n’ai plus de net ???

J’ai constaté grace à ifconfig, qu’il me manquait la ligne inet. Je l’ai rajouté avec la commande route, pas de changements. Je l’ai configuré avec une adresse statique, pareil, je ne ping même pas le routeur. :cry:

Le pire, c’est que la je n’ai aucune connexion même en redemarrant, contrairement à hier.

Bizare bizare. :confused:

Bon, d’accord, c’est une bonne façon d’apprendre, mais j’ai le paquets?

Je vais tacher de m’y remettre après la diner.

Courage, courage :laughing:

Jean :wink:


#12

Oublies la testing pour l’instant, tu ferais mieux d’y revenir plus tard, quand tu maîtrisera les base.

Ce n’est pourtant pas le choix qui manque :

[quote]xscreensaver - Automatic screensaver for X
xscreensaver-gl - GL(Mesa) screen hacks for xscreensaver
xscreensaver-gnome - transition package for xscreensaver
xscreensaver-nognome - transition package for xscreensaver
ksetisaver - Seti screensaver for KDE
kscreensaver - additional screen savers released with KDE
kscreensaver-xsavers - KDE hooks for standard xscreensavers[/quote] :laughing:

Toute la configuration réseau se trouve là:

burp:/etc/network# pwd /etc/network burp:/etc/network# ls if-down.d if-post-down.d if-pre-up.d if-up.d interfaces options run burp:/etc/network#
Lis bien les man pages, en particulier pour le fichier interfaces, tout est expliqué. C’est la meilleure manière d’apprendre…
Un truc: Pour lire les man pages confortablement tu lances konqueror et tu colles par exemple: “man:interfaces” dans la barre d’URL, tu m’en diras des nouvelles :wink:


#13

Je pense que tu as raison, je vais rester sous la version stable.

J’ai copier le fichier /etc/network/interfaces de la stable et ajouté à la testing, mais rien n’y fait, pas moyen de se connecter, diffile dans ce cas de régler le reste.

Sinon, en attendant le retour de réparation de mon disque finale je vais continué de me documenter, pour le cas ou j’aurai une solution. :wink:

Jean :laughing:


#14

J’ai trop bu ou ta carte est un rt 8139 et le module que tu charges 8169 ???


#15

Non, tu n’as pas trop, du moins, je l’espère. :laughing:

Mais effectivement, je possède deux cartes Ethernet sur mon PC. L’une eth0 rt 8139
L’autre dont je ne me sers pas 1 gigabyte 8169.

Il aurait donc chargé le module de l’autre lors de l’update ?
Comment dois je faire pour changé cela, si tel est bien la cause ?

Je retourne sur l’autre disque pour voir cela de plus prèt. Heureusement, il me reste une connexion sur le portable au cas ou.

Jean :wink:


#16

Si je ne me trompe pas la rtl8169 est intégré au motherboard. Si elle ne sert pas il serait bon de la désactivé dans le bios. Cela t’aidera à t’y retrouver plus facilement.


#17

Ca y est, c’est tout bon, j’ai réussis à me connecter.

C’est vrait, à un moment donnéj’avais désactiver ma carte intégrée par le bios, je ne sais pourquoi je l’ai réactivé, mais comme je n’avais pas de problème j’ai fini par la laisser ainsi.

En attendant, je vous remercie, je vais pouvoir continuer l’installation du reste. :laughing:

Jean :smiley:


#18

C’est quoi une motherboard ? Je connais que les Funboard… Ah, la plage et un petit mistral…

J’ai une carte rt8169 et elle marche extraordinairement bien. Je n’ai jamais vu une carte réseau marcher aussi bien. Et en plus, elle n’est pas chère.


#19

motherboard : Carte mere :slightly_smiling:


#20

Ah oui, alors ça flotte pas… :confused: