Lecteur DVD externe ne fonctionne pas

Bonjour
Le lecteur DVD interne de mon vieil ordinateur (Asus Pro de 2009, Bullseye) ne fonctionne plus alors j’ai acheté un lecteur externe mais pas plus de résultat sur les CD audio . Un DVD video a marché une fois ou 2 . Pourtant ce lecteur externe fonctionne normalement sur une autre machine (HP de 2011windows 10) Pensant à un problème d’alimentation j’ai acheté un câble double branché sur 2 ports USB, sans résultat.
Que faut il investiguer en console pour faire un diagnostic ?
Merci

salut*
"ne marche pas " n’est pas assez précis :

  • pas de lumière ?
  • pas de bruit au démarrage dde la machine
  • pas de réaction sur la touche eject
  • pas de résultat à dmesg |egrep 'sr0|cdrom'
  • quelle marque
  • qu’est-ce que câble double branché sur 2 ports USB
  • quel résultat à mkdir -p /media/cdrom && mount -t iso9660 /dev/sr0 /media/cdrom
  • stretch, buster,bullseye ?

Alors, ce genre de câble, sur le papier, c’est une bonne idée, mais il faut connecter les deux prises sur deux ports qui ne sont pas sur la même ligne d’alimentation, sinon, ça n’a aucun intérêt. Ce que tu peux essayer avec ce genre de câble, c’est que connecter les données aux PC et l’alimentation sur un chargeur qui fourni un port USB, tu sauras si le problème vient effectivement de l’alimentation du port USB ou d’autre chose.

En réalité c’est une mauvaise idée car sur le papier, un port USB n’est pas censé délivrer plus de 100 mA si on ne le lui demande pas explicitement via le bus de données. Or la seconde fiche A n’a pas de fils de données et ne peut donc rien demander. Sur le papier donc, on peut espérer au mieux 500 mA sur le port connecté à fiche principale (qui a les fils de données) et 100 mA sur celui connecté à la fiche secondaire qui n’a que les fils d’alimentation, soit 600 mA en tout.

Heureusement (ou pas), en pratique, il est rare que les ports USB limitent le courant à ce qui a été négocié avec le périphérique.

Oui, c’est ce que je disais, les lignes d’alimentation des ports USB sont communes.
Ce qui fait que, soit tu as une ligne commune et le brancher sur deux ports n’apporte rien de plus, soit le port gère la limitation de courant par port et tu n’as que 100 mA de plus.
D’où mon idée de connecter la fiche supplémentaire sur un chargeur USB externe.

Tu l’as déjà fait ? Ça a le défaut d’injecter la tension de sortie du chargeur sur les bornes d’alimentation du port USB de l’ordinateur qui est conçu pour fournir du courant mais pas forcément pour en recevoir, ce qui pourrait l’endommager.

Autre possibilité : intercaler un hub USB ayant sa propre alimentation et ne limitant pas le courant sur ses ports.

Bonjour
@dindoun : je suis sous Bullseye

  • lecteur marque RoHS Pop-up Mobile External DVD
  • le lecteur est détecté et listé dans Thunar sous le nom du DVD
  • je peux le démonter et l’éjecter puis le remettre il se monte automatiquement
  • j’ouvre le répertoire et la liste des videos s’affiche video TS 01, 02 etc.
  • ça fonctionne avec certains DVD et pas avec d’autres
  • ouverture avec VLC : VLC s’afiche mais il ne se passe rien, j’entends le lecteur se lancer puis stopper en boucle
  • ouverture avec le lecteur Parole : Parole s’affiche mais j’ai un message « erreur du moteur Gstreamer »

Le câble branché en double : j’avais lu ça dans un vieux fil . Sur la machine Windows où ça fonctionne comme dit au début, le câble en double ou en simple a le même résultat ok

Résultats des commandes :

  • avec un DVD qui fonctionne :
joel@joel-k70ij:~$ sudo dmesg |egrep 'sr0|cdrom'
[    3.002369] sr 1:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    3.002372] cdrom: Uniform CD-ROM driver Revision: 3.20
[    3.064521] sr 1:0:0:0: Attached scsi CD-ROM sr0
joel@joel-k70ij:~$ 
joel@joel-k70ij:~$ sudo mkdir -p /media/cdrom && mount -t iso9660 /dev/sr0 /media/cdrom
mount: /media/cdrom0: seul le superutilisateur peut utiliser mount.
joel@joel-k70ij:~$ 
  • avec un DVD qui ne fonctionne pas
joel@joel-k70ij:~$ sudo dmesg |egrep 'sr0|cdrom'
[    3.002369] sr 1:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    3.002372] cdrom: Uniform CD-ROM driver Revision: 3.20
[    3.064521] sr 1:0:0:0: Attached scsi CD-ROM sr0
joel@joel-k70ij:~$ 
joel@joel-k70ij:~$ sudo mkdir -p /media/cdrom && mount -t iso9660 /dev/sr0 /media/cdrom
mount: /media/cdrom0: seul le superutilisateur peut utiliser mount.
joel@joel-k70ij:~$ 
  • avec un CD audio (ne fonctionne jamais) : message « l’emplacement n’est pas montable »
joel@joel-k70ij:~$ sudo dmesg |egrep 'sr0|cdrom'
[sudo] Mot de passe de joel : 
[    3.002369] sr 1:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    3.002372] cdrom: Uniform CD-ROM driver Revision: 3.20
[    3.064521] sr 1:0:0:0: Attached scsi CD-ROM sr0
joel@joel-k70ij:~$   
joel@joel-k70ij:~$ sudo mkdir -p /media/cdrom && mount -t iso9660 /dev/sr0 /media/cdrom
[sudo] Mot de passe de joel : 
mount: /media/cdrom0: seul le superutilisateur peut utiliser mount.
joel@joel-k70ij:~$ 

pourtant j’indique bien le mot de passe habituel

Il faut exécuter mount en tant que root si on utilise des paramètres différents (type, point de montage ou options) de ceux définis dans /etc/fstab avec l’option user. sudo ne s’applique pas à ce qui suit &&.
Les DVD vidéo sont au format UDF et non ISO9660, il vaut mieux ne pas forcer le type et laisser mount l’auto-détecter.
Un CD audio standard (CDDA) n’est pas un système de fichiers, ça ne se monte pas.

désolé
évidemment il faut soit être en root soit metrte sudo devant mount :
la phrase « seul le superutilisateur peut » signifie exactement cela.

Pour l’histoire du udf/ccda je ne ĉonnais pas trop

Reprenons :

après avoir un mis un dvd , Ca se monte tout seul chez moi avec rien dans le fstab ( essayé dans buster )

[ 4761.635840] UDF-fs: INFO Mounting volume 'Projet sans titre', timestamp 2021/06/24 06:13 (1000)

df -h
/dev/sr0           4,4G    4,4G     0 100% /media/dindoun/Projet sans titre

ls /media/dindoun/Projet\ sans\ titre/
VIDEO_TS

Peut etre te manque-t-il un programme ;
udftools dvd+rw-tools genisoimage gvfs-backends

je peux te conseiller ma page où tu installes tout ou ce qu’il te faut :

tu peux aussi regarder dans ton settings ( mate , cinnamon …) et regarder ce que tu as dans les applications préférées

A noter que, comme suggéré par pascal hambourg on peut simplement écrire
mount /dev/sr0 /media/cdrom

bien que chez moi,

mount -t iso9660 /dev/sr0 /media/cdrom

et

mount -t udf /dev/sr0 /media/cdrom

marchent tous les deux pour le même dvd ( en iso9660 je suis en minuscules et en majuscules sur udf )

Bonjour
J’avoue que je me perds un peu dans les réponses
Essayons de procéder au cas par cas :
CD audio : ils sont bien détectés dans Thunar mais comme on peut voir le message s’affiche quelle que soit la demande : monter, ouvrir par clic droit ou double clic

Suite
je lance « Lecteur Parole » "lire le disque « Disque audio » j’obtiens le message " erreur du moteur Gstreamer "
je lance lecteur VLC puis tente d’ouvrir Disque audio , le résultat est : « emplacement non montable »
par curiosité je suis allé voir les partitions, le CD n’est pas détecté, n’apparaît pas non plus dans les périphériques

udftools dvd+rw-tools genisoimage ne servent à rien pour lire des CD et DVD.
Eventuellement gvfs peut être utile pour traiter les pistes de CD audio comme des fichiers ordinaires, mais je n’ai pas creusé le sujet.

Je répète qu’un CD audio n’est pas utilisable tel quel comme un périphérique bloc ni un système de fichiers. Ça ne se monte pas, ça ne se copie pas avec dd, ça ne se gère pas avec un éditeur de table de partition.

c’est bien toi qui parle d’udf
et le but est d’aider quelqu’un , je ne vois pas en quoi tes réponses aident; ne me répond pas réponds lui
et penser aux problèmes futurs est ma façon de penser

Bonsoir
J’ai utilisé le lecteur sur l’autre machine Windows, mais je voudrais bien le faire marcher avec ma bonne Bullseye, alors je relance le fil
Déjà régler le problème DVD, certains fonctionnent et d’autres non

merci

C’est censé montrer quoi ? Les deux captures ont exactement le même contenu avec la même commande erronée qui ne montre strictement rien dans les deux cas.

Désolé, alors je m’exprime mieux : puisque certains DVD marchent et d’autres non, comment trouver la différence qui compte : est-ce dû aux DVD eux mêmes ou à un paramétrage sur ma machine ? Une commande plus pertinente existe probablement ?
Merci

Dans Synaptic je vois installés plusieurs gvfsmais pas tous

Bonsoir,

Te manquerait-il le paquet libdvd-pkg, qui installe les bibliothèques requises pour lire certains DVD du commerce ?

A+

Je répète ce que j’ai déjà écrit mais qui est peut-être passé inaperçu :

voici le fichier /etc/fstab ouvert avec la commande sudo mousepad /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=a94b48c7-aa30-434d-b693-f43818f3a442 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda6 during installation
UUID=55d16a7c-24b1-4bbf-8a45-ab1b26199f9a /home           ext4    defaults        0       2
# swap was on /dev/sda5 during installation
UUID=bcf38a59-ad05-483e-ba2a-9f6697c64dcc none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

merci