Lecteur fichiers midi sous Sarge :


#1

Bonjour,

Ca faisait un petit moment que je n’avais pas rencontré de problème depuis l’installation de ma Sarge avec noyau 2.6.8, mais voilà : je n’arrive pas à sortir un son midi de mes HP.
Après le boot, quand je lance la lecture d’un fichier midi (avec kmid par défaut), j’ai un message d’erreur me disant qu’il est impossible d’ouvrir /dev/sequencer (en effet, ça n’existe pas).
Après lancement de la commande modprobe snd-virmidi, je n’ai plus ce message d’erreur, mais la lecture ne produit aucun son. Je n’ai aucun message d’erreur.

# lsmod | grep midi snd_virmidi 4740 0 snd_seq_virmidi 7680 1 snd_virmidi snd_seq_midi 8608 0 snd_seq_midi_event 7936 3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi snd_seq 53648 6 snd_seq_virmidi,snd_seq_oss,snd_seq_midi,snd_seq_midi_event snd_rawmidi 25316 4 snd_seq_virmidi,snd_seq_midi,snd_emu10k1,snd_mpu401_uart snd_seq_device 8264 4 snd_seq_oss,snd_seq_midi,snd_emu10k1,snd_rawmidi snd 57380 22 snd_virmidi,snd_seq_virmidi,snd_seq_oss,snd_seq_midi, snd_seq_midi_event,snd_seq,snd_emu10k1,snd_util_mem, snd_hwdep,snd_via82xx,snd_ac97_codec,snd_pcm_oss, snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart, snd_rawmidi,snd_seq_device
J’ai vérifier les niveaux sonores avec alsamixer et kmixer, tout est à fond.
J’ai fouillé sur le groupe et sur le net, je n’ai pas encore été capable de trouver l’info pertinente pour arriver à mes fins.
Des idées ?


#2

Moi aussi, je souffre régulièrement avec la configuration du son … :frowning:

Mais:

Tu utilises des outils dédiés à alsa et on dirait que tes modules chargés sont des modules OSS, non ?


#3

Non, justement. Les modules commençant par “snd” sont les modules alsa


#4

En fait, moi pas trop avec Sarge (par contre, avec knoppix, c’était Rock N’ Roll, MatOtop doit s’en rappeler !!), j’ai eu de la chance jusque là, juste le midi qui m’ennuie et il y a quelques temps des soucis d’enregistrement des paramètres alsa sous Gnome (pas de problème sous KDE).

[quote=“Jabba”]Mais:

Tu utilises des outils dédiés à alsa et on dirait que tes modules chargés sont des modules OSS, non ?[/quote]
Normalement non, mais je n’en suis pas certain. Comment puis-je le vérifier ?


#5

Essaye avec apt-get install timidity freepats timidity /où/est/ton_fichier.mid
et dis nous si ça marche, s’il te plait.


#6

[quote=“pocrave”]Essaye avec apt-get install timidity freepats timidity /où/est/ton_fichier.mid
et dis nous si ça marche, s’il te plait.[/quote]
Super, ça marche :slightly_smiling:
Par contre, sous kmid, toujours aucun son ni message d’erreur :frowning:
NB : timidity était déjà installé car j’avais lu un fil sur les pb midi sur ce forum, où MatOtop en conseillait l’installation. freepats ne l’était pas par contre.


#7

[quote=“Korben Dallas”]
Par contre, sous kmid, toujours aucun son ni message d’erreur :frowning:[/quote]
Je n’ai toujours pas résolu ce problème :imp:
Des idées ?


#8

Finalement le midi ne fonctionne pas sur sarge?
J’aimerais bien utiliser Kguitar, mais j’ai des problème de midi toujours ce message “Error opening MIDI device!”.
Quelqu’un connait’il la solution.

Bien entendu comme Korben dallas kmid ne fonctionne pas.


#9

[quote=“dmon”]Finalement le midi ne fonctionne pas sur sarge?
J’aimerais bien utiliser Kguitar, mais j’ai des problème de midi toujours ce message “Error opening MIDI device!”.
Quelqu’un connait’il la solution.

Bien entendu comme Korben dallas kmid ne fonctionne pas.[/quote]

Ouep, meme soucis…