Lenteur connexion sous X


#1

Salut ,
Je rame autant que mon micro au lancement de Gnome, :imp:
Pour accelerer la connexion je dois bidouiller en console en stoppant -redemarrant les services :open_mouth:

  • networking.
  • hotplug
    En mode console je pedale a 60 k en apt-get update. Donc mon probleme est - je pense - lie a X ou autre - fichier host - oujesaispas.
    une fois logge et les services ok, tout fonctionne au poil…

Je touille en rond apres des heures - je devrais dire des jours - de recherche sur le oueb…
Si quelqu un a une solution a me proposer je suis preneur…

Je suis en Sarge kernel 2.6.7-1- i386
modem cable sur port usb…en 512 k - petite precision, sous windaube ma connexion fonctionne -

AU SECOURS … :blush:


#2

C’est souvent un problème de configuration réseau il me semble…

/etc/hosts
/etc/resolv.conf
et attention à:
/etc/nsswitch.conf

ping hostname de ta machine
ping localhost
ping adresse IP de ta machine
ping 127.0.0.1 (loopback)

Les miens en exemple:

burp:~# cat /etc/hosts
127.0.0.1 localhost
192.168.0.2 burp.cave.maison burp

burp:~# cat /etc/resolv.conf
search cave.maison
nameserver 192.168.0.1

burp:~# cat /etc/nsswitch.conf

/etc/nsswitch.conf

Example configuration of GNU Name Service Switch functionality.

If you have the glibc-doc' andinfo’ packages installed, try:

`info libc “Name Service Switch”’ for information about this file.

passwd: compat
group: compat
shadow: compat

hosts: files dns
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis
burp:~#

Quand tu es connecté, tu as une route par défaut ?

burp:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
default smoothwall 0.0.0.0 UG 0 0 0 eth0
burp:~#


#3

Salut Jabba,
merci pour tes conseils

***mon fichier hosts

127.0.0.1 localhost.localdomain localhost debian

The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


Je pige pas…le ping de 127.0.0.1 , localhost, debian, etc … marche pas !!!

****resolv.conf

debian:/etc# more resolv.conf
search
nameserver 81.220.255.4
nameserver 80.236.0.68
nameserver 80.236.0.73

tous les pings OK

******nsswitch.conf pareil que toi

[color=darkred]******** route me donne
[/color]

Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
82.216.232.0 * 255.255.254.0 U 0 0 0 eth0
default ip-1.net-82-216 0.0.0.0 UG 0 0 0 eth0

******* mon fichier /etc/network/interfaces

The loopback network interface

auto eth0
iface eth0 inet dhcp

Apparemment, comme tu dis mon prob vient de la conf reseau.
Le fait de pas pouvoir pinger en local en 127.0.0.1 confirme ton diagnostic…
Je vois pas de ou cela vient - j ai aussi des prob de conf clavier !!! - impossible avoir keyboard in French, mais bon c est pas mon prob principal - :laughing:
A l instal - j en suis a 7 ou 8 - a la premiere connexion, pas de prob, c est au reboot que cela se gate…j ai du rater quelque chose dans la config d install, mais quoi ???
Si tu as la solution, n hesite pas a me la donner, je t en remercierai eternellement …
:wink:


#4

Hello,

burp:/etc/network# cat interfaces

/etc/network/interfaces – configuration file for ifup, ifdown

The loopback interface

auto lo
iface lo inet loopback

–> tout ca me semble un peu … vide ! :slightly_smiling:

Le mien:

The first network card - this entry was created during the Debian installation

(network, broadcast and gateway are optional)

auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
burp:/etc/network#

–> Essayes les commandes ci-dessous:
Pour reconfigurer tout ca avant toucher aux fichiers

burp:/etc/network# ifconfig lo0
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:560 (560.0 b) TX bytes:560 (560.0 b)

->il DOIT y avoir au minimum:

inet addr:127.0.0.1
UP LOOPBACK RUNNING

->sinon:

ifconfig lo0 down
ifconfig lo0 127.0.0.1 netmask 255.0.0.0 up

->puis recontrôler avec ifconfig lo0

-> pour eth0 (une adresse quelconque … en général pour un réseau privé: 192.168.x.x)

burp:/etc/network# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:60:08:E3:CC:2F
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:55256 errors:0 dropped:0 overruns:0 frame:0
TX packets:31331 errors:0 dropped:0 overruns:0 carrier:0
collisions:322 txqueuelen:1000
RX bytes:75911105 (72.3 MiB) TX bytes:2205971 (2.1 MiB)
Interrupt:5 Base address:0xa000

burp:/etc/network#

ifconfig eth0 down
ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up

ensuite, tu mets tout ca dans /etc/hosts sous la forme:

192.168.0.2 burp.cave.maison burp

–> ceci dit, tu n’as en principe pas besoin d’avoir eth0 actif pour que XWindow fonctionne correctement
seule l’interface loopback suffit.

apparement, ta route par défaut passe par eth0 qui n’est pas actif !

Quand tu est sur Internet, tu est connecté via un modem ?

Si c’est par modem alors:

route add default gw IP-adresse ppp0

et connecté à internet, le nslookup marche ?

burp:/etc/network# nslookup sun.com
Note: nslookup is deprecated and may be removed from future releases.
Consider using the dig' orhost’ programs instead. Run nslookup with
the `-sil[ent]’ option to prevent this message from appearing.
Server: 192.168.0.1
Address: 192.168.0.1#53

Non-authoritative answer:
Name: sun.com
Address: 209.249.116.195

burp:/etc/network#

Pour reconfigurer tout ca à la méthode Linux (je connais mieux Solaris que linux…), il y a des scripts
du genre dpkg-reconfigure package_name. Il me semble que tout package Debian peut se reconfigurer
de cette manière (il y a des spécialistes Debian dans la salle, please ? )

Pour descendre et remonter les interfaces réseau, ifdown et ifup je crois.
Pour redémarrer TOUS les services réseaux sans rebooter: /etc/init.d/networking stop puis start

A moins que tu veuilles utiliser IPV6 tu peux virer tout ce bazar:

The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

de ton /etc/hosts

Il est bien possible qu’à l’install de ton système tu aies oublié de charger le module de ta carte réseau.
Est-ce que la procédure d’install t’a demandé les paramètres réseau ?
Si c’est non, tu as loupé une étape.

quand tu monte ton interface réseau ifconfig eth0 … up, ouvres un 2ème terminal et tu tapes dedans: tail -f /var/log/messages
C’est extrêmement instructif ! :slightly_smiling:

dmesg | less peut aussi t’aider …

Dans tous les cas, ton interface lo0 DOIT impérativement fonctionner !!!
Voilà, j’espère que ca t’aidera …
Bon courage !

Jabba


#5

J’avais oublié, pour le clavier c’est un truc du genre:

loadkeys fr_… (chez moi fr_CH)


#6

[color=darkred]Salut Jabba,
cela se complique …en tout cas pour moi…!!!

ifconfig lo0[/color]

lo Lien encap:Boucle locale
LOOPBACK MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

[color=darkred] # ifconfig lo0 down[/color]

lo0: ERROR while getting interface flags: Aucun périphérique de ce type

[color=darkred]#ifconfig lo0 127.0.0.1 netmask 255.0.0.0 up 

[/color]SIOCSIFADDR: Aucun périphérique de ce type

[color=darkred] Par contre sans rien modifier:


ifconfig eth0[/color]

eth0 Lien encap:Ethernet HWaddr 00:10:95:D8:67:8B
inet adr:82.216.233.67 Bcast:82.216.233.255 Masque:255.255.254.0
adr inet6: fe80::210:95ff:fed8:678b/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2379139 errors:0 dropped:0 overruns:0 frame:0
TX packets:6252 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:136541204 (130.2 MiB) TX bytes:518213 (506.0 KiB)


# nslookup sun.com
bash: nslookup: command not found


Effectivement à l’install de Debian ( avec le nouvel installer pour la 3.1.R1 en linux26 ) le menu me demande de configurer ma carte réseau.
Le prob est que j’ai un modem-cable sur port USB, et pas de carte réseau, je ne peux donc pas le déclarer lors de l’instal, donc je prends le choix sans carte réseau.
J’avais le meme prob avec la 3.0, il suffisait alors de configurer le /network/interfaces , comme mon mien ci-dessus, et ça se dépatouillait tout seul ( sans que je me pose de questions et sans lenteur de connexion )
J’ai donc fait la meme config pour la 3.1.R1.
A force de ‘rincer’ et de réinstaller en reformatant et repartitionnant, je peux me tromper, mais il me semble qu’à la première install, j’avais pas eu ce souci de lenteur ( j’avais fait l’install complète en Anglais, mais ça n’a surement aucun rapport ).
Je n’ai surement pas tout compris, mais avec la 3.1.R1, le menu de reconf est : base-config et d’après ce que j’en ai vu, ne permet pas de re-modifier les modules noyau meme en dynamique ( j’avais installé ‘modconf’ qui ne fait plus partie du nouveau package, pour y accéder, mais apparemment ça semait la zone dans le noyau 2.6.7 ) ,
En tout cas, merci pour ton aide, je poursuis mes investigations et te tiens au courant de mon feuilleton …à suivre…


#7

Houlà ! C’est que je n’ai jamais installé de machine sans connexion réseau moi … :frowning:
Pour une pile TCP/IP minimum, il faut au moins sélectionner IPV4 dans les options d’installation, je ne sais plus où ca se trouve.

Ensuite, quand il te demandes les paramètes réseau, essayes de mettre des trucs bidon et je pense qu’il devrait au moins monter une interface lo0, il me semble que sous linux, l’interface lo0 n’est pas dépendante d’une carte réseau physique. Mais je n’en suis absolument pas sûr alors il faudrait vérifier.

Un chose est sûre, Xwindow est un logiciel client-serveur et n’importe quel soft de ce type à besoin d’une interface réseau pour fonctionner correctement et lo0 est justement destiné (entre autres) à cet usage…

Ensuite, pendant l’installation, il faut choisir dans la section USB des modules, celui qui correspond le mieux à ton matos.
Choisir “linux bf24” au démarrage de l’install, c’est dans cette version que l’USB est le mieux supporté.

Tu pourras toujours reconfigurer ton modem USB après l’install.

A+

Jabba

PS: pour le clavier --> dpkg-reconfigure console-data


#8

[color=darkred]Salut Jabba,
Heu, réinstaller avec le noyau 2.4 ??? je préfère pas …
j’ai eu pas mal de soucis avec la partie son + USB avec le 2.4 et Debian 3.0…

Je sais pas trop ce que ça donnerait avec la Sarge 3.1.R1…
J’en suis à 8 réinstalls…je commence à fatiguer :wink:

Effectivement j’ai un blême avec la partie réseau:

dmesg| grep IP[/color]

IP: routing cache hash table of 2048 buckets, 16Kbytes
IPv6 over IPv4 tunneling driver
eth0: no IPv6 routers present
eth0: no IPv6 routers present

#ifconfig -a
eth0 Lien encap:Ethernet HWaddr 00:10:95:D8:67:8B
inet adr:82.216.233.67 Bcast:82.216.233.255 Masque:255.255.254.0
adr inet6: fe80::210:95ff:fed8:678b/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:938837 errors:0 dropped:0 overruns:0 frame:0
TX packets:6488 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:153026815 (145.9 MiB) TX bytes:504251 (492.4 KiB)

lo Lien encap:Boucle locale
LOOPBACK MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

sit0 Lien encap:IPv6-dans-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)


s# netstat -nr

Table de routage IP du noyau
Destination Passerelle Genmask Indic MSS Fenêtre irtt Iface
82.216.232.0 0.0.0.0 255.255.254.0 U 0 0 0 eth0
0.0.0.0 82.216.232.1 0.0.0.0 UG 0 0 0 eth0

Pour le clavier…c’était tout bêtement le type de clavier en US dans la config du bureau de gnome
:blush:

A suivre …


#9

Ben voilà, on dirait que ca avance :slightly_smiling:

Tu as déjà retrouvé lo0 et eth0 (quand le modem est démarré ?)

sit0 c’est pour le modem ?
–> sit0 Lien encap:IPv6-dans-IPv4 (Houlà, que pour compliquer les choses !)

et eth0 ? --> inet adr:82.216.233.67 ca ressemble à une adresse externe ca… Celle de ton FAI, je pense ?

D’après ta commande netstat, tout ton traffic est redirigé sur eth0, donc j’en déduis qu’il s’agit de ton interface modem.

Il faudrait encore trouver le moyen d’assigner une adresse IP à to lo0.

Et surtout virer la partie IPV6 que tu ne vas pas utiliser, une source d’erreurs potientielle …

Tu devrais pouvoir refaire toute ta config réseau sans forcément faire une réinstall. complète.

8 réinstall. c’est claire que ca doir commencer à lasser mais après tu auras la satisfaction de SAVOIR POURQUOI CA MARCHE !!! :slightly_smiling:))

C’est quoi ton modem USB ?

A+

Jabba


#10

Jabba,
j’en pleurerais ( presque ) sur l’IRC :
#debian-fr
Un King Linux- Debian " KAel " m’a donné THE SOLUTION !!!
Un bugg de l’installer Debian …
la solution ( ne me demande pas pourquoi, mais IL le sait LUI … )

dans /etc/interfaces :
il “suffisait” de rajouter:

auto eth0
iface eth0 inet dhcp

auto lo
iface lo inet loopback

Et roule ma poule …à fond les manettes …
:laughing:

Merci pour ton aide …


#11

Effectivement, si je regarde mon fichier, je l’ai aussi et j’avais pas vu qu’il n’y était pas chez toi …

The loopback interface

auto lo
iface lo inet loopback

Il ne t’as pas dit si c’est un bug qui se produit de façon aléatoire ? (en tout cas, je ne l’ai jamais eu chez moi …)

Eh ben tant mieux, le problème est réglé :slightly_smiling:
Bonne soirée et à la r’voyure !


#12

[color=darkred]Bonne soirée pareillement Jabba,…

Bon maintenant, faut que je voye comment on ferme le post sur le forum …

A+[/color]


#13

[color=red]Sorry Jabba,
j’avais pas tout lu ( l’émotion sans doutes :wink: )
Le Bugg n’est pas aléatoire, c’est un Bugg de la version Béta de l’installer …

A + [/color]