Links2 et SSL et TLS


#1

Bonsoir,
Merci d’abord voaiment bcp, car grace a votre aide, enfin
centericq a une bonne version, marche correctement.
Ce sera une super chose en attendant de passer [ la Sarge, qui me prendrait pour l’instant trop de temps.
J’ai aussi install& links2 grace [ backports sur une Woody. Ca va
mieux qu’avant, il veut bien ouvrir hotmail.com.
Reste un dernier pb: pourquoi quand je remplis mon
formulaire d’identification et l’envoie, Links me dit que “Cette version ne supporte pas SSL/TLS”?
Pourriez-vous me l’expliquer svp?
Et ai-je un moyen de parer [ cela (autre version, patch…)?
Merci bcp pour tout, et votre prochaine r&ponse, merci d’avance.
A+


#2

salut

a priori, le package links2 sous debian n’integre pas le support ssl/tls :confused: donc 2 possibilités :

  • essayer de trouver un backport avec le support SSL
  • compiler links2 a la main en integrant au ./configure --with-ssl=/usr/include/openssl , a condition d’avoir les headers de dev d’openssl

bon courage!


#3

Salut,
Ok merci pour l’info. J’ai cherch& sur backports.org, apparemment
ya pas de packages avec le support SSL/TLS (du moins j’ai pas trouv&).
Je vais devoir faire la deuxi\me solution: mais la c’est plus dur, je suis
pas tr\s pro en programmation.
D’autre part, j’ai install& openssl mais y a pas le r&pertoire /usr/include/openssl, ya que /usr/bin/openssl.
Est-ce q qqn pourrait me dire comment recompiler links2 [ la main avec le support SSL? Ou si c’est trop long, ou
je pourrais trouver de la doc la-dessus, histoire d’apprendre [ recompiler un programme en lui ajoutant des supports?
Faut t&l&charger quoi et ensuite, comment ca marche? J’arrive [ peine dans la programmation, j’y
connais rien j l’avoue.
Merci bcp pour tout.
A+
JP


#4

Salut

je viens de tester sur une woody une compilation manuelle de links. Voila ce qu’il faut faire :

  • telecharger les sources ici : artax.karlin.mff.cuni.cz/~mikula … re9.tar.gz
  • Decompresser
  • installer le package libssl-dev (apt), tu devrais normalement avoir maintenant /usr/include/openssl/
  • aller dans le repertoire links-1.00pre9
  • taper en tant que user : ./configure --with-ssl=/usr/include/openssl
  • toujours en tant que user : make
  • en root : make install

Ca installera links dans le chemin par defaut definit par debian, qui est /usr/local , pour tout les packages non installés via apt, par contre ca va ecraser le binaire links que tu as deja en place. Si tu souhaite faire un test , tu peux passer dans le ./configure l’argument : --prefix=/usr/local/links , ainsi les binaires iront s’installer dans ce repertoire.

J’ai testé un accès sur linuxfr.org/ et ca marche.

Tiens nous au courant


#5

Salut,
J’ai bien telechargé la version de links dont tu me parles, mais
quand j’ai cherch& sur backports.org libssl q j’ai pas sur mes cds, j’ai trouv& plusieurs versions. Laquelle il faut stp?
Et dans sources.list, faut taper:
deb backports.org/debian woody libsslVersion

ou c’est pas bon?
J’ai un peu de mal a d&finir les chemins dans sources.list, et la ca a pas fait d’erreurs mais il a pas trouv& le package libssl, il a des versions.
Merci de m’en dire +, et j’essaierai c q tu m’as dit jusqu’au bout.
A+ et vraiment merci pour ton aide, sans ca j’avoue q j serais perdu.
JP


#6

tu n’as pas a inserer quoique ce soit dans ton sources.list. Tu peux te contenter du package fourni par la Woody. Voila ce que j’ai sur une Woody à jour :

$apt-cache search libssl-dev
libssl-dev - SSL development libraries, header files and documentation

Donc en root :

apt-get install libssl-dev

Une fois que c’est installé, tu peux te lancer dans la compilation manuelle de liniks

Tiens nous au courant :wink:


#7

Salut,
Ma nullité me fait parfois peur. Mais bon, faut bien
tatonner pour apprendre. Aussi, voici ma nouvelle situation.
J’ai install& libssl-dev. Puis, dans links-1.00pre9 j’ai fait: ./configure --with-ssl=/usr/bin/openssl Voici la traduction de ce qu’il me dit.
Le package openssl n’a pas &t& trouv& dans le chemin de recherche de pkg-config. Vous devriez ajouter
le r&pertoire contenant openssl.pc dans la variable d’environnement PKG_CONFIG_PATH.
Pas de package openssl trouv&.

Pourtant, la ligne d’apres:
Checking for openssl: yes

Bien. Euh, j’avoue que moi non plus j’ai pas trouv& openssl.pc. Mais en plus,
meme si je savais ou ce fichier &tait, comment le dire a la variable d’environnement PKG_CONFIG_PATH. J crois que ca se fait en faisant PKG_CONFIG_PATH=… puis export PKG_CONFIG_PATH,
mais j n sais pas trop.
T’as rencontr& c pb toi aussi? Et ]as fait comment pour l contourner si oui stp? Pasque faudrait deja q j trouve ce openssl.pc, ce que find / openssl.pc ne m’a pas permis de faire.
Merci bcp de ton soutien, j’esp!e que j finirai par un peu m’am&liorer, j’en ai besoin j sais.
D&sol& du d&rangement et merci encore de l’aide au d&butant q j suis.
A+
JP


#8

Salut,
Rectification, c’est bien --with-ssl=/usr/include/openssl que j’ai fait et non /bin/openssl.
Voila, c’&tait juste une erreur d’&tourderie dans le message d’avant
A+
JP


#9

c’est bizarre, je n’ai pas eu ce genre de probleme a l"installation :frowning: Le repertoire /usr/lib/openssl existe bien apres l’install de libssl-dev ? si c’est le cas, tu peux creer manuellement le fichier openssl.pc . Il se situe dans le repertoire /usr/lib/pkgconfig/

Voici ce que contient ce fichier sur ma woody :

prefix=/usr
exec_prefix=${prefix}
libdir=${exec_prefix}/lib
includedir=${prefix}/include

Name: OpenSSL
Description: Secure Sockets Layer and cryptography libraries and tools
Version: 0.9.7d
Requires:
Libs: -L${libdir} -lssl -lcrypto -ldl
Cflags: -I${includedir}

Sinon est ce que le ./configure est arrivé a la fin sans erreur ou est ce que ca a echoue ?

a+


#10

Hello,
Certes. J’ai installé par apt-get install libssl-dev
libssl. Pourtant, /usr/lib/openssl n’existe pas.
J comprends mieux le pb. Par contre j sais pas trop comment le réparer.
Quant a ./configure, pas de pb particulier, aucune erreur except& celle-ci, ce qui
m’ennuie puisque c’est pr&cis&ment pour le support ssl que j recompile.
Voila. Je suis un peu d&sarm&. J vais retenter d’installer libssl, si ca marche, j repose
un message, sinon c que ca a pas march&, auquel cas si t’as une id&e de
comment contourner ce pb, ca m’arrangerait bcp.
Merci d’avand.
A+
JP


#11

Ca a pas march& la reinstallation de libssl-dev.
Toutefois, comme y avait pas d’err1or apres ./configure, j’ai tent& de poursuivre vinstallation.
Ca c’est pas mal pass&. Effectivement, j crois que j’ai r&ussi. Mon pb ne devait pas etre si genant pour Debian.
Mais je consulte, pour tester, orange.fr et hotmail.com. Et ces sites veulent javascript.
Donc, va falloir q j recompile links2 avec le support SSL.
Ca marche pareil selon toi? Ou la proc&dure change? Et j peux trouver ou les sources de links2 (car les backports me vont fourni sous forme package)?
Merci bcp d ton aide, vraiment ca m’a fait avancer, puisque j’ai recompil& quand j’ai vu qu’au fond, ./configure, mis [ part c message, fonctionnait.
Merci encore.
A+
JP


#12

c’est cool si ca s’est bien passé :smiley: comme tu le vois, une compile depuis les sources n’est pas si compliquée :wink:

pour le support du javascript, une rapide recherche sur google me donne ca :
./configure --with-ssl=/usr/include/openssl --enable-javascript


#13

Bon promis, dernier message sur c sujet, apres j t’embete plus.
J’ai essay& la commande q tu viens d m dire, et n’ai pu acc&der a hotmail.com. J’en d&duis qu’il doit manquer autre chose.
Donc, selon toi, est-ce qu’il existe dispo sur internet les sources de links2? Pasqu’avec ca,
j recompile links2 avec le support ssl et c’est bon! Puisque links2 marche bien, il manque juste c support.
Sauf qu’a part en backports, donc en package, j’ai pas trouv& les sources de links2, meme avec google. J’ai
peut-etre pas tap& c qu’il fallait.
Donc, ou j peux trouver les sources de links2 stp? Et selon toi, si j fais ./configure --with-ssl=/usr/include/openssl dans le r&pertoire de links2 d&compress&, ca m l recompilera comme il faut avec le support ssl?
Merci d ton aide, et j crois q ca devrait etre la derniere fois q j t’ennuie avec ca. Dsl encore.
A+
JP


#14

ca ne me pose pas de probleme de te repondre tant que je peux le faire :smiley:

J’ai trouvé les sources de links2, dispos ici : (c’est le site officiel )
ttp://atrey.karlin.mff.cuni.cz/~clock/t … e15.tar.gz

Je teste sur ma machine (en Sarge) :

$./configure --with-ssl=/usr/include/openssl --enable-javascript --prefix=/usr/local/links2


SSL support: YES
Javascript enabled: YES

$make (prend pas mal de temps…)
#make install

j’ai pas testé hotmail, j’ai pas de compte … mais tiens nous au courant :slightly_smiling:

a+


#15

Salut,
Bah ecoute, vraiment merci. J viens de compiler links2 avec les sources, ca marche super bien. Il me reste juste un ennui, plus mineur mais q j comprends pas du tout.
Sur hotmail.com, j rentre adresse mail et mot de passe, mais quand j’envoie, il me dit: “Please type your email adress”. J n comprends pas puisque je l’ai tap&e.
C’est nettement moins grave qu’avant cette compilation ou j’avais plus de mail, vu q j’ai retrouv& l’une de mes boites. Mais 3est genant pour hotmail, je comprends pas c qui peut lui inspirer ce message.
Si tu vois d’ou ca peut venir, n’h&site pas surtout.
Merci bcp encore et a bientot.
A+
JP


#16

ok bah c’est cool :wink:

a+