Linux 4.17 inutilisable

Tags: #<Tag:0x00007feddbce6ed8>

Bonjour,

Depuis ce matin après avoir fais les mises à jours de testing mon Linux 4.17 n’arrive pas à démarrer GDM tandis que le noyau 4.16 fonctionne parfaitement.

Les symptômes sont les suivants, au boot j’avais un bug qui faisait que le thème Plymouth gris par défaut se lance, sous 4.17 j’ai directement le thème que j’ai implanté après avoir vu la sortie du noyau. Quand le démarrage se termine j’ai les messages de boot en gras, le clavier fonctionne mais je n’ai aucun shell, lorsque je fais un Ctrl+Alt+Fx la console x s’affiche mais j’ai un scintillement avec les messages de boot, du coup impossible de taper mon mot de passe.
Une fois la console s’est stabilisé, startx ne fonctionnais pas et on me disais que le module radeon n’existait pas (celui qui se charge de mon affichage !). Un update-initramfs -u n’a rien changé.

Quelqu’un a-t-il une solution pour moi ?

Mon système est un portable Lenovo, j’ai un APU AMD FX-7500 Radeon R7, 10 Compute Cores 4C+6G, la carte graphique est reconnue comme une Kaveri [Radeon R6/R7 Graphics], j’ai bien firmware-amd-graphics et xserver-xorg-video-radeon.
Un update-initramfs -u retourne ça

bonjour,
ils font tous la queue sur l’autoroute
bref,
les préconisations "déinstallation de …

sans garantie:
le boot mode “rescue” avec password root

Merci de répondre si vite. Mais qu’est ce que je fais une fois en rescue ?

dans le choix 2, du grub,
je laisse dérouler la séquence de boot

à un moment, il (Debian) demande le mot de passe de root,
renseigner
Debian rend la main avec le #
ensuite on peut “manipuler” comme apt uninstall …
attention, je ne fais pas de la hotline

cryptsetup: WARNING: The initramfs image may not contain cryptsetup binaries 
    nor crypto modules. If that's on purpose, you may want to uninstall the 
    'cryptsetup-initramfs' package in order to disable the cryptsetup initramfs 
    integration and avoid this warning.

la ligne suivante pc105 ne correspondrait pas à la bonne configuration du clavier!

l’architecture µP, c’est quoi?

C’est un amd64 un APU AMD FX-7500.
Je viens de tester le recue mode qui fonctionne correctement, je vais réessayer sans cryptsetup-initramfs de booter mon système. En tout cas je n’ai plus le message du clavier assuming pc105.

Ça n’a rien changé :cry:

J’ai réussi à faire booter mon 4.17 ! J’ai désinstallé ROCm

rocm, je ne connais pas,
j’ai déjà du mal à rester sur les sentiers
bon aprés-midi

18:15 je viens de faire mes MAJs
j’ai le même type d’erreur,
je n’ai pas rebooté

Tu peux essayer de prendre les firmware qui sont en SID en ce moment, pour moi ça m’a régler quelques soucis avec mon Ryzen 2200G

apt install firmware-amd-graphics=20180518-1

https://debian-facile.org/viewtopic.php?pid=273043#p273043