LMDE - Bureau Mate - 2 tableaux de bord - login impossible

Bonjour,

J’utilise une Linuxmint Debian LMDE 201403 64-bit et le bureau Mate 1.6.1
Quand je travaille avec deux tableaux de bord, l’un au-dessus de l’écran et l’autre en bas de l’écran, pas de problème.

Quand je place les deux tableaux de bord dans le bas de l’écran: pas de problème, jusqu’à ce que je quitte la session et y revienne ou quand je redémarre le pc.
A ce moment là, il m’est impossible d’ouvrir une session : dans mdm j’entre mon mot de passe, la session est lancée et… l’écran affiche le menu de bienvenue de Mate et, au lieu d’avoir mes deux tableaux de bord qui apparaissent dans le bas de l’écran, j’ai juste une bande blanche qui tremble, toujours dans le bas de l’écran et j’eb reste là.

J’utilise Mate 1.6.1 avec ma Debian Wheezy 7.4 et deux tableaux de bord en bas de l’écran, pas de problème ça marche. Avec une autre version de linuxmint : Petra - 64bit Mate 1.6.1 pas de problème non plus. :frowning: !?

Merci d’avance.

Hux40


uname -a --> 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux

Elle est bien entretenue comme distrib la Linux Mint Debian Edition ?

Tu trouveras peu de gens qui utilisent Mate ici, donc pas évident de tester et voir si on rencontre le même problème. Ca ressemble à un bug, tu as été voir le suivi de bugs de LMDE ? Ils en disent ptet un mot sur leur forum.

Bonjour,

Merci pour ta réponse.

La LMDE est bien entretenue : c’est la dernière version parue au début de ce mois de mars 2014 …

J’ai découvert linux via Ubuntu, comme beaucoup d’utilisateurs de linux, il y a 6 ans maintenant.
Quand le bureau gnome 2 a été abandonné pour gnome 3 (ou Unity chez Ubuntu), j’ai migré vers linuxMint qui proposait le fork de Gnome2 : Mate, et assez rapidement vers LMDE : Linux Mint Debian Edition, basé directement sur Debian et non plus sur Ubuntu, elle-même basée sur Debian…

J’ai utilisé LMDE avec beaucoup de satisfaction jusqu’à l’update pack 7 avec lequel j’ai déjà rencontré le problème que j’explique dans mon post.
J’ai donc migré vers Debian… avec bonheur (stabilité-infos-esprit,…) et installé Mate qui fonctionne sans aucun problème avec les deux tableaux de bords dans le bas de l’écran…

J’aurais aimé trouver une solution pour la LMDE qui est une distribution pleine de promesses et que j’apprécie beaucoup.
J’ai posté sur Linuxmint mais, pas de de réponse.

Enfin, merci quand même, pas d’infos dans les rapports de bugs de LMDE.

Hux40

Donc le problème survient:

  • sur LMDE
    Mais pas sur:
  • Linux Mint
  • Debian Wheezy + Mate (dépot externe ?)

As-tu tenté de créer un nouvel utilisateur sous ce système, pour voir si le problème était récurrent ?

Tu peux aussi vérifier le fichier ~/.xsession-errors, en l’effaçant avant de démarrer Mate, tu y trouveras peut-être des messages d’erreur plus explicites sur le pourquoi tes panels déconnent.

Bonjour,
Merci pour les pistes de recherche.

J’avais déjà créé un deuxième utilisateur et le problème était récurrent.

Dans le fichier ~/.xsession-errors j’ai trouvé la ligne suivante :

** Message: applet now removed from the notification area
mate-session: Fatal IO error 11 (Ressource temporairement non disponible) on X server :0.

J’ai tenté d’utiliser un autre display manager que mdm (mate display manager - fork de gdm pour Mate) à savoir lightdm.
Résultat : pas mieux.

J’ai ensuite installé les drivers de ma carte graphique NVidia [VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)] en suivant ce wiki: wiki.debian.org/fr/NvidiaGraphicsDrivers pour wheezy.
J’utilisais jusque là le driver nouveau (nb: c’est aussi celui que j’utilise sur ma debian wheezy + Mate et là, pour rappel, ça fonctionne !?!).
Résultat : driver bien installé mais pour mon problème : pas mieux.

Cependant, dans lightdm, j’ai maintenant la possibilité d’appeler le script Default Xsession et là, ça fonctionne !

Je repasse dans mdm (# dpkg-reconfigure mdm) et maintenant, il me propose en plus des options de connexion présentes avant d’installer lightdm (Last - Lancer le script Xclient (?) - Mate) : Default Xsession. Je choisis donc Defaut Xsession et … ça fonctionne: j’entre bien dans ma session et mes deux tableaux de bord en bas de l’écran apparaissent bien.

Mouais, quel chipo !
Comment configurer tout cela correctement et simplement dès le départ ? Qu’en penses-tu ?

Hux40

Ben, je sais pas trop non plus exactement comment ça se goupille.

Par contre je sais qu’il y a des trucs relatifs à xsession/Xsession par ici:

~/.xsession
/etc/X11/Xsession*

Je pensais que “Default Xsession” était synonyme de “La dernière session utilisée”, mais il va peut être chercher sa config autrepart.