Logiciel


#1

Y a t-il un moyen d’installer amule sans passer par toutes les dépendances qui n’en finissent pas. Merci


#2

apt-get install amule

Comment tu fais pour te plaindre des dépendances sous Debian alors qu’apt s’occupe de tout ?


#3

[quote=“BobX”]apt-get install amule

Comment tu fais pour te plaindre des dépendances sous Debian alors qu’apt s’occupe de tout ?[/quote]
apt-get install donne ceciLecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Aucune version du paquet amule n’est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu’il est devenu obsolète
ou qu’il n’est disponible que sur une autre source
E: Aucun paquet ne correspond au paquet amule

j’ai donc télécghargé amule sous forme de paquet
seulement a l’install par dpkg il demande d’installer la dependance X mais X a besoin de R et T qui a lui même besoin de P et de Z … bref on n’en sort pas .sans te parler de certains lib x.xxx qui existent mais dans une version différente et qui " cassent " dans synaptic
Si tu as une soluce je suis preneur


#4

Cherche amule sur apt-get.org, tu trouveras plein de dépôts où il est présent. Il y aura plus qu’à les ajouter dans ton source.list, faire ton apt-get update puis apt-get install.

Au fait, t’es sous quelle version de Debian? Sarge?


#5

y’a qu’à demander :laughing:

[quote]Package amule

* [b]testing[/b] (x11): aNOTHER eMule P2P Client
  2.0.3-3.0.1: arm hppa sparc
  2.0.3-3: alpha amd64 i386 ia64 m68k mips mipsel powerpc s390
* unstable (x11): aNOTHER eMule P2P Client
  2.0.3-3.0.1: arm hppa sparc
  2.0.3-3: alpha amd64 i386 ia64 m68k mips mipsel powerpc s390

Package amule-daemon

* [b]testing[/b] (x11): aMule daemon
  2.0.3-3.0.1: arm hppa sparc
  2.0.3-3: alpha amd64 i386 ia64 m68k mips mipsel powerpc s390
* unstable (x11): aMule daemon
  2.0.3-3.0.1: arm hppa sparc
  2.0.3-3: alpha amd64 i386 ia64 m68k mips mipsel powerpc s390

Package amule-utils

* [b]testing[/b] (x11): utilities for amule
  2.0.3-3.0.1: arm hppa sparc
  2.0.3-3: alpha amd64 i386 ia64 m68k mips mipsel powerpc s390
* unstable (x11): utilities for amule
  2.0.3-3.0.1: arm hppa sparc
  2.0.3-3: alpha amd64 i386 ia64 m68k mips mipsel powerpc s390

[/quote]

packages.debian.org/cgi-bin/sear … lla-search


#6

[quote=“BobX”]Cherche amule sur apt-get.org, tu trouveras plein de dépôts où il est présent. Il y aura plus qu’à les ajouter dans ton source.list, faire ton apt-get update puis apt-get install.

Au fait, t’es sous quelle version de Debian? Sarge?[/quote]

Je suis sous Sarge .

En résumé que mle conseille tu?


#7

personnellement, je te conseillerais d’upgrader en etch (si tu n’as rien de critique à faire tourner, ni de contrainte à rester en sarge, tu n’as aucun risque), car amule n’est pas disponible en sarge.
L’autre solution, c’est d’ajouter les sources etch dans ton sources.list, de faire un ‘apt-get update’, puis ‘apt-get install amule’, et ensuite de recommenter tes sources etch. Ceci étant dit, même si l’install ne pause pas de problême, tu n’auras pas de possibilité de mises à jour d’amule, et il te proposera peut etre même de désinstaller amule lors de ton prochain ‘apt-get upgrade’.