Mail recu mais invisible !


#1

Bonjour,

J’ai installé un serveur de mail sur mon serveur, et j’ai un problème étrange, sans doute une erreur de config…

Alors voilà, j’envoie des mail à martin@mondomaine.org, il arrive. Quand je dis il arrive, c’est plus ou moins : quand je fais mail, il me dit no mail for martin, et quand je vais voir dans /var/mail/martin, je trouve le mail que j’ai envoyé… Argh, même problème en local :s Même webmin me dit qu’il n’y a aucun mail :frowning:

Y’a-t-il un fichier de config pour mail ? lequel ??? man mail ne me donne rien de bien utile :s

Merci d’avance !


#2

slt,

Si tu nous disait quel serveur de mail utilise tu ? :smiley: si dans /var/mail/martin tu as un mail c’est peut etre que ton client mail est mal configuré.


#3

Désolé ^^ J’utilise postfix.
Rien ne spécifie où enregistrer les mail dans la configuration de postfix :frowning:


#4

slt,

As tu regardé les logs ? (/var/log/mail.*). Oui il n"y a rien qui définit le rép parcontre sur ton client de mail oui il y a un rép, par default posftix les remtes dans /var/mail/user


#5

Je ne vois rien qui pourrait aider :s Il n’y a rien dans mail.err, mail.info et mail.log sont exactement identiques et rien dans mail.warn :frowning:

Edit : Je viens d’installer QPopper, et je récupère les mails parfaitement :s Seulement, j’aimerai bien arranger ce problème :smiley:


#6
  1. Y-a-t-il un lien de /var/spool/mail vers /var/mail?

  2. Qu’y a-t-il dans dans variable MAIL (il devrait y avoir

MAIL=/var/mail/martin


#7

$ echo $MAIL
/var/mail/root
$ file /var/spool/mail
/var/spool/mail: symbolic link to ‘…/mail’

Tout me semble parfait :frowning:


#8

Non: echo MAIL

/var/mail/root

et tu veux recevoir le courrier de martin,

essaye un
$ export MAIL=/var/mail/martin


#9

Wahoo ca marche :slightly_smiling:

Merci beaucoup !
Malheureusement, chaque utilisateur doit le faire ?

merci encore pour ton aide :wink:


#10

Non, chaque utilisateur ne doit pas le faire, c’est surtout qu’aucun utilisateur ne doit utiliser le compte root.
Evites le su, installes sudo, et tout fonctionnera correctement.


#11

Si tu t’es logué sous ton nom, c’est qu’il y a un souci dans ton .bashrc, la variable MAIL est crée au login.

Pour MattOTop, si tu fais su, la variable MAIL reste vers la boite de l’utilisateur, là c’est l’inverse, je ne pense pas que ça soit ça. Soit il s’est loggué en root puis su utilisateur (curieux), soit le login initialise mal les variables.


#12

[quote=“fran.b”]Si tu t’es logué sous ton nom, c’est qu’il y a un souci dans ton .bashrc, la variable MAIL est crée au login.

Pour MattOTop, si tu fais su, la variable MAIL reste vers la boite de l’utilisateur, là c’est l’inverse, je ne pense pas que ça soit ça. Soit il s’est loggué en root puis su utilisateur (curieux), soit le login initialise mal les variables.[/quote]C’est vrai. J’avais oublié. Il a aussi pû faire un ‘su -’, mais ça serait étonnant .