[MAJ]Bénéficiez du dernier firefox


#1

Bonjour voici une astuce

!!! cette methode n’est pas supporté par Debian !!!
Personne ne peut en aucun cas être tenu pour responsable des dégats présents ou futures.

Avec ma stretch, j’aimerai bénéficier de la dernière version de Firefox.

$sudo vim /etc/apt/sources.list

deb http://deb.debian.org/debian stretch main contrib non-free
deb-src http://deb.debian.org/debian stretch main contrib non-free

deb http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src http://deb.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

### ligne que j'ai rajouté
deb http://http.debian.net/debian sid main

Ensuite créez le fichier :

sudo vim /etc/apt/preferences

Package: *
Pin: release o=Debian,n=sid
Pin-Priority: 100

On lance la commande pour installer

$sudo apt install -t sid firefox-l10n-fr firefox

Si on souhaite le nouveau Firefox par défaut pour notre distribution

$ sudo update-alternatives --config x-www-browser

Il faut sélectionner le chiffre en face de cette ligne :

/usr/bin/firefox

et bien sur il faut aussi modifier votre choix dans votre environnement de travail.


#2

Salut
Il est vrai que la version stable/testing est firefox-esr ce qui peut surprendre quand on cherche firefox.

root@debian:# apt list firefox
En train de lister... Fait
root@debian:# apt list firefox-esr | grep install

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

firefox-esr/stable,now 52.2.0esr-1~deb8u1 amd64  [installé]

Pour les alternatives, en gnome il existe aussi gnome-www-browser

Moi je suis Chromium :slight_smile:

 update-alternatives --display gnome-www-browser
gnome-www-browser - mode manuel
  link best version is /usr/bin/google-chrome-stable
 le lien pointe actuellement sur /usr/bin/chromium
  link gnome-www-browser is /usr/bin/gnome-www-browser
  slave gnome-www-browser.1.gz is /usr/share/man/man1/gnome-www-browser.1.gz
/usr/bin/chromium - priorité 40
/usr/bin/firefox-esr - priorité 70
 lien secondaire gnome-www-browser.1.gz : /usr/share/man/man1/firefox-esr.1.gz
/usr/bin/google-chrome-stable - priorité 200

#3

Bonjour

J’etait Chromium. Mais je veux laisser une chance à Firefox. Il ne faut pas laisser l’eco-systeme d’internet à Google


#4

Attention, ceci bien qu’étant une méthode intéressante, n’est pas recommandé par Debian !
Merci de bien le mettre en valeur - cf le fameux FrankenDebian :wink:


Bon usage de sources.list quand Stretch deviendra la nouvelle stable
#5

Méthode ne fonctionnant plus, voir les deux posts après celui-ci.

Bonjour,

Personnellement, j’utilise la méthode venant d’ici qui évite le pinning :

echo "deb http://http.debian.net/debian experimental main"  > /etc/apt/sources.list.d/mozilla.list
apt-get update && apt-get install -t experimental firefox

#6

bizarre il n’y a pas de firefox dans experimental

https://packages.debian.org/fr/experimental/web/
https://packages.debian.org/experimental/allpackages


#7

Bonjour Sk4rr

http.debian.net a changer de nom. Il s’agit de deb.debian.org.
De plus comme dit grandtoubab, il n’y a pas de firefox dans experimental.


#8

Effectivement, je viens de voir que firefox n’est plus du tout disponible dans experimental… Se doit être assez récent parce que mon portable est en 53.0.1.

Exacte, je suis allez un peu vite en copiant-collant l’exemple du site en question, désolé :confused:

Bon du coup, autant pour moi.


#9

ca y est firefox-esr est dans stretch/security

Réception de:7 http://security.debian.org/debian-security stretch/updates/main amd64 libgnutls30 amd64 3.5.8-5+deb9u1 [895 kB]
Réception de:8 http://security.debian.org/debian-security stretch/updates/main amd64 firefox-esr-l10n-fr all 52.2.0esr-1~deb9u1 [524 kB]


# apt list firefox-esr -a
En train de lister... Fait
firefox-esr/testing,now 52.2.0esr-1~deb9u1 amd64  [installé]
firefox-esr/stable 52.2.0esr-1~deb8u1 amd64
firefox-esr/testing 45.9.0esr-1 amd64
firefox-esr/stable 45.9.0esr-1~deb8u1 amd64


#10

A priori l’augmentation des processus de Firefox, elle est la cause de nombreux figes.

Je m’explique sur quelques machines, j’ai eu des remontées de figes en pages web.
J’ai rétrogradé en esr. Il n’y pas de soucis pour l’instant.


#11

Et oui comme on dit “le mieux est souvent l’ennemi du bien” :grinning:

 apt list firefox-esr -a
En train de lister... Fait
firefox-esr/stable,now 52.2.0esr-1~deb9u1 amd64  [installé]
firefox-esr/oldstable 52.2.0esr-1~deb8u1 amd64
firefox-esr/stable 45.9.0esr-1 amd64
firefox-esr/oldstable 45.9.0esr-1~deb8u1 amd64

Donc maintenant:
les paquets oldstable=Jessie
les paquets stable= Stretch


#12

La version 54.0.1 corrige le bug du fige , OUF!!:blush:


#13

Firefox n’est présent dans expérimental que quand la version en question est en pré-release. S’il n’y pas de version disponible dans experimental, c’est que la dernière version dispo de Firefox est déjà dans Sid.
Exemple :

~$ acpol firefox
firefox:
  Installé : 54.0-2
  Candidat : 54.0-2
 Table de version :
     55.0~b2-1 1
          1 https://deb.debian.org/debian experimental/main amd64 Packages
 *** 54.0-2 520
        520 https://deb.debian.org/debian sid/main amd64 Packages
        100 /var/lib/dpkg/status

Donc par rapport au premier post, si vous voulez rester dans le cadre du support Debian, il est préférable alors de passer par les dépôts Sid et/ou Experimental puis de faire du pinning (sans oublier qu’il n’est pas nécessaire de “pin”-er le dépôt Experimental puisqu’il a un pin par défaut à 1.

L’augmentation des processus, ou la séparation en “multi-threading” des processus de Firefox est apparue récemment (depuis la version 53 il me semble), mais curieusement elle n’est pas activée par défaut dans Firefox pour Debian.

Vous pouvez vérifier en ouvrant dans un onglet —>> about:config

Puis en regardant la clé :

dom.ipc.processCount

D’origine sa valeur est à 1, si vous souhaitez activer le multi-process il faut changer cette valeur.
Néanmoins, il se peut que même en changeant cette valeur le multi-process ne soit pas actif, et ceci est dû à certaines extensions ou add-ons qui sont encore incompatibles pour l’instant avec le multi-thread dans Firefox.

Donc je pencherai plus pour un problème du côté des extensions dans ton cas. Ça arrive parfois et en général c’est rapidement résolu.


#14

Bonjour

j’ai qu’une extension. Le fige a disparu depuis la 54.0-2. idem sur d’autres postes. Par contre peut etre que l’extension s’est mis à jour.


#15

Oui c’est parfaitement possible que l’extension ait subi une mise à jour, comme par défaut pour les extensions les mises à jour automatiques sont activées… Ou bien simplement qu’il y ait quelque chose dans les scripts de Firefox qui ait changé lors de la MàJ de celui-ci et qui ne rentre plus en conflit avec l’un des scripts de l’extension.

De toute façon comme je l’ai dit pour le multi-thread, tu peux vérifier la valeur de la clé ci-dessus dans about:config, et quand bien même tu aurais déjà changé sa valeur, tu peux vérifier si les process sont split-és ou pas en regardant dans le moniteur système. S’il y a bien plusieurs process attachés à Firefox, comme c’est le cas avec Chromium par exemple, alors ça fonctionne, sinon refais le test en désactivant temporairement ton extension et tu verras que les process seront séparés…

Petite parenthèse, il est vrai que, multi-process activé ou pas, Firefox est devenue proche d’une fusée depuis l’arrivée de la version 54 chez moi.


#16

Entièrement d’accord avec toi, j’ai quitter chromium (enfin) parce que on sent la différence.


#17

Je ne sais pas, disons que je n’irai pas jusque là, à dire que Firefox est maintenant plus rapide que Chromium, mais qu’il est au moins aussi rapide que son concurrent oui. J’ai toujours les deux au cas où, ça mange pas de pain.


#18

Le soucis avec chromium, je me retrouve avec un cache de 3 Gio, il ne vide jamais.


#19

Bonjour

Télécharger le dernier firefox ici :

attention il faut etre root
décompresser le dans /opt/firefox

tar xvf firefox*

Ensuite on va l’ajouter à notre systeme Debian en root

update-alternatives --install /usr/bin/x-www-browser x-www-browser /opt/firefox/firefox 100

Ensuite on autorise les mises à jours automatique ( J’ai pris mon utilisateur principale)

chown -R christophe:christophe firefox

Pour finir, On va le mettre dans son menu de son bureau. A faire avec votre utilisateur

nano ~/.local/share/applications/firefox

coller ceci

#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Icon[fr_FR]=/opt/firefox/browser/icons/mozicon128.png
Name[fr_FR]=Firefox
Exec=/opt/firefox/firefox
Name=Firefox
Icon=/opt/firefox/browser/icons/mozicon128.png

dites moi ce que vous en pensez.


#20

j’ai installé mon “autre firefox” dans mon home, je distingue les profiles dans les différents lanceurs dans .local/share/applications/

en ce moment j’ai firefox-esr et firefox57

au premier lancement j’utilise l’option -p et je créé un profile, puis dans le lanceur

Exec=/home/xxx/firefox/firefox -p firefox57 %u

xxx est à remplacer par le nom de l’utilisateur

pour l’officiel firefox-esr

Exec=/usr/lib/firefox-esr/firefox-esr -p default %u

ça donne ça

/.mozilla/firefox# ls
 4r5uzj0d.firefox57  'Crash Reports'   ha8qbmcx.default  'Pending Pings'   profiles.ini   xzmnr0h2.firefox-esr

cat profiles.ini

[General]
StartWithLastProfile=0

[Profile0]
Name=default
IsRelative=1
Path=ha8qbmcx.default
Default=1

[Profile1]
Name=firefox57
IsRelative=1
Path=4r5uzj0d.firefox57

[Profile2]
Name=firefox-esr
IsRelative=1
Path=xzmnr0h2.firefox-esr

comme ça pas de perturbation à cause des extension de l’un dans l’autre et vice-versa :grinning: