MAJ bullseye

bonjour.
je m’étonne de ne pas avoir de MAJ depuis le passage à bullseye. Normal??
mon sources.list:

deb https://deb.debian.org/debian/ bullseye main contrib non-free
deb https://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb https://deb.debian.org/debian-security bullseye-security main contrib non-free

Par curiosité, que donne comme retour la commande apt update ?

sortie de apt update:

Atteint :1 http://dl.google.com/linux/chrome/deb stable InRelease
Atteint :2 http://dl.google.com/linux/earth/deb stable InRelease               
Atteint :3 https://deb.debian.org/debian bullseye InRelease                    
Atteint :4 https://download.virtualbox.org/virtualbox/debian buster InRelease  
Réception de :5 https://deb.debian.org/debian bullseye-updates InRelease [36,8 kB]
Atteint :6 https://repo.skype.com/deb stable InRelease                
Atteint :7 https://deb.debian.org/debian-security bullseye-security InRelease
36,8 ko réceptionnés en 2s (17,8 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.

sortie de apt upgrade:

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour

Attends, il manque des trucs là.
Tu peux me donner le retour de la commande grep -v "^#" /etc/apt/sources.list{,.d/*} ?

Et, par curiosité, si tu peux transmettre le retour de la commande dpkg -l 'linux-image*'.


Si tu peux mettre en forme les retours que je le fais pour tes messages, c’est plus lisible, merci.

Salut,

Tu ne mets pas de :

deb https://deb.debian.org/debian/ bullseye-proposed-updates main contrib non-free
deb https://deb.debian.org/debian/ bullseye-backports main contrib non-free

dans ton sources.list ?

Pour quoi faire ? Ces dépôts sont pour un usage spécifique.
Ils sont seulement nécessaires si on a besoin d’avoir une version plus récente d’un logiciel.
Si le but est d’avoir des mises à jour à tout pris, autant ajouter le dépôt sid.

avram@sda5-bullseye: 16:37:45: ~$ grep -v "^#" /etc/apt/sources.list{,.d/*}
/etc/apt/sources.list:
/etc/apt/sources.list:deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian buster contrib
/etc/apt/sources.list:deb https://deb.debian.org/debian/ bullseye main contrib non-free
/etc/apt/sources.list:deb https://deb.debian.org/debian/ bullseye-updates main contrib non-free
/etc/apt/sources.list:deb https://deb.debian.org/debian-security bullseye-security main contrib non-free
/etc/apt/sources.list:deb https://deb.debian.org/debian/ bullseye-proposed-updates main contrib non-free
/etc/apt/sources.list.d/google-chrome.list:deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/google-earth-pro.list:deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main
/etc/apt/sources.list.d/skype-stable.list:deb [arch=amd64] https://repo.skype.com/deb stable main
avram@sda5-bullseye: 16:38:18: ~$ 

il me manquait la ligne « proposed-updates » dans mon sources.list, mais cette ligne doit elle obligatoirement être présente?

je reformule le problème autrement: quel est le bon sources.list pour bullseye?

T’as sources.list est correcte pour bullseye :

deb https://deb.debian.org/debian/ bullseye main contrib non-free
deb https://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb https://deb.debian.org/debian-security bullseye-security main contrib non-free

par contre pourquoi ne pas utiliser apt full-upgrade a la place de sortie de apt upgrade

En faite la problématique est que tu ne remarques pas de mises a jour depuis un moment sur bullseye ?

Bonjour,

quel était le contenu de ton sources-list jusqu’au moment où bullseye est passé en stable ?

invar

exactement, j’avais mis à jour vers bullseye mi août sans problème et je suis étonné de ne pas voir de mise àjour mais j’avais omis proposed-updates dans mon sources.list; en rajoutant cette ligne quelques MAJ étaient proposées. Je passe en résolu.

L’inconvénient de bullseye-proposed-updates, c’est de servir de bêta-test.

Utiliser « proposed-updates » est un choix, pas une obligation.

merci pour cette info