MàJ driver carte graphique

Tags: #<Tag:0x00007f8a4d7232e0> #<Tag:0x00007f8a4d756d98> #<Tag:0x00007f8a4d801428>

Bonjour la communauté,

J’utilise Debian Buster avec les pilotes Nvidia propriétaires (ouch ça commence mal! :slight_smile: )
J’ai eu un gros stress lors d’une mise à jour du pilote de ma CG (apt-get dist-upgrade, aujourd’hui):

Le processus se déroule, et à la fin un message m’annonce de manière assez laconique que le pilote nvidia qui vient d’être installé ne correspond pas au module actuellement chargé, que le server x risque de ne pas fonctionner correctement et que no soucy, quand la machine va redémarrer tout ira bien.
L’entête du message est « configuration de xserver-xorg-video-nvidia » et cette mise à jour a lieu avec une session graphique ouverte (en l’occurrence sous gnome).

Donc reboot, mais malheur, un message d’erreur me dit que si je voulais passer les diagnostics en cours, je devais faire ctrl+c - mais ça ne faisait rien et impossible d’aller plus loin. d’où mon stress.

Finalement tout est rentré dans l’ordre en démarrant en mode dépannage. En ligne de commande en root, j’ai tenté un apt-get upgrade, et le message d’erreur m’a indiqué comment résoudre mon problème: « dpkg --configure -a » et j’ai pu retrouver mon interface graphique chérie.

d’habitude lors d’une mise à jour du pilote, mon environnement graphique ne démarre pas mais j’arrive au moins jusqu’au gestionnaire de connexion et je peux passer en mode console. Je ne sais pas pourquoi là ça s’est mal passé.
Lorsque j’ai lancé dpkg j’ai vu qu’il était aussi question de mise à jour du kernel (en tout cas quelque chose avec « 4.19.x.x »), peut être est-ce pour cela que je n’ai pas été bloqué au même endroit que d’habitude? mais là n’est pas ma question:

C’est plutôt, comment mettre à jour proprement mes drivers de carte graphique?
est-ce normal qu’après un apt-get upgrade un message me fasse miroiter un reboot sans souçis alors que je fois finaliser la mise à jour « à la main »?

Je me demande si c’est moi qui n’ai pas de chance car qq chose dans ma configuration pose problème, ou bien si d’autres se retrouvent bloqués après un reboot avec ce même message faussement rassurant.

Si ce n’est que moi, tant pis, je pense que j’arriverais à m’en sortir (avc quelques sueurs froides).
Si ça arrive à mamy Huguette à qui j’avais dit « mais si tu va voir, Linux ça marche super bien » je pense que ça peut faire un peu peur :slight_smile:

je vous prie de m’excuser si quelques terminologies sont approximatives. J’ai essayé d’être précis mais de nombreux aspects de mon OS (que j’apprécie énormément) me sont encore très obscurs…

merci pour votre aide!

Greg

Bonjour,
As-tu installé le paquet linux-headers-amd64 qui va avec ton noyau (donc amd64 à changer si besoin et si le noyau vient des backports installer la version des backports) ?

Bonjour,

Le problème arrive quand le pilote installé par défaut ne convient pas car la carte vidéo est un peu ancienne. Pour savoir quoi faire le wiki de debian donne une procédure qui fonctionne parfaitement chez moi :

https://wiki.debian.org/fr/NvidiaGraphicsDrivers

Commencer par l’tape nvidia-detect permet de connître le bon paquet à installer :

$ nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 730] [10de:0f02] (rev a1)
Checking card: NVIDIA Corporation GF108 [GeForce GT 730] (rev a1)
Your card is only supported up to the 390 legacy drivers series.
It is recommended to install the
nvidia-legacy-390xx-driver
package.

Il suffit ensuite d’aller dans la bonne section et de suivre les indications

Bonjour chalu,
oui, le paquet linux-headers-amd64 est bien installé, j’ai aussi activé les backports pour 2/3 appli spots mais je ne pense pas que mon noyau vient de là

Bonjour gingko_biloba,
Le retour de nvidia-detect est le suivant:

gregory@grumpf:~$ nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM206 [GeForce GTX 950] [10de:1402] (rev a1)

Checking card: NVIDIA Corporation GM206 [GeForce GTX 950] (rev a1)
Your card is supported by the default drivers and legacy driver series 390.
It is recommended to install the
nvidia-driver
package.

Je vais me plonger plus en détail dans la procédure décrite dans le wiki debian

merci de vos retours!

merci de vos retours!