Manipulation de pilote

Tags: #<Tag:0x00007f8a4cd9b510>

Je dispose d’une clé wi-fi pour me connecter à l’internet. Cette clé nécessite un driver que je trouve tout simplement de cette manière :
wiki.debian.org/fr/rtl819x#Debi … 2Wheezy.22

Je souhaite savoir s’il est possible de conserver ce driver sur un support (clé usb) de manière à pouvoir l’installer ultérieurement sans passer par le cable.

En effet, je ne dispose pas de connexion par cable.

ftp://ftp.fr.debian.org/debian/pool/non … e-nonfree/

en utilisant http et sans passer par le japon : ftp.fr.debian.org/debian/pool/no … +1_all.deb

pour installer le paquet, ouvrir un terminal en root et taper :

merci beaucoup

juste une précision; dans le gestionnaire de paquets synaptiques, le driver présentement installé sur ma machine est :
firmware-realteck 0.36+wheezy.1

il est présent dans ftp://ftp.fr.debian.org/debian/pool/non … e-nonfree/

lequel dois-je retenir ?

firmware-realtek_0.36+wheezy.1_all.deb
ou bien
firmware-realtek_0.43~bpo70+1_all.deb

tant qu’à faire, utilise le plus récent qui potentiellement corrige des bugs pour le firmware de ta clé wifi.
ces paquets de firmware sont génériques de toute façon, ils n’ont aucune dépendances.

ok c’est vérifié ça fonctionne avec la version 0.43

merci beaucoup

affaire classée

pardonnez-moi; ou cliquer pour clore le sujet? merci.

Bonjour

J’ai un peu de temps pour migrer sous debian 9

puis-je utiliser le même driver pour ma clé-wifi?

à noter que le cd d’installation s’est connecté pour charger des paquets via cette même clé wifi. mais la connexion ne fonctione pas une fois le système lancé.

merci

avant de migrer sauvegarde l’existant au cas où tu rencontrerais des problèmes pendant la migration. Migre d’abord vers jessie et ensuite vers stretch et pas directement de wheezy vers stretch.

bonjour

merci ; tout est ok sur ce point, j’ai un disque additionnel pour procéder à tous les tests que je souhaite effectuer.

et je suis sous jessie depuis sa sortie, avec le même driver. d’ou ma question

merci

Bonjour

Je remonte le sujet car je ne suis toujours pas parvenu à fixer ceci

l’intallation manuelle de firmware-realtek_0.43~bpo70+1_all.deb ne fonctionne pas sur ma debien 9.

J’ai donc essayé le dernier de la liste : firmware-realtek_20190114-1_all.deb
l’installation est réalisée ; je peux le voir dans le gestionnaire de paquets synaptique.

mais toujours pas de connexion wifi

une chose étrange ; avant d’installer le driver realtek les différents reseaux wifi de mon immeuble étaient déjà visible dans la liste.

Comment cela est-il possible?

ensuite je tente de me connecter sur mon réseau ; avec la même configuration que sur ma debian 8 mais rien ne se passe. le petit icone tourne comme pour chercher le réseau quelques secondes puis le message de non-connexion apparaît.

je suis vraiment embarrassé et je n’ai plus d’idées. comment procéder?

merci

Bonsoir :slight_smile:
C’est une clé usb que tu utilises pour avoìr le wifi et certaines posent problème sur Debian 9 en lien avec le changement de nom des interfaces.
Donne le retour puisque tu vois des réseaux de la commande user

ip a

Les noms à problème sont avec un x de la forme wlx…
Si c’est ça, tu peux regarder ici pour résoudre le problème

Pour le firmware tu n’en as peut-être plus besoin sur Debian 9, c’est mon cas, il fallait un firmware sur Jessie mais pas sur stretch

Bonjour

Mon problème est résolu grace au post précedent. Affaire classé.

Merci beaucoup

Ok :slight_smile: et tu coches pas en résolu ?

Oups j’avais oublié de cocher ‘résolu’

à noter que à partir de hier fin d’aprèm, j’ai eu quelques soucis de déconnexion intempestives. j’ai même eu un freeze complet de la bécane.

après quelques redémarrages, avec et sans la clé cela semble fixé.

curieux la connexion a pourtant fonctionné sans problème pendant deux journées.

affaire à suivre…

merci

Ça ne vient peut-être pas de la clé. A mon avis si ça recommence il faudra ouvrir un autre fil et poster les éventuels messages d’erreurs des logs.

Bonsoir

Un petit feed-back sur le souci ;

J’ai réinstallé totalement le système, j’ai fait les deux modifs pour faire reconnaître la clé.

Pratiquement juste après, au moment d’installer ‘firmware-linux’, j’ai eu cette série de messages sur la console :

W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169

donc j’ai installé le driver realtek de la clé.

Pour le moment, plus de problèmes. la connexion fonctionne et j’utilise le pc depuis trois jours.

merci

Bonjour

Malheureusement je remonte ce sujet pour chaque nouvelle version de debian

Sous debian 10 ma clé pose à nouveau problème.

Cette fois elle semble reconnue sans driver puisqu’elle “s’affiche” dans le tableau de bord

Je choisis ma box parmis les signaux de l’immeuble, ça mouline brièvement ;

il me demande le code secret de la connexion

ça mouline à nouveau un bon moment et puis plus rien. message “pas connecté”

J’ai fais les deux solutions proposées précédemment dans le lien :
https://debian-facile.org/viewtopic.php?id=21137
(sous debian 9, la seule solution #1 avait résolu l’affaire)

Cela ne fait que mouliner avec ou sans driver

Quelqu’un a une idée pour fixer ma clé sous debian 10 ?

Bus 007 Device 002: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter

merci

Quelqu’un as-t-il une idée pour fixer ma clé usb-wifi pour debian 10 ?

Sinon, quel modèle de clé dois-je choisir pour la remplacer ?

merci

Je viens de réaliser une installation de debian 9.11 et le résultat est le même.

clé usb wifi qui mouline et qui refuse de se connecter

ce qui est intérréssant c’est qu’actuellement j’utilise une autre debian 9 (à jour) que j’avais installé début 2019. Sur laquelle ma clé fonctionne parfaitement…

quelqu’un a une idée ?

oups il s’agissait du filtrage mac sur la box…:sunglasses:

le filtre mac semblerait avoir été activé automatiquement, étrange.