Message d'erreur depuis migration Stretch Buster lors des apt upgrade


#1

Bonjour,
depuis ma migration à Buster j’ai un message d’erreur :

apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  exim4-base exim4-config exim4-daemon-light
3 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/2 039 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Lecture des fichiers de modifications (« changelog »)... Terminé
Préconfiguration des paquets...
(Lecture de la base de données... 255742 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../exim4-config_4.92-8+deb10u2_all.deb ...
Dépaquetage de exim4-config (4.92-8+deb10u2) sur (4.92-8+deb10u1) ...
Préparation du dépaquetage de .../exim4-base_4.92-8+deb10u2_amd64.deb ...
Dépaquetage de exim4-base (4.92-8+deb10u2) sur (4.92-8+deb10u1) ...
Préparation du dépaquetage de .../exim4-daemon-light_4.92-8+deb10u2_amd64.deb ...
Dépaquetage de exim4-daemon-light (4.92-8+deb10u2) sur (4.92-8+deb10u1) ...
Paramétrage de minissdpd (1.5.20190210-1) ...
ens5 wls1 Job for minissdpd.service failed because the control process exited with error code.
See "systemctl status minissdpd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript minissdpd, action "restart" failed.
● minissdpd.service - keep memory of all UPnP devices that announced themselves
   Loaded: loaded (/lib/systemd/system/minissdpd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2019-09-06 19:47:13 CEST; 11ms ago
     Docs: man:minissdpd(1)
  Process: 9783 ExecStart=/usr/lib/minissdpd/minissdpd-systemd-wrapper ${MiniSSDPd_INTERFACE_ADDRESS} $MiniSSDPd_OTHER_OPTIONS (code=exited, status=1/FAILURE)

sept. 06 19:47:13 debian systemd[1]: Starting keep memory of all UPnP devices that announced themselves...
sept. 06 19:47:13 debian minissdpd-systemd-wrapper[9783]: Usage: /usr/sbin/minissdpd [-d] [-6] [-s socket] [-p pidfile] [-t TTL] [-f device] -i <interface> [-i <interface2>] ...
sept. 06 19:47:13 debian minissdpd-systemd-wrapper[9783]:   <interface> is either an IPv4 address with mask such as
sept. 06 19:47:13 debian minissdpd-systemd-wrapper[9783]:   192.168.1.42/255.255.255.0, or an interface name such as eth0.
sept. 06 19:47:13 debian minissdpd-systemd-wrapper[9783]:   By default, socket will be open as /var/run/minissdpd.sock
sept. 06 19:47:13 debian minissdpd-systemd-wrapper[9783]:   and pid written to file /var/run/minissdpd.pid
sept. 06 19:47:13 debian systemd[1]: minissdpd.service: Control process exited, code=exited, status=1/FAILURE
sept. 06 19:47:13 debian systemd[1]: minissdpd.service: Failed with result 'exit-code'.
sept. 06 19:47:13 debian systemd[1]: Failed to start keep memory of all UPnP devices that announced themselves.
dpkg: erreur de traitement du paquet minissdpd (--configure) :
 installed minissdpd package post-installation script subprocess returned error exit status 1
Paramétrage de exim4-config (4.92-8+deb10u2) ...
Paramétrage de exim4-base (4.92-8+deb10u2) ...
Paramétrage de exim4-daemon-light (4.92-8+deb10u2) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Traitement des actions différées (« triggers ») pour systemd (241-5) ...
Des erreurs ont été rencontrées pendant l'exécution :
 minissdpd

Merci pour l’aide


#2

Ca ressemble à ce bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=932138
Essayes sudo dpkg-reconfigure minissdpd en attendant que je creuse.
[edit:]Je ne trouve rien, essaye apt purge minissdpd, en vérifiant bien qu’il ne t’enlève que ça, au moment de confirmer la suppression, et éventuellement réinstalle le aprés.


#3

Salut,

je viens de le réinstaller j’ai toujours le même message.
J’ai essayé : sudo dpkg-reconfigure minissdpd ça me donne : /usr/sbin/dpkg-reconfigure: minissdpd est cassé ou partiellement installé

Lors de l’installation de minissdpd il me demande s’il faut le lancer au démarrage et ensuite il me demande sur quel port.
Donc moi j’ai mis sur ipv6 ?
Aurait-il un lien avec mon VPN ?
Merci pour l’aide


#4

As tu vraiment besoin de minissdpd? c’est pas indispensable
https://packages.debian.org/fr/buster/minissdpd


#5

Je suis assez d’accord avec grandtoubab, peu de monde a besoin de minissdpd. Pour en être sûr , tu liras ceci :

Si tu n’en as pas besoin, tu n’auras qu’à le purger :

apt purge minissdpd


#6

Ou éventuellement, purger, finaliser l’install propre, et tenter de le réinstaller.


#7

Ok,
Je vais m‘en passer puisque ça ne me servira pas.
Merci pour votre aide