Mise à jour de debian buster 10.8

Bonjour tout le monde,
j’ai lancer une mise à jour debian buster 10.8 en tapant apt update ce message d’erreur s’affiche comme suit:

Tous les paquets sont à jour.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://packages.sury.org/php buster InRelease : Les signatures suivantes ne sont pas valables : EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key <deb@sury.org>
W: Impossible de récupérer https://packages.sury.org/php/dists/buster/InRelease  Les signatures suivantes ne sont pas valables : EXPKEYSIG B188E2B695BD4743 DEB.SURY.ORG Automatic Signing Key <deb@sury.org>
W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

quelqu’un peut m’aider à voir ces erreurs
Merci

C’est un problème de clé lié au dépôts de SURY, regarde la procédure pour ajouter correctement ce dépôts.

1 J'aime

Sury n’est pas un dépot de package officiel de debian.

2 J'aime

Bonjour,

justement je veux savoir cette procédure pour régler ce problème de clé, svp si vous pouvez me guider.
Merci

bonjour,
Oui je sais bien mais comment je vais régler ce problème de clé.

Merci

Peut-être en effectuant les opérations recommander sur la documentation :wink:

https://packages.sury.org/php/README.txt

apt-get -y install apt-transport-https lsb-release ca-certificates curl
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
1 J'aime

Merci pour votre aide

Bonjour,

La question date un peu mais ça peut en aider d’autres…

Le problème est que la clef du dépot sury a expiré.
Il suffit donc de supprimer la clef :

sudo apt-key del B188E2B695BD4743

puis d’ajouter la nouvelle :

sudo curl -sSL -o /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg

si curl n’est pas installé faire au préalable :

sudo apt install curl
1 J'aime

Merci @fgerges !