Mise à jour site WEB avec vsFTPd


#1

Boujour all,

J’ai installer et configurer vsFTPd pour mettre à jour deux sites en VirtualHost, à partir du tuto Andesi.

Site 1 : c1.ccpa.fr/
Racine du compte FTP de c1 dans /var/www/c1

Site 2 : c2.ccpa.fr/
Racine du compte FTP de c2 dans /var/www/c2

Tout fonctionne mais je voudrais savoir comme j’ai adapter le tuto à mon cas, si les modif que j’ai apporter ne sont pas des erreurs ou avoir des informations ou des conseilles en plus. :wink:

-= Installation de vsFTPd =-

-= Sauvegarder la configuration par défaut =-

[code]# mkdir /etc/vsftpd

cp /etc/vsftpd.conf /etc/vsftpd.conf.default.bak

cp /etc/pam.d/vsftpd /etc/pam.d/vsftpd.default.bak[/code]

-= Installation libdb3-util pour la création de base de données d’utilisateurs virtuels =-

[code]# apt-get install libdb3-util

mkdir ~/tmp

vi ~/tmp/login.txt

c1
passwd_c1
c2
passwd_c2

db3_load -T -t hash -f ~/tmp/login.txt /etc/vsftpd/login.db

chmod 600 /etc/vsftpd/login.db[/code]

-= Création du fichier PAM =-

[code]# vim ~/tmp/vsftpd.pam
auth required /lib/security/pam_userdb.so db=/etc/vsftpd/login
account required /lib/security/pam_userdb.so db=/etc/vsftpd/login

cp ~/tmp/vsftpd.pam /etc/pam.d/vsftpd[/code]

-= Ajout de l’utilisateur virtuel =-

[code]# groupadd ftp

useradd -g ftp -d /home/ftp/virtual/ virtual

mkdir -p /home/ftp/virtual

chown root.ftp ~virtual/

chmod 2750 ~virtual/[/code]

-= Fichier conf vsftpd =-

[code]# vi ~/tmp/vsftpd.conf
ftpd_banner=Welcome to DS181 FTP service.
listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
guest_enable=YES
guest_username=virtual
chroot_local_user=YES
max_clients=200
max_per_ip=4
secure_chroot_dir=/var/run/vsftpd
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/certs/vsftpd.pem

cp ~/tmp/vsftpd.conf /etc/

/etc/init.d/vsftpd stop

/etc/init.d/vsftpd start[/code]

-= Activation de la configuration per-user =-

[code]# vi /etc/vsftpd.conf

Activer la configuration per-user

user_config_dir=/etc/vsftpd/vsftpd_user_conf

mkdir /etc/vsftpd/vsftpd_user_conf/

/etc/init.d/vsftpd reload[/code]

-= Droit des utilisateurs c1 et c2 =-

[code]# echo “anon_world_readable_only=NO” > /etc/vsftpd/vsftpd_user_conf/c1

echo “write_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c1

echo “anon_upload_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c1

echo “anon_mkdir_write_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c1

echo “anon_other_write_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c1

echo “anon_world_readable_only=NO” > /etc/vsftpd/vsftpd_user_conf/c2

echo “write_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c2

echo “anon_upload_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c2

echo “anon_mkdir_write_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c2

echo “anon_other_write_enable=YES” >> /etc/vsftpd/vsftpd_user_conf/c2

echo “local_root=/var/www/c1” >> /etc/vsftpd/vsftpd_user_conf/c1

echo “local_root=/var/www/c2” >> /etc/vsftpd/vsftpd_user_conf/c2[/code]

J’ai rajouter les deux commandes pour que c1 et c2 est le droit d’écrire dans leur répertoire.

[code]# chown virtual /var/www/c1

chown virtual /var/www/c2[/code]

Merci d’avances.

:wink:


#2

J’ai un petit problème avec la mise à jour avec le compte ftp.

Si je créé un fichier index.html et je upload avec un client ftp dans le compte de c1.
J’ai un message d’erreur.

[code]Forbidden

You don’t have permission to access /index.html on this server.

Apache/2.0.54 (Debian GNU/Linux) Server at c1.ccpa.fr Port 80[/code]

Je regle le problème avec un “chmod -R 755 /var/www/c1” mais le problème revient à chaque modification après upload du serveur par ftp.

:open_mouth:

Je remarque que les fichiers upload sur le compte ftp de c1 sont en -rw------- je pense que le problème est du au droit d’écriture de c1.


#3

Dans mon /etc/vsftpd/vsftpd_user_conf/c1 j’ai ajouter une ligne et maintenant les fichiers et les répertoires on les droits -rw-r–r-- et drw-r–r--.

[code]anon_world_readable_only=NO
write_enable=YES
anon_upload_enable=YES
anon_mkdir_write_enable=YES
anon_other_write_enable=YES
local_root=/var/www/c1

anon_umask=022[/code]

Sa fonctionne mais je sais pas si c’est les bonnes options pour… :unamused: