Mise à niveau et backports [résolu]


#1

Bonjour,

J’envisage une mise à niveau de Stretch vers Buster mais j’ai quelques paquets qui viennent de stretch-backports. Dois-je supprimer ses paquets ainsi que la ligne stretch-backports de mon sources.list avant la mise à niveau ou je peux tout laisser en l’état sans crainte?


#2

S’ils ne sont pas critiques pour le systéme, pas la peine, il sera toujours temps d’installer/downgrader la version pure buster si ils ne marchent pas aprés l’upgrade.
Pour les paquets systéme, un downgrade en stretch avant le dist-upgrade, plutôt qu’une suppression, pour qu’ils se réinstallent en buster dans le processus.


#3

Le souci c’est que ce sont des paquets pour le client nextcloud et qu’ils ne sont présent dans stretch que via les backports. Du coup je pense que je vais les désinstaller le temps de faire la mise à niveau et les remettre ensuite sachant que dans buster le client nextcloud est présent dans les dépots officiels. Je n’aurais alors plus besoin de passer par les backports.


#4

Donc je ne vois pas du tout pourquoi tu veux les désinstaller.
Installe buster: si les paquets nextcloud de main normal sont plus récnts, ils s’installeront, si ils sont incompatibles avec buster, il te le dira et il sera temps de les downgrader en buster, ou si aprés l’install, tu découvres qu’ils plante, il sera là encore temps de réinstaller.
Qu’est ce que tu te prends la tête.


#5

J’ai suivi ton conseil et la mise à niveau s’est bien déroulée. Merci!
Cependant suite à cela un nouveau problème m’est apparu.
Je ne parviens pas à lancer synaptic. et lorsque je le fais en CLI j’ai cette réponse:
gksu synaptic
/usr/bin/xauth: file /home/fred/.Xauthority does not exist


#6

“en CLI” c’est

synaptic-pkexec

Cordialement,
Regards,
Mit freundlichen Grüßen,
مع تحياتي الخالصة


F. Petitjean

« On ne perd pas son temps en aiguisant ses outils. »
Proverbe français

« Moi, lorsque je n’ai rien à dire, je veux qu’on le sache. » (R. Devos)


#7

Voici le retour:
$ synaptic-pkexec
No protocol specified
Unable to init server: Impossible de se connecter : Connexion refusée

(synaptic:2689): Gtk-WARNING **: 19:17:28.708: cannot open display: :0


#8

Il semblerait qu’il y ait une incompatibilité entre wayland et synaptic puisqu’en passant à une session sous X11 tout fonctionne normalement. Existe-il une alternative à synaptic supportée par wayland?


#9

La CLI (Command Line Interface), Synaptic n’est qu’une interface graphique.


#10

J’ai trouvé gnome-packagekit mais je le trouve trop incomplet. Je pense qu’il me faut améliorer ma maîtrise de apt.