Mode console [Résolu]


#1

Bonsoir, je voulais vous demander comment faire pour démarrez en mode console et non en mode graphique avec la Debain !
Habituer à mandriva, je n’ai malheureusement pas trouvé l’emplacement.
Merci d’avance.


#2

il faut faire comme sous mandrake:

éditer le fichier /etc/inittab, et changer l’init par défaut à utiliser. Information a recouper avec les fichiers d’init de gdm/xdm/kdm/whateverstartingx11 ;p

A+


#3

merci de la rapidité de ta réponse mais sous mandrake je choississez en mode graphique le lancement du mode texte sans rien modifier dans inittab et donc je vois pas l’endroit ou je dosi modifié
merci d’avance


#4

control alt f1


#5

merci bien

je vais peut être t’embêter encore un peu mais je voudrais qu’au démarrage du systéme, je démarre en mode console.
alors que là je vais devoir à chaque fois démarrez en mode graphique et ensuite en mode console.
merci bien


#6

[quote=“haross”]merci de la rapidité de ta réponse mais sous mandrake je choississez en mode graphique le lancement du mode texte sans rien modifier dans inittab et donc je vois pas l’endroit ou je dosi modifié
[/quote]
Il est TRES probable que Mandrake modifie ce fameux fichier inittab sans que tu t’en sois aperçu. C’est finalement un inconvénient du paramétrage en mode tout graphique qui ne permet pas réellement de savoir sur quoi (quel(s) fichier(s)) on agit.

Si tu ouvres ce fichier, il te suffit de le lire et tu trouveras à coup sûr l’endroit à modifier :

[quote]# The default runlevel.
id:2:initdefault:[/quote]qui correspond chez moi à un démarrage en mode graphique.


#7

ok merci bien mais je mets cette ligne en commentaire ou je la remplace ?
merci d’avance


#8

"recovery mode "


#9

Les programmes qui se lancent au démarrage sont listés dans le répertoir /etc/rc2.d/ , sous Debian.
Jettes-y un oeil, puis l’autre, tu devrais y voir le gdm, xdm ou kdm qui pose problème.


#10

AMA, le plus simple, c’est de supprimer le “login manager” que tu utilises (xdm, gdm, login.app ou kdm) et ca devrait suffire.
apt-get remove kdm
par exemple.

Si tu veux le conserver mais qu’il ne se lance pas au démarrage, tu mets un “exit 0” au debut du script de lancement (/etc/init.d/kdm par exemple). C’est un peu brutal, mais ça devrait aussi marcher.
Il y a parfois un flag genre ‘ACTIVE=off’ à mettre dans /etc/default/?dm, mais ca dépend du ?dm que tu utilises.
Enfin en tout cas, le plus simple, c’est de l’empêcher de démarrer, puisque c’est un de ces programmes qui lance X windows, quoi.


#11

Si tu la commentes, tu auras des soucis.
Il te faut mettre le bon code id qui correspond à ton choix.


#12

Merci de vos réponses je voulais demander à ed comment faire pour retourner en mode graphique une fois qu’on avait fait

ctrl +alt + f1.

Car startx ne marche pas j’ai une erreur à la place qui est celel la :

Merci d’avance !!


#13

[quote=“haross”]je voulais demander à ed comment faire pour retourner en mode graphique une fois qu’on avait fait

ctrl +alt + f1.[/quote]
ctrl + alt + F7


#14

trop sympa gros merci !!


#15

Non, pas gros, … enveloppé :laughing:


#16

mdrrr


#17

Le login graphique peut être supprimant d’un level (level par défaut = 2) en supprimant les références à xdm/gdm/kdm dans /etc/rc?.d ou ? = niveau:

exemple: je suis sous xdm

je vois dans /etc/rc2.d
lrwxrwxrwx 1 root root 13 2003-12-18 17:12 S99xdm -> …/init.d/xdm

Si je supprime ce lien par rm ou par update-rc (cf man, moi je fais rm, c’est + direct), le xdm et X ne seront pas lancés.

Pour remettre le boot, il suffit de refaire le lien.

Pour mettre à jour le level 3, il suffit d’agir sur /etc/rc3.d.

Ça avec² /etc/inittab permet de faire ce qu’on veut