Modem Speedtouch pour Debian !


#1
  • Erf problèm j’ai besoin que vous me guidiez.

J’ai dl le driver “” et le microcode “mgmt.o” "speedmgmt.tar"
Je rajoute les lignes : “none /proc/bus/usb usbdevfs defaults 0 0” dans “etc/fstab”

ensuite je décompresse speedtouch-1.3.1.tar dans /usr/share/doc/speedtouch/mgmt.o
jy ai même installé speedtouch_1.0-1.1rc2-1_i386.deb
je lance le script “adsl-conf-pppd” qui me posera des question sur mon login : fti/xxxxx@fti
pass: xxxxxx
8.85 pour le vpi … comme indiqué

Bon ensuite je fais : modem_run -s -m -f /usr/share/doc/speedtouch/mgmt.o

MON MODEM CLIGNOTE ! C’est génial !
mais après avoir tapé “pppd call adsl” in the Terminal et avoir fait un ping : ping debian.org =( marche pas !
Même avec Konqueror :-s

Bon j’me suis demandez si celà est à cause de mon installation des driver alors je dl “speedtouch_1.3.1-2_i386.deb” et puis bordel d’ananas voilà ce que j’ia comme erreur dans mon installation : (Reading database … 18679 files and directories currently installed.)
Preparing to replace speedtouch 1.3.1-2 (using …/speedtouch_1.3.1-2_i386.deb) …
Unpacking replacement speedtouch …
dpkg: dependency problems prevent configuration of speedtouch:
speedtouch depends on libc6 (>= 2.3.2.ds1-4); however:
Version of libc6 on system is 2.2.5-11.5.
dpkg: error processing speedtouch (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
speedtouch

Enfin pourtant sur mon mandrake il suffisait de decompresser et tout mettre dans un fichier précis et de lancer un assistant enfin bon DEBIAN is Very Difficult ^^ Si quelqu’un m’aidait sa serait pas de regret


#2

Bon Debian is not very difficult, it is just very far away from Redmond culture, so you are not as accustomed to it as you are, using Mandrake, mon gars. C’est juste des questions d’habitudes :slightly_smiling:
Par ailleurs, je vois que tu es chez Wanadoo ( dommage :cry: ), et il me semblait que les speedtouch distribués étaient supportés en direct dans le noyau de distrib debian… Mais bon. En plus, je ne sais pas ou tu as récupèré ton paquetage , mais ca ne me viendrait JAMAIS à l’idée d’installer les paquetages distribués par un FAI…
Sinon, pour ton pb, comme le message apt te l’indique, ta version de la libc6 est trop ancienne pour le paquetage que tu a sélectionné.
La gestion des .deb ne se fait pas du tout comme celle des rpm.
Sous debian, on évite d’importer un paquetage récupèré on ne sais ou pour l’insèrer dans le systeme, on essaye toujours d’abord d’installer en ligne la version qui correspond a la distrib qu’on utilise:
as tu essayé de faire un

apt-get install speedtouch

(qui télécharge et installe le paquetage speedtouch_X.Y.Z*.deb correspondant à ta config) ?
Si le paquetage existe dans les sources de mise à jour de ta machine, cela installera automatiquement LE paquetage compatible avec ton installation courante.
Sinon, il faut faire une mise à jour de ta libc6 (attention, ce n’est pas anodin, car la libc6 est au coeur de linux, donc à éviter sur une machine de production sans raison impérative):

apt-get update

(màj de la base de donnée des paquetages dispos)
aprés, plusieurs options:

apt-get upgrade

pour faire une mise à jour globale de ton système

apt-get install libc6 (–reinstall si tu as besoin de forcer)

Si la version que tu cherche n’apparait pas dans les mises à jour qui s’effectuent, c’est que tu es sur une debian un peu trop ancienne pour installer le paquetage speedtouch que tu as récupèré. Si tu es en stable sur une machine perso, tu peux passer sans grand risque en testing, mais c’est une autre histoire. Tu me diras si c’est nécessaire, et je t’indiquerais si tu le souhaites la marche à suivre
++