Mon royaume pour un clavier !


#1

bonjour,

j’ai installe Debian etch recement, et le probleme est que je n’arrive pas a avoir un clavier normal. En effet, toutes les touches qui requierent qu’on appuie sur shift ou altgr pour sortir un caractere ne fonctionnent pas. Par exemple, impossible de sortir des lettres accentuees, des dieses, des accolades, des point d’interrogation, des slash, etc. Pour autant le clavier est bien en azerty.

J’ai bien essaye de faire un “dpkg-reconfigure xserver-xorg” en reglant comme cela me semblait le plus logique, mais sans resultat probant…

Si quelqu’un a une solution je suis preneur, et excusez moi du manque d’accents dans mon message.


#2

tu as essayé un dpkg-reconfigure locales
que te renvoi la commande locale


#3

envoie :
/etc/X11/xorg.conf


#4

[quote=“Ashgenesis”]tu as essayé un dpkg-reconfigure locales
que te renvoi la commande locale[/quote]

oui j’ai essaye, mais ca n’a pas l’air de changer grand chose.

debian:/home/misssardonik# locale
LANG=fr_BE@euro
LANGUAGE=fr_FR:fr:en_GB:en
LC_CTYPE="fr_BE@euro"
LC_NUMERIC="fr_BE@euro"
LC_TIME="fr_BE@euro"
LC_COLLATE="fr_BE@euro"
LC_MONETARY="fr_BE@euro"
LC_MESSAGES="fr_BE@euro"
LC_PAPER="fr_BE@euro"
LC_NAME="fr_BE@euro"
LC_ADDRESS="fr_BE@euro"
LC_TELEPHONE="fr_BE@euro"
LC_MEASUREMENT="fr_BE@euro"
LC_IDENTIFICATION="fr_BE@euro"
LC_ALL=[/code]


[quote="ricardo"]envoie :
/etc/X11/xorg.conf[/quote]

[code]debian:/home/misssardonik# cat /etc/X11/xorg.conf
# xorg.conf (Xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum
#   dpkg-reconfigure xserver-xorg

Section "Files"
        FontPath        "unix/:7100"                    # local font server
        # if the local font server has problems, we can fall back on these
        FontPath        "/usr/lib/X11/fonts/misc"
        FontPath        "/usr/lib/X11/fonts/cyrillic"
        FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/Type1"
        FontPath        "/usr/lib/X11/fonts/CID"
        FontPath        "/usr/lib/X11/fonts/100dpi"
        FontPath        "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        Load    "dri"
        Load    "evdev"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "type1"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "latin-1 fr"
        Option          "XkbVariant"    "latin9"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "false"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "ATI Technologies, Inc. R430 [Radeon X800 XL] (PCIe)"
        Driver          "vesa"
EndSection

Section "Monitor"
        Identifier      "�ran g��ique"
        Option          "DPMS"
        HorizSync       28-49
        VertRefresh     43-72
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. R430 [Radeon X800 XL] (PCIe)"
        Monitor         "�ran g��ique"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

voila…


#5

Ds Imput device, au lieu de
Option “XkbLayout” "latin-1 fr"
mets
Option “XkbLayout” "fr"
et commente (mettre un ‘#’ en tête de ligne)
# Option “XkbVariant” “latin9”


#6

J’ai fait ça, et il semble que ça fonctionne, j’ai maintenat accès à tous les caractères, un grand merci, donc.

Par contre, un autre problème moins grave est apparu, je ne sais pas si c’est lié: dans la console maintenant j’ai une police toute bizarre toute pixélisée pas lisible du tout. Une solution ?