Moniteur + sortie TV ATI radeon 9200 SE


#1

Salut à tous
Je cherche comment faire pour utiliser la sortie TV de ma carte ATI 9200 SE?
J’utilise Xfree avec le driver radeon
J’ai déjà modifié le fichier XF86Config-4 pour déclarer mon ecran et ma sortie. Cela fonctionne en partie car ma souris peut sortir de mon moniteur, mais l’ecran de TV reste noir.


#2

Est-ce que le driver ati est obligatoire ou peut on utiliser le driver de X?


#3

le driver propriétaire ati le fait trés bien.
tu devrais pas avoir trop de mal à trouver un lien dans ceforum qui t’explique comment faire


#4

Oui j’ai vu un tuto dans trucs et astuces je vais retourné faire un tour.
Merci pour l’info


#5

Bon j’ai installé le driver en suivant le tuto.
Tout c’est bien passé, mais la TV reste noir! :cry:


#6

montres ton xorg.conf


#7

Je suis sous xfree, mais c’est pire que cela!
Au redemarrage du serveur j’ai 2 ecrans noirs!
Au redemarrage du PC j’ai le bios sur la TV puis le moniteur redevient ecran principal (du moins j’ai le bureau dessus). Si on peut appeler cela un bureau c’est tout crade avec des merdes un peu partout sur la tele c’est pire! En plus il me fout les gammas a fond j’eclaire tout le salon!


#8

montres ta conf xorg ou xfree m’en fout !!! :smiling_imp:


#9
# XF86Config-4 (XFree86 X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
#   md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
#   dpkg-reconfigure xserver-xfree86

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig Screen 0" 0 0
	Screen         "aticonfig Screen 1" Above "aticonfig Screen 0"
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"
EndSection

Section "Files"

			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath     "unix/:7100"
	FontPath     "/usr/lib/X11/fonts/misc"
	FontPath     "/usr/lib/X11/fonts/cyrillic"
	FontPath     "/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath     "/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath     "/usr/lib/X11/fonts/Type1"
	FontPath     "/usr/lib/X11/fonts/CID"
	FontPath     "/usr/lib/X11/fonts/Speedo"
	FontPath     "/usr/lib/X11/fonts/100dpi"
	FontPath     "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
	Load  "GLcore"
	Load  "bitmap"
	Load  "dbe"
	Load  "ddc"
	Load  "dri"
	Load  "extmod"
	Load  "freetype"
	Load  "glx"
	Load  "int10"
	Load  "record"
	Load  "speedo"
	Load  "type1"
	Load  "vbe"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "keyboard"
	Option	    "CoreKeyboard"
	Option	    "XkbRules" "xfree86"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "fr"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "ImPS/2"
	Option	    "Emulate3Buttons" "true"
	Option	    "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
	Identifier   "L1915S"
	HorizSync    30.0 - 83.0
	VertRefresh  56.0 - 75.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "TV"
	HorizSync    31.5 - 31.5
	VertRefresh  50.0 - 70.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "aticonfig Monitor 0"
EndSection

Section "Monitor"
	Identifier   "aticonfig Monitor 1"
EndSection

Section "Device"
	Identifier  "ATI Technologies, Inc. RV280 [Radeon 9200 SE]"
	Driver      "radeon"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "ATIDriverTV"
	Driver      "radeon"
	BusID       "PCI:1:0:1"
	Screen      1
EndSection

Section "Device"
	Identifier  "ATI Graphics Adapter 0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "ATI Graphics Adapter 1"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
	Screen      1
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "ATI Technologies, Inc. RV280 [Radeon 9200 SE]"
	Monitor    "L1915S"
	DefaultDepth     24
	SubSection "Display"
		Depth     1
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     4
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     15
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Screen"

    #Option "backingstore"
	Identifier "Screen1"
	Device     "ATIDriverTV"
	Monitor    "TV"
	DefaultDepth     24
	SubSection "Display"

  # initial origin if mode is smaller than desktop
#        Virtual     1280 1024
		Viewport   0 0
		Depth     16
		Modes    "800x600"
	EndSubSection
	SubSection "Display"

  # initial origin if mode is smaller than desktop
#        Virtual     1280 1024
		Viewport   0 0
		Depth     24
		Modes    "800x600"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig Screen 0"
	Device     "ATI Graphics Adapter 0"
	Monitor    "aticonfig Monitor 0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig Screen 1"
	Device     "ATI Graphics Adapter 1"
	Monitor    "aticonfig Monitor 1"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Mode         0666
EndSection

J’avais déjà essayé de rajouter ma TV “a la main” Je pense que ca a fouitu la merde.


#10

remplaces:[code]Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "aticonfig Monitor 0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig Screen 1"
Device "ATI Graphics Adapter 1"
Monitor "aticonfig Monitor 1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection[/code]par[code]Section "Screen"
Identifier "aticonfig Screen 0"
Device "ATI Graphics Adapter 0"
Monitor "L1915S"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig Screen 1"
Device "ATI Graphics Adapter 1"
Monitor "TV"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection[/code]


#11

Oui, mais j’ai aussi 4 “device” de déclarés est-ce qu’il ne faut pas en enlever 2?
Idem pour les “monitor” et “screen”?


#12

C’est pas grave: c’est le “Layout” qui compte (et comme tu n’en as qu’un, pas d’ambiguité possible), les déclarations superflues ne sont pas utilisées…


#13

J’ai essayé les modifs mais ca plante le serveur x.
J’ai fait des “tests” et voila les resultats:
Si je demarre avec 1915 + TV = Bios sur TV + affichage de merde + fond d’ecran sur TV
Si je demarre avec 1915 seul = Affichage normal mais pas de fond d’ecran
Idem pour redemarrage du serveur x seulement.
Sous win il arrive qu’après un “plantage” ce soit la TV qui soit considérée comme moniteur principal mais cela se règle tout seul aprèsle bios pendant le demarrage. Je ne pense donc pas avoir besoin de modifer quelque chose dans le bios. Quel parametre peut me permettre de definir l’ecran principal? Normalement cela devrit se faire tout seul si il considere un moniteur et une TV?


#14

:blush: La même chose sans tenir compte du fond d’ecran…


#15

Il n’y a pas vraiment de notion d’écran “Principal” sous linux.
En console, c’est le premier device (carte graphique) détecté sur lequel s’affiche le prompt. Si l’ordre ne plait pas on doit jouer avec l’ordre de chargement des modules.
Le twinview nVidia fonctionne en mode clone, à priori, en mode console.

Ensuite, ce qui se passe sous X est indépendant de ce que tu as en console.
Les tests, tu les a faites avec la config sans les modifs ?


#16

Oui avec la modif ca ne passe pas du tout le serveur x ne demarre pas.
Est-ce que je ne devrais quand meme pas “nettoyer” le fichier de config?


#17

Et tu as besoin d’une bénédiction pour essayer ?


#18

Est-ce que cela en est une?
En fait j’ai déjà fait plusieurs essais qui ont f…


#19

Voila j’ai fini le menage.
Ca fonctionne bien avec le moniteur seulement, mais avec les 2 c’est pas beau.
C’est comme si les 2 ecrans etaient superposés et que la configuration de la TV n’était pas bonne.
J’ai essayé de changer les option dans le serverlayout mais cela n’a rien donné

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig Screen 0" 0 0
	Screen         "aticonfig Screen 1" 1280 0
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"
EndSection

L’option de base était “aticonfig Screen 1” Above "aticonfig Screen 0"
J’ai essayé RightOf et 1280 0 mais cela ne change rien.

De meme dans le tuto d’Alexis de Lattre on trouve

Option "OffTime" "20" 

Pour regler le temps avant la mise en veille de l’ecran, mais cette otpion n’est pas prise en compte.

Ou puis-je trouver les fichiers de config pour ces éléments?