Montage de dossier reseau

Tags: #<Tag:0x00007fb16cdad570> #<Tag:0x00007fb16cdad138>

Bonjour à tous!
Ayant eu quelques soucis sur mon serveur la semaine passée je me suis décidé ce matin à le formater et réinstaller.
J’ai donc une installation neuve avec Buster dessus.
Je cherche à monter mes disques réseau comme j’avais précédemment.
J’ai installé Samba, instauré mes 3 lignes dans mon fichier Fstab (récupéré dans l’instal précédente). mon fstab :
GNU nano 3.2 /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=dd54eb40-5110-4716-acec-02685618539f /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=68FA-DB34  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/sda3 during installation
UUID=1b72b48e-e157-4d64-94c0-762d5dcff02d none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
//192.168.1.197/family    /media/documents        cifs    guest,iocharset=utf8,gid=100,uid=1000,_netdev   0       0
//192.168.1.1/hdd_asus  /media/documents2       cifs    guest,iocharset=utf8,gid=100,uid=1000,_netdev   0       0
//192.168.1.1/Lacie /media/documents3       cifs    guest,iocharset=utf8,gid=100,uid=1000,_netdev   0       0    

J’ai créer les dossier dans lequel ils doivent être montés. J’ai une erreur lors du

root@jeedomplex:/home/jeedomplex# mount -a mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Quelqu’un pour m’aider à me dépatouiller?
merci!

Dans un point de montage CIFS tu dois t’authentifier auprès du serveur distant.
C’est ce qu’il te manque dans tes parametres avec l’option:

credential=<path vers le fichier de credentials>

et le fichier de credential contient:

username=<username>
password=<mot de passe>
domain=<domaine windows si tu en utilise un sinon pas besoin de cette ligne>

de mere ajoute, pour des raison de performance l’option de version SMB en 3.0

vers=3.0

ce qui donnerais par exemple:

//192.168.1.197/family    /media/documents        cifs    guest,iocharset=utf8,gid=100,uid=1000,_netdev,credentials=/home/monuser/.moncred,vers=3.0   0       0

Merci pour ta réponse!
par contre je pige pas tout j’ai pas vraiment le cerveau d’un codeur :wink: Le fichier credentials c’est quoi exactement? je n’ai qu’a créer un fichier avec nano et y mettre ce que tu m’ donné?
Le fait de passer en smb3 ne peux pas induire des incompatibilité? (sinon… pourquoi on utilise encore le smb2?)

Ok je comprends mieux le credentials…
Juste une question encore : dans le credentials c’est le user et password de débian?
Les emplacements réseau que j’essaye de monter sont en accès libre(en local) sans login ni password…

le cas échéant tu devrait avoir un message en te connectant ou dans les logs (vu que c’est via /etc/fstab) qui indiquera que tu es en version 1. Au pire tu teste et sauras tout de suite. Chez moi, la différence de performance est très perceptible en tout cas.

Non c’est le compte utilisateur de samba.

Alors tu devrais pouvoir te connecter sans l’option credential je pense.

je me disais aussi… sinon ça n’aurait pas fonctionné jusqu’ici sur l’ancienne installatio… mais du coup si ne n’est pas le credential… c’est du à la version de smb? je vais rajouter vers=3.0 dans mon fstab et retester

hum… non ce n’est pas encore ça… toujours la même erreur…

sinon… créer un fichier credentials vide?bonne idée?

A tester, mais je ne pense pas que ca marche. Car lui disant d’utiliser un login et un mot de passe, il en voudra un. Il suffit donc juste d’enlever l’option credential.
Tu peux essayer d’utiliser l’option sec=none aussi.

Concernant tes options, gid, uid et guest ne sont pas pertinentes à moins que ton serveur ne soit pas capable de fournir les informations de propriété.
gid et uid sont normallement lié à debugfs ou devpts je crois.

Si tu veux que les user puissent utiliser les point de montage, l’option user suffit. Quand à iocharset, mieux vaut laisser faire le serveur à l’autre bout et ton locale. A moins que ton serveur ne gère pas bien.

Pour la version, SMB a été introduit dans Windows 8 et Server 2012. Si tes serveurs sont des serveurs Samba, jette un oeil sur leur paramètre.
Ceci dit, normallement, à partir des kernels 4.13 c’est la version 3.0 qui est négociée par défaut.

Pour avoir plus d’info en faisant un montage manuel (avec mount -t cifs …) utilise l’option --verbose pour mieux debug.

Et sinon les deux serveurs de fichier, qu’est-ce qu’ils sont?

3 en fait… ce sont juste des disques qui contiennent une bibliothèque multimedia que je lis avec Plex…
Sur les 3 il y a
un nas Lacie, deux disques dur connecté en direct sur un routeur asus.
Est-ce normal que les option gid, uid et guest ne soient pas pertinente? ça fonctionnait sur debian 9… avec les même ligne dans mon fstab.

ma ligne devrait donc ressembler à ça ?
//192.168.1.197/family /media/documents cifs user,iocharset=utf8,_netdev,vers=3.0, 0 0

guest c’est pour ne pas avoir à mettre un mot de passe en mettant un user.
sur tes disques connectés au routeur, tout depend des paramètres de ton routeur. Le fait de mettre des gid:uid, ça implique que ceux ci sont les mêmes partout où tu les utilises, sinon d’une machine à l’autre tu risques d’avoir des problèmes.
mais déjà utilise la liogne que tu viens de mettre (teste la avec mount en ligne de commande avant de la mettre dans ton fstab). Ajoute ensuite les options une à une pour voir ce que ça donne.

root@jeedomplex:~# mount //192.168.1.197/family /media/documents
Password for root@//192.168.1.197/family:  ****************
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
root@jeedomplex:~#

et avec mount -t cifs

root@jeedomplex:~# mount -t cifs //192.168.1.197/family /media/documents
Password for root@//192.168.1.197/family:  ***************
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

es tu sur qu’il n’y a pas un firewall quelque part qui bloque?
utilise l’option --verbose et quels sont les logs sur les serveurs?

voila ce que donne le verbose :

root@jeedomplex:/home/jeedomplex# mount -t cifs //192.168.1.197/family /media/documents --verbose
Password for root@//192.168.1.197/family:  ***************
mount.cifs kernel mount options: ip=192.168.1.197,unc=\\192.168.1.197\family,user=root,pass=********
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Bonjour,

Depuis le début on a toujours la même erreur :
Host is down
Donc, soit les IP ne sont pas les bonnes. À tester avec ping :

ping -c2 192.168.1.197

Et donner au passage :

ip a

Soit les hôtes sont éteints ou sur-protégés par des règles de pare-feu inutiles.

voici ce que donne le ping et le ip a :

root@jeedomplex:/home/jeedomplex# ping -c2 192.168.1.197
PING 192.168.1.197 (192.168.1.197) 56(84) bytes of data.
64 bytes from 192.168.1.197: icmp_seq=1 ttl=64 time=0.214 ms
64 bytes from 192.168.1.197: icmp_seq=2 ttl=64 time=0.192 ms

— 192.168.1.197 ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 2ms
rtt min/avg/max/mdev = 0.192/0.203/0.214/0.011 ms
root@jeedomplex:/home/jeedomplex# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 94:de:80:a5:f4:d8 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.10/24 brd 192.168.1.255 scope global dynamic noprefixroute eno1
valid_lft 70937sec preferred_lft 70937sec
inet6 fe80::96de:80ff:fea5:f4d8/64 scope link noprefixroute
valid_lft forever preferred_lft forever

Comme je le disais dans mes premiers messages j’y ai déjà eu accès dans cette configuration… le seul truc c’est que j’ai changé l’os (passé de debian 9 a 10).
Je pense plutôt à une configuration que j’aurais raté après l’installation de Buster ce qui n’est pas impossible car je ne suis pas codeur, je viens de l’univers win et macos… j’ai dejà fais quelques bricoles sur debian mais je dois avoir raté un truc c’est pas possible…

je viens de tester un truc :
j’ai été sur mon serveur en mode graphique, et j’ai essayé d’accéder a mes disque réseau. Aucuns problèmes j’y ai bien accès.
J’ai essayé d’aller dans mes dossiers documents, documents2 et documents3…

Impossible d'accéder à documents
mount : /media/documents: opération permise uniquement pour root.

Et avec smbclient ?

smbclient -L //192.168.1.197
root@jeedomplex:~# smbclient -L //192.168.1.197
bash: smbclient : commande introuvable

Alors :

apt install smbclient cifs-utils

et réessayer.

root@jeedomplex:~# smbclient -L //192.168.1.197
Enter WORKGROUP\root’s password:

    Sharename       Type      Comment
    ---------       ----      -------
    IPC$            IPC       IPC Service (LaCie-CloudBox)
    FLO             Disk
    pixel2012       Disk
    Family          Disk

Reconnecting with SMB1 for workgroup listing.

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------
    WORKGROUP            JEEDOMPLEX