Monter-afficher les HDD dans l'explorateur de fichiers


#21

Pour la Xeme fois:
ce n’est pas le fait que tes disques soient montés sur des répertoires dans /, le problème.
Peu importe ou tu les mets, le problème vient des droits d’accès configurés pour ton utilisateur normal sur ces données, ou comme je le pensais, de la manière dont tu indiques le chemin à ton logiciel de sauvegarde, mais je le répète encore, ça ne vient pas de l’endroit ou tu as choisi de monter ces partitions, c’est juste certain.

parted/gparted sert à physiquement changer la structure de formatage de ton disque, ça n’a rien à voir avec le probléme.

Tu n’as pas BESOIN de les déplacer, je le répète.
Mais… ça peut régler le problème de refaire ta config de montage des disques à zero.

Voici la manip pour “accrocher” tes disques sur un autre répertoire (un autre chemin) qu’actuellement dans ton arborescence.
Ca ne va rien déplacer, tes deux disques de backup ne seront pas modifiés, ils seront juste accessibles ailleurs que dans /

Mettons par exemple que tu veuilles utiliser /mnt et ranger tes disques dedans.
Dans /mnt tu crées les répertoires ou tu vas accrocher tes disques (avec de meilleurs noms de répertoires que ceux que tu avais choisi):
sudo mkdir /mnt/interne
sudo mkdir /mnt/seagate

Ensuite, tu vas modifier le fichier /etc/fstab pour préciser ou il faut accrocher tes disques, tu remplaces:

# /Back_Up_Interne was on /dev/sdb5 during installation
UUID=df2e3ab0-10f3-4c11-b358-d541737461be /Back_Up_Interne ext4    defaults        0       2
# /Back_Up_Seagate was on /dev/sda1 during installation
UUID=8a545573-927b-4395-91ce-4d6257e99b01 /Back_Up_Seagate ext4    defaults        0       2

par

# /Back_Up_Interne was on /dev/sdb5 during installation
UUID=df2e3ab0-10f3-4c11-b358-d541737461be /mnt/interne ext4    defaults        0       2
# /Back_Up_Seagate was on /dev/sda1 during installation
UUID=8a545573-927b-4395-91ce-4d6257e99b01 /mnt/seagate ext4    defaults        0       2

Ensuite, tu rebootes,

tu vérifies que tes disques sont biens montés comme tu veux:
mount | grep "/mnt"

Si c’est bon, tu peux enlever les vieux répertoires où tu avais accroché tes disques avant:
rmdir /Back_Up_Interne /Back_Up_Seagate

Ensuite vérifie que tu peux y lire:
ls /mnt/seagate

Puis, en user, vérifies que tu peux y écrire:
touch /mnt/seagate/testfichier # pour créer un fichier
ls /mnt/seagate/testfichier # pour vérifier qu’il existe
rm /mnt/seagate/testfichier # pour le supprimer.

Si ensuite, tu as toujours des problèmes avec ta sauvegarde, c’est dans la manière de configurer la sauvegarde qu’il faudra regarder.


#22

Ah oui. Je commence à comprendre :|0
Je vais essayer ce que tu proposes dès que je trouve le temps. Cet après-midi, j’ai mon atelier de dentelle aux fuseaux qui me prend tout mon temps :wink:

Merci pour vos aides très très patientes avec mes pauvres neurones :wink:


#23

Bonjour mattotop,

J’ai enfin pu reprendre les rennes de ma machine.
J’ai effectué les manipulations que tu proposes et ça fonctionne très bien.

MERCI pour ton aide précieuse.