Monter un DVD


#1

Bonsoir,

Comment monter un DVD (de données) sous Linux ???


#2

[quote=“Neuromancien”]Bonsoir,

Comment monter un DVD (de données) sous Linux ???[/quote]
Mon /etc/fstab contient :
/dev/hdc /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
et pour le monter, soit je clique sur l’icône que j’ai mise sur le bureau, soit je fais mount /dev/hdc /mnt/dvd


#3

[quote=“Korben Dallas”][quote=“Neuromancien”]Bonsoir,

Comment monter un DVD (de données) sous Linux ???[/quote]
Mon /etc/fstab contient :
/dev/hdc /dvd iso9660 defaults,ro,user,noexec,noauto 0 0
et pour le monter, soit je clique sur l’icône que j’ai mise sur le bureau, soit je fais mount /dev/hdc /mnt/dvd[/quote]
Le type iso9660 convient pour un CD-ROM, pas pour un DVD. Apparamment, il faut le support du système de fichiers udf. J’ai chargé le module du noyau correspondant. Mais le montage me donne une erreur :

debian:/home/jerome# mount -t udf /dev/hdc /media/cdrom0 mount: block device /dev/hdc is write-protected, mounting read-only mount: wrong fs type, bad option, bad superblock on /dev/hdc, or too many mounted file systems

Un autre problème : malgré l’option noexec dans le fstab, les partitions et CD-ROM sont montés avec le droit en écriture.


#4

et en mettant le type en auto dans le fstab ?


#5

debian:/home/jerome# mount /media/cdrom0 mount: block device /dev/hdc is write-protected, mounting read-only mount: N'est pas un répertoire


#6

C’est curieux, car chez moi, j’arrive sans problème à monter mon lecteur DVD avec mon /etcfstab :open_mouth:


#7

debian:/home/jerome# mount /media/cdrom0 mount: block device /dev/hdc is write-protected, mounting read-only mount: N'est pas un répertoire[/quote]
aurais tu par hasard oublié de créer le point de montage /media/cdrom0 :laughing:
sinon, en le montant ailleurs (tjs en auto) ?


#8

Non, le point de montage /media/cdrom0 existe bien. Une tentative de montage ailleurs donne le même résultat. Je vais essayer avec Knoppix et Yoper.


#9

alors ? ca se monte bien, en livecd ?


#10

Non ! :frowning:


#11

c’est bien détecté par le bios ?
as tu vérifié les nappes et l’alim ?


#12

[quote=“MattOTop”]c’est bien détecté par le bios ?
as tu vérifié les nappes et l’alim ?[/quote]
Le lecteur DVD fonctionne bien, j’ai d’ailleurs pu lire le DVD sous Windows.


#13

il y a quand même un probleme, si tu n’as rien quand tu boote sur livecd…
mais la, plus d’idée…