Multitaches ?


#1

Salut,

j’ai qques soucis sous ma Debian lorsque je lance plusieurs “activitées” en meme temps.
Par exemple, j’ecoute de la musique avec Kaffeine et quand je passe en console et que je fais un apt-get, la musique est toute sacadée.

Autre exemple, je lance le téléchargement d’une distro sur un FTP, le PC rame à 200% tant que le téléchargement n’est pas terminé.

Enfin, je vais par exemple naviguer sur plusieurs onglets avec Firefox. Je lance une recherche sur Google dans le premier, quand j’arrive dans le deuxieme onglet, je tape une nouvelle URL. Là le curseur rame, et je tape dans le vide, le temps que ce monseiur se réveille.

D’ou cela peut venir ?

Merci


#2

je dirais que ca vient du réseau: tous les exemples que tu donnes concernent l’utilisation du réseau en même temps qu’autrechose.
Ca ne m’étonnerais pas que tu aies un modem usb pour ta connection internet, non ?


#3

Il y a aussi les commandes nice et renice qui pourraient t’aider.
Quand une machine est surchargée, ca permet de changer les priorités ente processes. Pendant que tu fais les opérations que tu as décrites, regardes si tu as d’autres jobs qui tournent en arrière-plan et change leur priorité.

man nice et renice


#4

D’ailleurs, une manière de donner une priorité forte à toute l’interface graphique, c’est de speeder un peu Xwindows, en allant dans /etc/X11/Xwrapper.config pour lui préciser une valeur de nice_value négative (personnellement, j’ai mis à -10).
Ceci étant, ce n’est pas normal d’avoir ce genre de pb sur une machine récente. Quoi que doté d’1Go de rambus, mon pIV 1.4, que je charge comme un bourrin (tjs une compil en cours, la télé allumée en permanence, occupation du processeur au taquet en pemanence), je n’ai pas de problème avec le son. J’ai parfois un peu de soucis de réactivité, mais pas les problèmes que décrit evilangel.
Je suis persuadé que le problème vient du réseau (mauvaise gestion de la carte rézo ou du modem).
Je me répète, mais ca sent le modem usb…
Tu as quoi evilangel comme noyau ?


#5

C’es quoi ces attaques sur mon matos réseau :imp: :wink:
Je suis en Wifi pour simplifier les choses sur une connexion FREE 8 Mo.

Pour ce qui est du noyau, c’est un 2.6.10.
Niveau matos, j’ai un Barton 3200+ avec 512 RAM.
Pas de du dernier cris je l’avoue mais pas de quoi s’essoufler pour un ftp.

La derniere fois, que ca a ramé comme ca, je suis allé faire un top pour voir, et surprise le proc était à 9% environ d’utilisation…


#6

bon, vu ta config, c’est vraiment anormal cette histoire…
je ne dis pas que le matériel rezo est en cause (sauf si c’avait été du matos usb), je dis que c’est ca gestion qui est en cause.
As tu regardé si tu avais le même problème avec un noyau plus ancien ?
Sinon, tu utilises un noyau de distrib, ou un noyau compilé par tes soins. Peut etre qu’en touchant le paramètre “preempt” dans ta config noyau, ca amèliorerait les choses, sinon.


#7

Quand ça donne l’impression que ca rame (et que en fait ça rame pas …) c’est effectivement souvent un problème de config. réseau.
Ton /etc/resolv.conf est correctement configuré ?
Autre chose: Est-ce que ton interface ipv6 est activée ? (sit0)
Chez moi, je la vire systématiquement parce que du côté de certaines applications, c’est très mal géré pour l’instant. (mozilla par exemple)


#8

Pour ce qui est du noyau, c’est de la compilation maison.

Pour le /etc/resolv.conf, voici le listing du fichier:

[quote][tequila:/]$ cat /etc/resolv.conf
nameserver 213.228.0.23
nameserver 212.27.39.135[/quote]Les IP sont celles des serveurs DNS de FREE.

Pour d’interface ipV6 activée, enfin je pense.
Voici le listing de mon ifconfig

[quote][tequila:/]$ ifconfig
lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:345 errors:0 dropped:0 overruns:0 frame:0
TX packets:345 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:22321 (21.7 KiB) TX bytes:22321 (21.7 KiB)

wlan0 Lien encap:Ethernet HWaddr 00:0C:41:64:6F:06
inet adr:192.168.0.2 Bcast:192.168.0.255 Masque:255.255.255.0
adr inet6: fe80::20c:41ff:fe64:6f06/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:53019 errors:0 dropped:0 overruns:0 frame:0
TX packets:50730 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:48965219 (46.6 MiB) TX bytes:7396396 (7.0 MiB)
Mémoire:e6000000-e6001fff
[/quote]

Une derniere précision, j’ai la même impression de ramage avec les “bruitages” de KDE. Genre je ferme une fenetre, le petit son arrive un petit moent apres que la fenetre soit fermée.
Idem, si je fais des erreurs dans le shell, le son m’alerte une fois que j’ai dejà rectifié mon erreur.
Il y a comme un temps de latence.


#9

euh jabba, je m’apercois que je ne sais pas désactiver ipv6.
pour le resolv.conf, je préfère utiliser resolvconf, ca marche super bien avec les connections ppp.
sinon, evil, quand tu aura tout testé ailleurs (entre autre l’ipv6 qui m’a l’air une bonne piste) si tu as compilé, regarde les options de processeur, et essayes de te compiler un noyau avec une option preempt desactivée. =>

CONFIG_PREEMPT is not set


#10
pour la Fedora, j'avais modifié le fichier /etc/modprobe.conf comme ça:
alias net-pf-10 off

Pour la Debian, je le vire quand je recompile le kernel, mais on doit aussi pouvoir le désactiver en éditant les fichiers de configuration des modules, je l'ai jamais désactivé comme ça...
[code]pour le resolv.conf, je préfère utiliser resolvconf, ca marche super bien avec les connections ppp. [/code]
Effectivement, j'y pense jamais à ce machin là ...  :unamused:

[code]Pour d'interface ipV6 activée, enfin je pense.
Voici le listing de mon ifconfig [/code]
Tape ifconfig [b]-a[/b] et s'il te donne une interface sit0 avec le status RUNNING, c'est que t'as l'ipV6. 
En tous cas, à l'installation de la Sarge, si tu fais pas une install "expert26", il te colle l'ipV6 par défaut.

pour la Fedora, j’avais modifié le fichier /etc/modprobe.conf comme ça:
alias net-pf-10 off

Pour la Debian, je le vire quand je recompile le kernel, mais on doit aussi pouvoir le désactiver en éditant les fichiers de configuration des modules, je l’ai jamais désactivé comme ça…

Effectivement, j’y pense jamais à ce machin là … :unamused:

Pour d'interface ipV6 activée, enfin je pense. Voici le listing de mon ifconfig
Tape ifconfig -a et s’il te donne une interface sit0 avec le status RUNNING, c’est que t’as l’ipV6.
En tous cas, à l’installation de la Sarge, si tu fais pas une install “expert26”, il te colle l’ipV6 par défaut.


#11

Vérification faite dans mon .config, voilà ce que je trouve:

[quote][tequila:/boot]$ cat config-2.6.10|grep CONFIG_PREEMPT

CONFIG_PREEMPT is not set[/quote] :unamused:

Pour IPv6, bien vu, il n’apparit pas dans ifconfig.
Par contre, ifconfig -a:

[quote]sit0 Lien encap:IPv6-dans-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)[/quote]


#12

[quote=“evilangel”]Vérification faite dans mon .config, voilà ce que je trouve:

[quote][tequila:/boot]$ cat config-2.6.10|grep CONFIG_PREEMPT

CONFIG_PREEMPT is not set[/quote] :unamused:[/quote]

alors c’est l’inverse qu’il faut tester pour toi:
chez moi, c’est en ‘y’

c’est inexact: la ligne
adr inet6: ::1/128 Scope:Hôte
du lo est déjà un symptome que l’ipv6 est actif…
[Jabba]je n’avais pas pensé à désactiver le net-pf-10 avec un alias, merci.


#13

Ben y a pas de quoi, pour une fois que j’arrive à proposer une astuce que tu ne connais pas déjà ! 8)


#14

@MattOTop
Oki, je vais recompiler ce weekend avec l’option PREEMPT

@Jabba
Euh…comment je fais pour désactiver ipv6 car je n’ai pas de fichier /etc/modprobe.conf ? :cry:

merci


#15
Sous Debian, c'est le fichier /etc/modules.conf, tu trouveras la ligne à modifier sous:

[code]# Uncomment the network protocols you don't want loaded:
# alias net-pf-1 off            # Unix
# alias net-pf-2 off            # IPv4
# alias net-pf-3 off            # Amateur Radio AX.25
# alias net-pf-4 off            # IPX
# alias net-pf-5 off            # DDP / appletalk
# alias net-pf-6 off            # Amateur Radio NET/ROM
# alias net-pf-9 off            # X.25
alias net-pf-10 off             # IPv6
[/code]
Ensuite, il faudra redémarrer le réseau ou rebooter la machine

Sous Debian, c’est le fichier /etc/modules.conf, tu trouveras la ligne à modifier sous:

[code]# Uncomment the network protocols you don’t want loaded:

alias net-pf-1 off # Unix

alias net-pf-2 off # IPv4

alias net-pf-3 off # Amateur Radio AX.25

alias net-pf-4 off # IPX

alias net-pf-5 off # DDP / appletalk

alias net-pf-6 off # Amateur Radio NET/ROM

alias net-pf-9 off # X.25

alias net-pf-10 off # IPv6
[/code]
Ensuite, il faudra redémarrer le réseau ou rebooter la machine


#16

tahratata, je ramène ma science, mais c’est inexact. modprobe.conf sert aussi sous debian, mais avec les noyaux 2.6.
(cf debian-fr.org/forum/viewtopi … =5755#5755)

Par contre, il ne s’est pas toujours créé spontanément lors de l’installation d’un kernel-image 2.6 sur une machine seulement configurée pour le 2.4.

De toutes les manières, il suffit de le recopier pour qu’il contienne juste la ligne:

le répertoire /etc/modprobe.d doit exister par contre.

concernant le probleme de la desactivation du net-pf-10, donc, si tu es en 2.4, tu fais la modif que te disait Jabba, et en 2.6, tu crées ton /etc/modprobe.conf, et un /etc/modprobe.d/ip (par exemple), et tu y mets le ‘net-pf-10 off’


#17

Ok MattOTop…

Mais pourquoi cette multitude de fichiers sous Debian ?
Au final, le résultat est le même … Non ?

Je dois dire, que comparé aux Unix traditionnels, Debian me paraît un peu brouillon, du moins concernant les modules, justement.

Et tiens, pourquoi pas le désactiver dans ce fichier là:

blackhole:/etc/modprobe.d# pwd
/etc/modprobe.d
blackhole:/etc/modprobe.d# grep ipv6 aliases
alias net-pf-10 ipv6
blackhole:/etc/modprobe.d#

Et tant qu’à faire, pourquoi pas ici pendant qu’on y est:

blackhole:/lib/modules/2.6.8-2-386# pwd
/lib/modules/2.6.8-2-386
blackhole:/lib/modules/2.6.8-2-386# ls
boot    modules.alias   modules.ieee1394map  modules.pcimap   source
initrd  modules.ccwmap  modules.inputmap     modules.symbols
kernel  modules.dep     modules.isapnpmap    modules.usbmap
blackhole:/lib/modules/2.6.8-2-386# grep ipv6 modules.alias
alias net-pf-10 ipv6
blackhole:/lib/modules/2.6.8-2-386#

Eh ben, continue ! Je me pose encore passablement de questions sur le sujet… :slightly_smiling:

Mais bon, je vais retourner sur ton lien pour relire ta doc… :confused:


#18

ca se discute: l’eclatement d’un grand fichier d’alias en plusieurs petits fichiers permet par exemple de créer des fichiers de config partiels, embarqués avec le paquetage.
Sinon, c’est comme toujours dans /etc que se trouvent les fichiers à configurer, et à priori pas ailleurs. C’est une convention.


#19

Alors, si j’ai bien tout compris, moi qui ai un noyau 2.6, je crée dans mon repertoire /etc/modprobe.d un fichier ipv6 dans lequel je met juste l’instruction net-pf-10 off.

J’ai fait un /etc/init.d/networking restart.
Quand je fais ipconfig -a, j’ai encore:

[quote]sit0 Lien encap:IPv6-dans-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
[/quote]

J’ai raté un truc ? :unamused:


#20

le fichier modprobe.conf avec la directive include ?