Mysql-server : paquet défecteux sur Stretch

Tags: #<Tag:0x00007f78b3fe66a8>

Bonjour à tous.

Je sus me suis installé Debian Jessie puis j’ai installé les dépôts stretch pour passer en testing.
J’ai voulu me ré-installer un lamp local pour reprendre le développement de mon CMS perso : mais apt-get refuse d’installer myql-server. Ce dernier ne serait pas disponible sur le dépôt. :no_mouth:
Mais j’ai l’impression que la commande apt-cache policy n’est pas du même avis.

J’ai déjà consulté des problèmes similaires : mais sans trouver de résultat fonctionnel.
Au fait : est il possible de forcer l’installation d’une version en particulier avec APT ?
Bon, je vais continuer à chercher, à tout hasard…

Merci à toute la communauté. :slight_smile:
Bonne journée à tous.


Dépendances :
Voici le résultat de la commande # apt-get install mysql-server

Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites : 
mysql-server : Dépend: mysql-server-5.5 mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Voici le fichier source.list

# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 DVD Binary-1 20170116-11:01]/   jessie contrib main
# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 DVD Binary-1 20170116-11:01]/ jessie contrib main

deb http://ftp.fr.debian.org/debian/ jessie main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ jessie main non-free contrib
deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ jessie-updates main contrib non-free

# stretch
deb http://ftp.fr.debian.org/debian/ stretch non-free contrib main
deb-src http://ftp.fr.debian.org/debian/ stretch main contrib non-free
deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free    
deb-src http://security.debian.org/debian-security/ stretch/updates main contrib non-free

Et la commande #apt-cache policy mysql-server-5.5

mysql-server-5.5:
Installé : (aucun)
  Candidat : 5.5.54-0+deb8u1
  Table de version : 
    5.5.54-0+deb8u1 500
      500 http://security.debian.org jessie/updates/main amd64 Packages
      100 /var/lib/dpkg/status
    5.5.53-0+deb8u1 500
      500 http://ftp.fr.debian.org/debian jessie/main amd64 Packages

Salut,

Et pourquoi ne pas utiliser MariaDB? J’ai eu aussi un problème d’installation de MySQL sur ma stable il y a peu, et comme MariaDB est compatible à 99%… Qu’il est mieux optimisé… Autant sauter le pas.

Je n’ai plus le lien, mais je crois même me rappeler que le paquet MySQL sera en fait remplacé par MariaDB. En plus, il s’utilise exactement pareil, les commandes reste mysql etc…

koshicalement

C’est un bonne idée, merci. :slight_smile:

J’ai voulu essayé, mais il persiste à jouer les méchants. :confounded:
J’ai voulu forcé mais apt-get -f install me retourne la même chose.

Bonne soirée.


dpkg: erreur de traitement du paquet mariadb-server-10.1 (--configure) :
  le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg: des problèmes de dépendances empêchent la configuration de mariadb-server :
  mariadb-server dépend de mariadb-server-10.1 (>= 10.1.22-1) ; cependant :
  Le paquet mariadb-server-10.1 n'est pas encore configuré.

dpkg: erreur de traitement du paquet mariadb-server (--configure) : 
problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.24-9) ...
Traitement des actions différées (« triggers ») pour systemd (232-19) ...
Des erreurs ont été rencontrées pendant l'exécution :
  mariadb-server-10.1
  mariadb-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et aptitude te propose une solution à ça?

Même chose. C’est le cafouin là dedans… :confounded:
Je suis en train de construire le paquet depuis les sources.
J’espère que ça va marcher. :no_mouth:

J’ai trouvé : c’était une rupture de dépendances : celles ci ne devait pas être à la même version que le paquet mysql-server sur les dépôts.

apt-get remove mysql* --purge
aptitude install mysql-server/stable

Puis choisir la version antérieur du paquet (seconde proposition ).