N100 alder-lake, chargement des drivers wifi et bluetooth échouent

Bonjour, j’ai installé firmware-iwlwifi et bluetooth ne marche toujours pas -pas pu essayé wifi pour l’instant- et je reçois les messages suivant de dmesg:

@84-47-09-37-40-35 ~/D/A/Ada> doas dmesg|grep "failed to load"
[    4.418691] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-86.ucode (-2)
[    4.418730] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-86.ucode (-2)
[    4.418762] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-85.ucode (-2)
[    4.418934] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-85.ucode (-2)
[    4.418965] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-84.ucode (-2)
[    4.418983] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-84.ucode (-2)
[    4.419007] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-83.ucode (-2)
[    4.419025] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-83.ucode (-2)
[    4.419048] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-82.ucode (-2)
[    4.419066] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-82.ucode (-2)
[    4.419098] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-81.ucode (-2)
[    4.419118] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-81.ucode (-2)
[    4.419140] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-80.ucode (-2)
[    4.419158] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-80.ucode (-2)
[    4.419180] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-79.ucode (-2)
[    4.419199] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-79.ucode (-2)
[    4.419221] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-78.ucode (-2)
[    4.419239] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-78.ucode (-2)
[    4.419262] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-77.ucode (-2)
[    4.419279] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-77.ucode (-2)
[    4.419301] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-76.ucode (-2)
[    4.419319] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-76.ucode (-2)
[    4.419341] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-75.ucode (-2)
[    4.419359] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-75.ucode (-2)
[    4.419381] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-74.ucode (-2)
[    4.419399] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-74.ucode (-2)
[    4.419420] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-73.ucode (-2)
[    4.419438] iwlwifi 0000:00:14.3: firmware: failed to load iwlwifi-so-a0-hr-b0-73.ucode (-2)
[    4.429406] iwlwifi 0000:00:14.3: firmware: failed to load iwl-debug-yoyo.bin (-2)
[    4.429416] iwlwifi 0000:00:14.3: firmware: failed to load iwl-debug-yoyo.bin (-2)
[    4.537914] bluetooth hci0: firmware: failed to load intel/ibt-0040-1050.sfi (-2)
[    4.538044] bluetooth hci0: firmware: failed to load intel/ibt-0040-1050.sfi (-2)

Bonjour @evanescenteondine ,

Je suppose que votre carte mère ou que votre environnement sont anciens à moins que ce ne soit la carte ou la clef USB/Bluetooth. Sans autres précisions, il est difficile de faire la part des choses. A titre d’information, la carte mère Asus ProArt avec la Bookworm reconnait automatiquement et sans difficulté le Wifi et le Bluetooth. Quelle version de Debian et quel matériel wifi/bluetooth utilisez-vous ?

Ah mince pardon, je me suis mélangé les pinceaux, je me souvenais faussement avoir écrit ça.
J’ai une toute récente Firebat avec Intel n100 alder-lake, wifi 6 et bluetooth 5 si je me souviens bien.
J’ai installé ma debian récemment:
Linux 84-47-09-37-40-35 6.8.12-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.8.12-1 (2024-05-31) x86_64 GNU/Linux

J’ai lu qu’il y avait des problèmes de driver wifi et bluetooth sur ces derniers modèles sur linux. J’espère qu’il y a une solution.

Que donne :
sudo lshw -C network
et
sudo lshw -C communication

Bonjour,
As-tu installé les firmware backports? ils seront peut etre plus recent.

Dans l’ordre demandé:

drm@84-47-09-37-40-35 ~> doas lshw -C network
  *-network                 
       description: Wireless interface
       product: CNVi: Wi-Fi
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       logical name: wlp0s20f3
       version: 00
       serial: ee:7c:97:f2:6f:9d
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=6.8.12-amd64 firmware=72.daa05125.0 so-a0-hr-b0-72.uc latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: iomemory:600-5ff irq:16 memory:6001144000-6001147fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 15
       serial: 84:47:09:37:40:34
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=6.8.12-amd64 duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.8.121 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:16 ioport:4000(size=256) memory:74504000-74504fff memory:74500000-74503fff
  *-network
       description: Ethernet interface
       product: RTL8125 2.5GbE Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 05
       serial: 84:47:09:37:40:35
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=6.8.12-amd64 firmware=rtl8125b-2_0.0.2 07/13/20 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:17 ioport:3000(size=256) memory:74400000-7440ffff memory:74410000-74413fff

et

drm@84-47-09-37-40-35 ~> doas lshw -C communication
  *-usb:2                   
       description: Bluetooth wireless interface
       product: AX201 Bluetooth
       vendor: Intel Corp.
       physical id: a
       bus info: usb@3:a
       version: 0.02
       capabilities: bluetooth usb-2.01
       configuration: driver=btusb maxpower=100mA speed=12Mbit/s
  *-communication
       description: Communication controller
       product: Alder Lake-N PCH HECI Controller
       vendor: Intel Corporation
       physical id: 16
       bus info: pci@0000:00:16.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=mei_me latency=0
       resources: iomemory:600-5ff irq:138 memory:6001150000-6001150fff

Je ne sais pas pour les backports, mais j’étais tout en testing. Je viens de rajouter les dépôts unstable maintenant… et ça vient de rendre le paquet firmware-iwlwifi non disponible (« Error: Package ‹ firmware-iwlwifi › has no installation candidate »).

peux-tu essayer
sudo apt-get install bluetooth blueman bluez bluez-obexd bluez-firmware pulseaudio-module-bluetooth gnome-bluetooth-3-common gnome-bluetooth-sendto ubertooth libspa-0.2-bluetooth

Pour le wifi, il faut commencer par tester :

C’est fait. Aucun changement pour le bluetooth.

sur ma bookworm je n’ai pas
iwlwifi-so-a0-hr-b0-##.ucode avec ## >72 mais j’ai iwlwifi-so-a0-hr-b0-72.ucode
or ton dmesg montre quil cherche les ## de 81 à 73 ( pas de chance )

iwl-debug-yoyo.bin : inconnu

ibt-0040-1050.sfi inconnu mais 0040-4150.sfi existe .

peut être voir du côté de trixie :
https://packages.debian.org/search?suite=trixie&arch=any&searchon=contents&keywords=73.ucode
/lib/firmware/iwlwifi-ty-a0-gf-a0-73.ucode firmware-iwlwifi [mipsel]
yoyo.bin et ibt : non
mais ça peut marcher : bootes sur une clé trixie et regarde ce que ça donne.

par contre sur cette page qui correspond à ton probleme

qulqu’un propose de renommer des fichiers ce qui donne sur debian

cp /usr/lib/firmware/intel/ibt-1040-4150.ddc /usr/lib/firmware/intel/ibt-1040-1050.ddc
cp /usr/lib/firmware/intel/ibt-1040-4150.sfi /usr/lib/firmware/intel/ibt-1040-1050.sfi

un autre propose de patcher ton noyau ce qui semble correspondre aussi à AUR (en) - iwlwifi-ax101-dkms

Je n’ai aucun fichiers finissant par ddc dans /usr/lib/firmware/Intel/.
Pour le noyau… Au risque de paraître idiot, je ne sais pas du tout quoi faire avec un paquet archlinux :sweat_smile: Je ne sais patcher un noyau. Je lis « dkms » mais le nom du driver ou patch n’est pas vu par apt.

De ce que j’ai pu glaner comme information, il faut au minimum le kernel 6.4 (le prochain à ce jour n’a toujours pas non plus les correctifs :/) et à la main ajouter ce qu’il faut :

Peut-être que ce ne sera pas ok sur le git de kernel.org car il me semble avoir lu que Intel traîner souvent la pattes pour les correctifs :

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/

Du coup plus chez eux pour avoir ce qu’il faut à jour :

https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html

essaie effectivement avec ce lien :

et fais nous savoir si ça marche

Mais je ne sais pas quel driver m’est destiné, hardinfo donne ces informations:

CNVi: Wi-Fi
Wi-Fi 6 AX101NGW

… Mais c’est AX101, pas 201. Une erreur ?

Wifi AX101, bluetooth AX201 :slight_smile:

j’essaierais pour le N100
Intel® Centrino® Wireless-N 100 2.6.37+ iwlwifi-100-ucode-39.31.5.1.tgz

ou peut-être , pour le AX201
Intel® Wi-Fi 6 AX201 160MHz 5.2+ iwlwifi-Qu-48.13675109.0.tgz

mais sans certitude, les driver à l’intérieur n’étant pas ceux demandés dans le dmesg