NAT et OPENVPN

Tags: #<Tag:0x00007fedda18a900>

Bonjour à tous :slight_smile:
Voilà, j’ai configuré ma machine sous Debian 8 comme serveur OPENVPN.
Tout fonctionne bien, mais lorsque je ping une IP précise (ex 192.168.1.200) en continu depuis un poste connecté en VPN (notemment pour tester mes règles) et que je fait la même chose depuis mon serveur (en continu aussi), l’un des eux se coupe en alternance. En gros, c’est soit l’un, soit l’autre.

Voici ma config NAT et FORWARD IPTABLES :

iptables -t nat -A POSTROUTING -s 10.10.10.0/24 -o eth0 -j MASQUERADE
iptables -P FORWARD ACCEPT

Je pense que c’est un problème de NAT …
Si quelqu’un à une idée ?

Merci d’avance :slight_smile:

Peux-tu détailler “se coupe en alternance” ?
Pas de limitation du ping sur une des machines ?
Fournir les tables de routage du client, du serveur et de la cible du ping ?
Le client est dans le même réseau local que les deux autres ?

Alors imaginons que je sois en SSH sur mon serveur openvpn (en local, pas en VPN).
Je suis aussi connecté en même temps en VPN avec un poste (imaginons qu’il soit connecté à l’extérieur).
Depuis le PC en VPN (donc à l’exterieur de mon réseau mais connecté au VPN), je ping en continu une ip quelconque de mon réseau (ici mon NAS).
Pendant que le PC ping, je fais exactement la même chose au même moment depuis le serveur openvpn via mon shell en SSH.
Et la, le ping de mon poste qui est en VPN se coupe. Si j’arrête le ping depuis mon serveur openvpn, le ping refonctionne depuis le poste qui est connecté en VPN.
Il n’y a pas de limitation car quand j’arrête le ping sur l’un, ça refonctionne sur l’autre.
Ça fait pareil pour n’importe quel IP de mon réseau

C’est justement le principe d’une limitation : si on limite à 1 par seconde et qu’on envoie 2 fois 1 par seconde (donc 2 par seconde), il y en a seulement un qui passe.

A part ça, je ne vois pas . Il faudrait faire une capture du trafic à différents points du chemin pour voir où ça coince : aller, retour, serveur VPN, cible…