Navigation ftp impossible avec plusieurs serveurs FTP


#1

Euh j’ ai un problème qui est plutôt relou …
J’ ai un serveur ProFTPd avec support MySQL, en local il fonctionne parfaitement, par contre via internet c’ est une autre histoire.
Les gens peuvent se connecter mais il ne peuvent pas par exemple naviguer ou utiliser une commande, ils se mangent un timeout etc …

[code]
yafc 1.1 Copyright © 1998-2001 Martin Hedenfalk mhe@home.se.
This program comes with ABSOLUTELY NO WARRANTY; for details type ‘warranty’.
This is free software; type ‘copyright’ for details.

Connecting to www.goldzoneweb.info (82.232.48.84) at port 21…
FTP 24/7 GoLDZoNE
Bienvenue GoLD sur GoLDZoNE Web HoSTING
remote system: UNIX Type: L8
yafc GoLD@www.goldzoneweb.info:/> ls[/code]

Ayant mis un serveur dns en place je me suis dis que j’ avais merdé alors le l’ ai stoppé mais c’ est toujours le même résultat :confused:

Mon resolv.conf


192.168.0.1
= mon routeur.

J’ ai le même problème avec PureFTPd

Merci d’ avance pour votre aide. :wink:


#2

ton routeur, c’est un routeur linux ?
si oui, verifies que le module ip_nat_ftp est bien présent.
si ca ne fonctionne toujours pas, essayes, depuis l’exterieur, de faire ton ftp en mode passif (quote PASV aprés le login).


#3

slt,

Si ca marche en local je pense que ca doit venir da ta connexion essaie de mettre les dns de ton fai dans /etc/resolv.conf et ou essaie de voir dans quel mode ftp tu es passif ou actif.


#4

MattOTop : J’ ai un routeur Netgear :slightly_smiling:

--> [www.goldzoneweb.info] PASV <-- [www.goldzoneweb.info] 227 Entering Passive Mode (82,232,48,84,231,89).

stonfi : En mettant les DNS de Free ça fonctionne toujours pas :confused:

Edit :

Jvais me rensigner sur le mode actif/passif

Edit 2 :

Avec le client ftp ça fonctionne, avec yafc ça merde. Avec tout les clients graphiques que j’ ai essayé ça merde aussi (gftp, flashxp).


#5

Hum bon en ajoutant PassivePorts 40000 50000 dans mon proftpd.conf ca fonctionne :slightly_smiling:.

Merci de m’ avoir mis sur la piste MattOTop. Mais avoir autant de ports ouverts c’ est pas un peur risqué ?


#6

non, si ton serveur monte en charge, tu en aura besoin car je crois me souvenir que chaque flot de données ftp utilise un port.
PS: tu n’as rien d’autre que des jeux de guerre sur ton site ?
PPS: le liens “telechargement debian” ( goldzone.homelinux.org/index.php … ets_debian ) renvoie direct sur ta page d’accueil.


#7

Oki merci pour l’ info.
Euh sinon sur mon site ben euh :unamused: . Donne moi le nom d’ un jeu qui peut avoir son serveur hébergé sous Linux et je l’ ajoute :stuck_out_tongue:


#8

Comme ça ? de tête ?
Tous les MUDs (je sais, c’est pas bô).
50 000 jeux d’echecs, de dames, tuxracer et xpilot, je crois.
NeverWinterNights, si je me souviens bien, euh…
FreeCIV ? :laughing:
Bon, mais j’y retourne: en cherchant des reponses à cette question, j’ai commencé à éplucher les jeux sur freshmeat tuxgames et slashdot, et du coup j’ai plein de choses à tester…


#9

Oh un serveur Tux Racer !!!
NeverWinterNights j’y avais pas pensé :slightly_smiling:


#10

Sympa ton site, ca me redonne envie de jouer :smiley:


#11

Sinon, pour le ftp j’ai une question:
Je suis en train de préparer un nouveau serveur FTP au boulot. Je vais justement y mettre ProFTP.
Ca sera sous Solaris 10 (aie aie aie, il faudra reboucher tous les trous encore béants… :angry: Mais bon je dois m’y mettre à Solaris 10 …)
J’ai récupéré une vieille Netra Sparc avec 1 GB de Ram.
Il me semble que c’est largement suffisant, pour prévoir un grand nombre de connexions simultanées, qu’en pensez-vous ?


#12

Merci pour le site :slightly_smiling:
Sinon je pense que 1Go de ram ca devrait quand même suffir (dans les limites du raisonnable) :mrgreen:

Sinon moi j’ ai un autre soucis avec ProFTPd …
Ca me le fait seulement qu’ avec une seule personne. Quand elle se connecte le serveur FTP se stop :open_mouth:
Je ne vois rien dans les logs :confused:


#13

Et t’as rien configuré au niveau de Tcp Wrappers ?


#14

Euh nan je sais même pas ce que c’ est :confused:


#15

Quand tu dis qu’il se stoppe et que tu n’as rien dans les logs, tu veux dire que tu n’as plus de process, et pas de trace d’arret dans les logs ?
Et quand tu le redémarres, il ne râle pas à propos d’un verrou restant, ou un truc comme ça ?


#16

Ben en fait une fois qu’ il a essayé de se connecter, si je tape ça :

J’ ai le droit à une erreur 421 … Mais j’ ai plein de processus avec son IP.
Quand je fais un :

Nan il ne râle pas.

Sinon pour le TCP/Wrapper j’ ai trouvé ça :
http://www.linux-kheops.com/line/html/line/line-dec1996/datas/wrapper.htm


#17

[quote=“goldyfruit”]Ben en fait une fois qu’ il a essayé de se connecter, si je tape ça :

J’ ai le droit à une erreur 421 … Mais j’ ai plein de processus avec son IP.[/quote]l’IP de quoi ?
ce que je demandais, c’est si ‘ps aux | grep proftpd’ te renvoyait des processus à ce moment là.

[quote=“goldyfruit”]Quand je fais un :

Nan il ne râle pas.[/quote]
Si il n’y a pas de processus apparaissant dans le ps, il doit râler si tu fais un start (pas un restart).
Mais bon, ca veut juste dire que le processus se termine brutalement.
Tu as essayé de passer un argument à proftpd pour qu’il démarre en mode super verbeux (sans doutes -v ou -d pour debug).

[quote=“goldyfruit”]Sinon pour le TCP/Wrapper j’ ai trouvé ça :
http://www.linux-kheops.com/line/html/line/line-dec1996/datas/wrapper.htm[/quote]Oui, je ne voyais pas ce que voulais dire Jabba, mais ca ne te concerne pas: il y a deux manière de démarrer la plupart des services, par inetd, ou en mode autonôme avec un script en init.d. Si tu utilises l’inetd, tu peux utiliser les wrappers, mais toi tu es configuré en mode autonôme pour proftpd donc ca ne te concerne pas.


#18
 :open_mouth: Matt: et tu as vu oû qu'il est en mode autonome... suis-je myope  :question:  :open_mouth:

:open_mouth: Matt: et tu as vu oû qu’il est en mode autonome… suis-je myope :question: :open_mouth:


#19

Je suis bien en standalone (indépandent).


#20

[quote=“jabba”]Oui, je ne voyais pas ce que voulais dire Jabba, mais ca ne te concerne pas: il y a deux manière de démarrer la plupart des services, par inetd, ou en mode autonôme avec un script en init.d. Si tu utilises l'inetd, tu peux utiliser les wrappers, mais toi tu es configuré en mode autonôme pour proftpd donc ca ne te concerne pas.
:open_mouth: Matt: et tu as vu oû qu’il est en mode autonome… suis-je myope :question: :open_mouth:[/quote][quote=“goldyfruit”]/etc/init.d/proftpd restart[/quote]