Nouveau en Sarge : affichage 1280x1024 impossible


#1

Bonsoir,

Sur les conseils avisés de MattOTop, après avoir fait mes premiers pas Debian sous Knoppix 3.3, je viens d’installer une Sarge en version netinstall.
J’ai configuré le serveur X en utilisant la documentation de mon moniteur, je suis donc certain des fréquences acceptables.
J’ai bien spécifié d’autoriser différents formats d’affichage jusqu’à 1600x1200 mais malheureusement, je n’ai que la possibilité de 1024x768 maximum dans la liste déroulante des options de la résolution de l’écran : c’est pas terrible sur un 19" !

J’ai tenté de copier le fichier /etc/X11/XF86Config-4 de mon ancienne knoppix que j’avais conservé bien au chaud, mais là, le serveur X refuse carrément de se lancer.

Que puis-je faire pour accéder à d’autres formats d’affichage ?

Voici un cours extrait de mon fichier /etc/X11/XF86Config-4 actuel :

Section "Screen" Identifier "Default Screen" Device "ATI RagePro TNT2" Monitor "LG Flatron 915FT Plus" DefaultDepth 24 ... SubSection "Display" Depth 16 Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" EndSubSection SubSection "Display" Depth 24 Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" EndSubSection

Merci d’avance de votre aide.


#2

Bon, après avoir beaucoup tatonné, voici ce qui fonctionne :
Le driver “vesa” que j’avais sélectionné (selon les conseils de debconf à l’installation) ne permet apparemment pas d’afficher au dela de 1024x768, ce qui explique que les autres modes ne soient pas disponibles dans les options d’affichage.
J’ai mis le driver “nv”, qui permettaient tous les modes jusqu’à 1600x1200, mais après, j’avais de fortes instabilités du serveur X.
J’ai résolu ça en supprimant l’entrée “1600x1200” dans toutes les configurations, et maintenant c’est stable.

Je vais pouvoir pauffiner mon installation maintenant.


#3

Bon, rien que de trés normal.
Le vesa, est un serveur “trés” générique donc il est limite a ce que peuvent tenir les moniteurs repondant à la norme “vesa”: l’install te garantissait donc un demarrage compatible, mais c’est sur pas optimal.
L’ideal, avec ta nvidia, c’est :

echo >/etc/X11/XF86Config-4 # tu vide ta config
md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
dpkg-reconfigure xserver-xfree86

pour démarrer ta config à vide.
tu prends un pilote “nv”, des frequences correspondant à ton ecran, et tu actives toutes les options de ton serveur X (la config nvidia de ta knoppix ne pouvait pas fonctionner: elle necessite la desactivation de glcore et dri, qui sont eux, nécessaires à nv).
Mais quand tu auras recompilé ton noyau, tu devra reprendre ton ancienne config de knoppix (gardes celle d’nv, ca peux tjs servir).


#4

Je me suis avancé un peu vite quand j’ai dit que mon problème était résolu. En fait, au démarrage d’application OpenGl, genre l’économiseur d’écran de Gnome par exemple, ça freeze.
Le plus embêtant, c’est que je voudrais désactiver ce genre d’économiseur d’écran, car s’ils sont “jolis”, ils sont pour moi, inutiles : rien ne vaut un bon écran noir dans ce cas.
Mais pour le configurer, il me faut aller dans le menu, et comme il y a un aperçu, ça freeze en quelques secondes :frowning:
Je tourne en rond :open_mouth: