Nouveau sous Debian : aide à l'install [RESOLU]


#1

Je suis loin d’être un expert, il y a à peine qq mois que j’ai découvert Linux. J’ai goûté à Mdk, Fedora2 et Aurox.
Aucun ne me satisfait complètement et comme on m’en a dit du bien, je voudrais tester debian.
J’ai essayé avec le CD de Netinstaller et ma connexion n’ayant pas été reconnue, il ne m’a pas été possible de pousser plus loin que le login. J’ai tenté d’installer le pilote de mon modem : Sagem fast 800 de chez Free 2048 non dégroupé.
Impossible car il n’y a pas à ce niveau de GCC ni CC, ni CL.
On m’a conseillé de telecharger les 4 CD image classique, ce que j’ai fait cet AM.
J’ai tenté l’aventure ce soir mais sans plus de succès.
Arrivé au choix de la gestion des paquets, j’ai mis ‘cederom’ mais j’ai l’impression que ça n’a pas été reconnu car je n’ai eu aucune demande de placer un CD et la suite s’est terminée de la m^ façon qu’avec le Cd Netinstaller.
Comment faire .
Merci de votre aide.


#2

Normalement, quand tu choisis cdrom comme source de paquets, il te demande d’inserer chaque cd pour scanner leurs contenus. s’il ne t’a pas demander, c que tu as du te vautrer quelquepart. Mais si tu arrives au prompt, rien n’est perdu! Tu lances un apt-setup, tu rajoutes tes cds comme sources de packages, et apres il n’y ba plus qu’a installe ton systeme a coup d’apt-get :smiley:


#3

Pas mieux :cry:

J’ai fait apt-get et je me suis retrouvé au m^ point qu’hier:
msg d’alerte :
le prog n’a pas détecté auto le lecteur CD ou pas de CD utilisable ds lecteur.
Veuillez indiquer le nom du périphérique correspondant au lecteur.
Il ya de pré-tapé : /dev/cdrom
je fais OK
je place le CD1 bla-bla 1 minute
si vs avez un autre CD placez-le
OK, CD2, bla-bla, 1 mn
L’outil de gestion des paquets est maintenant configuré et va pouvoir installer 1385 paquets.
Vs pouvez ajouter une autre source pour telecharger …
réponse NON
Faut-il utiliser les MAJ de secu de debian.org si connecté au Net
NON (et pour cause)
Je me retrouve au prompt et c’est tout.
J’ai retenté de configurer mon modem mais sans plus de rslt qu’hier : gcc absent.
J’ai fait apt-get install gcc
et il me l’a installé
Chouette ! :stuck_out_tongue:
Je retente la config du pilote du modem :
Niet ‘C’ = pas bon :cry:


#4

tente ici
people.via.ecp.fr/~alexis/format … linux.html


#5

Installer gcc ne suffit pas pour compiler les pilotes, il faut aussi installer les librairies standards, qui ne s’installent pas par défaut avec gcc (ça c vraiment trop mal foutu)
Le nom du paquet doit être quelque chose du genre libc6-dev


#6

Merci BobX, tt était déjà installé.
Je pense que mon install n’a pas été faite correctement.
Je vais potasser le site indiqué par Ralou et je vais refaire calmement.
Réponse ds qq tps, si je ne me suis pas suicidé :stuck_out_tongue:


#7

grâce à ce tutos, et en le suivant pasd à pas,j’ai installé ma debian

mais bientot sortita le mêm tutos pour la version sarge


#8

C’est la “sarge” que j’ai telechargée.
penses-tu qu’il y une grande différence pour l’install ?


#9

Aucune différence dans l’install. Il ira juste chercher les paquets ailleur.


#10

Merci de la réponse rapide, je pense reprendre mon install dès le début, lundi ou mardi et je vais suivre ce tuto qui a l’air vraiment complet.


#11

Si si, l’installeur de sarge posséde une grosse différence par rapport à celui de la woody : il détecte automatiquement ton matériel et paramétre le noyau en conséquence il me semble. Par contre je ne crois pas qu’il donne un menu pour sélectionner les paquets à installer de base, c pourquoi il faut les installer “à la main”.
As-tu essayé de compiler tes pilotes de modem aprés avoir installé libc6-dev ?


#12

Oui, j’ai fait mais : négatif.
Je pense que j’ai mal rempli tt ce qui concerne la connexion : adresse IP, passerellle, masque.
comment trouver ces infos, avec ifconfig ?


#13

En résumé, tu en es ou ?
Ta debian est installée et compile bien ton module speedtouch ?
Quand tu insere à chaud ton modem en USB, il y a bien des traces de détection dans les logs ?
Quand tu fais un lsmod, tu retrouve bien ton modem ?

Si oui, aprés, il me semble que tu n’as pas à fournir autre chose que ton login et ton passwd, ppp doit te fournir les autres éléments (adresse, dns, etc…).
Qu’est ce que tu as utilisé pour configurer ta connection ?
as tu édité tes fichiers ppp comme conseillé par free ?
(sur support.free.fr/docs/linux/connexion.html )


#14

je ne pense que ça vienne de ta config réseau. Il doit sûrement te manquer des librairies pour pouvoir compiler ton pilote. Le configure te renvoie quoi?