Nouvelle installation : impossible de lancer l'affichage

Tags: #<Tag:0x00007f63e5da48c8> #<Tag:0x00007f63e5da47b0>

Bonjour,
Je viens d’acheter un pc LDLC Aurore NJ5S-16-S9, sans OS afin d’en faire un pc uniquement bootable sous Debian, ayant déjà l’habitude de cet OS.
J’ai donc fait l’installation, en choisissant Gnome comme environnement. Mais lors de l’allumage du pc, rien ne s’affiche. En utilisant les consoles, j’ai pu voir que le serveur X ne réussissait pas à se lancer/configurer.

J’ai écumé les forums une bonne partie de la nuit et de la journée, et je ne parvient pas à trouver une solution à mon problème.

Sortie de lspci

00:00.0 Host bridge: Intel Corporation Device 9b61 (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Device 9b41 (rev 02)
00:12.0 Signal processing controller: Intel Corporation Device 02f9
00:14.0 USB controller: Intel Corporation Device 02ed
00:14.2 RAM memory: Intel Corporation Device 02ef
00:14.3 Network controller: Intel Corporation Device 02f0
00:15.0 Serial bus controller [0c80]: Intel Corporation Device 02e8
00:15.1 Serial bus controller [0c80]: Intel Corporation Device 02e9
00:16.0 Communication controller: Intel Corporation Device 02e0
00:17.0 SATA controller: Intel Corporation Device 02d3
00:1d.0 PCI bridge: Intel Corporation Device 02b0 (rev f0)
00:1d.1 PCI bridge: Intel Corporation Device 02b1 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device 0284
00:1f.3 Audio device: Intel Corporation Device 02c8
00:1f.4 SMBus: Intel Corporation Device 02a3
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 02a4
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
01:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

Fichier Xorg.0.log après startx

[  2002.527] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[  2002.528] Build Operating System: Linux 4.19.0-10-amd64 x86_64 Debian
[  2002.529] Current Operating System: Linux morgoth 4.19.0-11-amd64 #1 SMP Debian 4.19.146-1 (2020-09-17) x86_64
[  2002.529] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19.0-11-amd64 root=/dev/mapper/morgoth--vg-root ro quiet
[  2002.531] Build Date: 27 August 2020  08:51:48AM
[  2002.532] xorg-server 2:1.20.4-1+deb10u1 (https://www.debian.org/support) 
[  2002.533] Current version of pixman: 0.36.0
[  2002.535] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  2002.535] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2002.538] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  7 14:09:06 2020
[  2002.539] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2002.540] (==) No Layout section.  Using the first Screen section.
[  2002.540] (==) No screen section available. Using defaults.
[  2002.540] (**) |-->Screen "Default Screen Section" (0)
[  2002.540] (**) |   |-->Monitor "<default monitor>"
[  2002.540] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[  2002.540] (==) Automatically adding devices
[  2002.540] (==) Automatically enabling devices
[  2002.540] (==) Automatically adding GPU devices
[  2002.540] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2002.540] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  2002.540] 	Entry deleted from font path.
[  2002.540] (==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[  2002.540] (==) ModulePath set to "/usr/lib/xorg/modules"
[  2002.540] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2002.540] (II) Loader magic: 0x565242f3de20
[  2002.540] (II) Module ABI versions:
[  2002.540] 	X.Org ANSI C Emulation: 0.4
[  2002.540] 	X.Org Video Driver: 24.0
[  2002.540] 	X.Org XInput driver : 24.1
[  2002.540] 	X.Org Server Extension : 10.0
[  2002.540] (--) using VT number 1

[  2002.541] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  2002.542] (--) PCI:*(0@0:2:0) 8086:9b41:1558:8686 rev 2, Mem @ 0xb2000000/16777216, 0xa0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/131072
[  2002.542] (II) LoadModule: "glx"
[  2002.542] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2002.542] (II) Module glx: vendor="X.Org Foundation"
[  2002.542] 	compiled for 1.20.4, module version = 1.0.0
[  2002.542] 	ABI class: X.Org Server Extension, version 10.0
[  2002.542] (==) Matched modesetting as autoconfigured driver 0
[  2002.542] (==) Matched fbdev as autoconfigured driver 1
[  2002.542] (==) Matched vesa as autoconfigured driver 2
[  2002.542] (==) Assigned the driver to the xf86ConfigLayout
[  2002.542] (II) LoadModule: "modesetting"
[  2002.542] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  2002.542] (II) Module modesetting: vendor="X.Org Foundation"
[  2002.542] 	compiled for 1.20.4, module version = 1.20.4
[  2002.542] 	Module class: X.Org Video Driver
[  2002.542] 	ABI class: X.Org Video Driver, version 24.0
[  2002.542] (II) LoadModule: "fbdev"
[  2002.542] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  2002.543] (II) Module fbdev: vendor="X.Org Foundation"
[  2002.543] 	compiled for 1.20.0, module version = 0.5.0
[  2002.543] 	Module class: X.Org Video Driver
[  2002.543] 	ABI class: X.Org Video Driver, version 24.0
[  2002.543] (II) LoadModule: "vesa"
[  2002.543] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  2002.543] (II) Module vesa: vendor="X.Org Foundation"
[  2002.543] 	compiled for 1.20.1, module version = 2.4.0
[  2002.543] 	Module class: X.Org Video Driver
[  2002.543] 	ABI class: X.Org Video Driver, version 24.0
[  2002.543] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2002.543] (II) FBDEV: driver for framebuffer: fbdev
[  2002.543] (II) VESA: driver for VESA chipsets: vesa
[  2002.546] (EE) open /dev/dri/card0: No such file or directory
[  2002.546] (WW) Falling back to old probe method for modesetting
[  2002.546] (EE) open /dev/dri/card0: No such file or directory
[  2002.546] (II) Loading sub module "fbdevhw"
[  2002.546] (II) LoadModule: "fbdevhw"
[  2002.546] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  2002.546] (II) Module fbdevhw: vendor="X.Org Foundation"
[  2002.546] 	compiled for 1.20.4, module version = 0.0.2
[  2002.546] 	ABI class: X.Org Video Driver, version 24.0
[  2002.546] (EE) Unable to find a valid framebuffer device
[  2002.546] (WW) Falling back to old probe method for fbdev
[  2002.546] (II) Loading sub module "fbdevhw"
[  2002.546] (II) LoadModule: "fbdevhw"
[  2002.546] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  2002.546] (II) Module fbdevhw: vendor="X.Org Foundation"
[  2002.546] 	compiled for 1.20.4, module version = 0.0.2
[  2002.546] 	ABI class: X.Org Video Driver, version 24.0
[  2002.546] (II) FBDEV(2): using default device
[  2002.546] (EE) Screen 0 deleted because of no matching config section.
[  2002.546] (II) UnloadModule: "modesetting"
[  2002.546] (EE) Screen 0 deleted because of no matching config section.
[  2002.546] (II) UnloadModule: "fbdev"
[  2002.546] (II) UnloadSubModule: "fbdevhw"
[  2002.546] (EE) 
Fatal server error:
[  2002.546] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[  2002.546] (EE) 
[  2002.546] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[  2002.546] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  2002.546] (EE) 
[  2002.553] (EE) Server terminated with error (1). Closing log file.

Fichier Xorg.0.log après X -configure

      [  3571.178] 
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[  3571.178] Build Operating System: Linux 4.19.0-10-amd64 x86_64 Debian
[  3571.178] Current Operating System: Linux morgoth 4.19.0-11-amd64 #1 SMP Debian 4.19.146-1 (2020-09-17) x86_64
[  3571.178] Kernel command line: BOOT_IMAGE=/vmlinuz-4.19.0-11-amd64 root=/dev/mapper/morgoth--vg-root ro quiet
[  3571.178] Build Date: 27 August 2020  08:51:48AM
[  3571.178] xorg-server 2:1.20.4-1+deb10u1 (https://www.debian.org/support) 
[  3571.178] Current version of pixman: 0.36.0
[  3571.178] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  3571.178] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  3571.178] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  7 14:35:15 2020
[  3571.178] (II) Loader magic: 0x5566e9d8ce20
[  3571.178] (II) Module ABI versions:
[  3571.178] 	X.Org ANSI C Emulation: 0.4
[  3571.178] 	X.Org Video Driver: 24.0
[  3571.178] 	X.Org XInput driver : 24.1
[  3571.178] 	X.Org Server Extension : 10.0
[  3571.178] (--) using VT number 1

[  3571.178] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  3571.180] (--) PCI:*(0@0:2:0) 8086:9b41:1558:8686 rev 2, Mem @ 0xb2000000/16777216, 0xa0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/131072
[  3571.180] List of video drivers:
[  3571.180] 	amdgpu
[  3571.180] 	ati
[  3571.180] 	intel
[  3571.180] 	nouveau
[  3571.180] 	qxl
[  3571.180] 	radeon
[  3571.180] 	vmware
[  3571.180] 	modesetting
[  3571.180] 	fbdev
[  3571.180] 	vesa
[  3571.180] (II) LoadModule: "amdgpu"
[  3571.180] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[  3571.180] (II) Module amdgpu: vendor="X.Org Foundation"
[  3571.180] 	compiled for 1.20.3, module version = 18.1.99
[  3571.180] 	Module class: X.Org Video Driver
[  3571.180] 	ABI class: X.Org Video Driver, version 24.0
[  3571.180] (II) LoadModule: "ati"
[  3571.180] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[  3571.180] (II) Module ati: vendor="X.Org Foundation"
[  3571.180] 	compiled for 1.20.4, module version = 19.0.1
[  3571.180] 	Module class: X.Org Video Driver
[  3571.180] 	ABI class: X.Org Video Driver, version 24.0
[  3571.180] (II) LoadModule: "intel"
[  3571.180] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  3571.181] (II) Module intel: vendor="X.Org Foundation"
[  3571.181] 	compiled for 1.20.1, module version = 2.99.917
[  3571.181] 	Module class: X.Org Video Driver
[  3571.181] 	ABI class: X.Org Video Driver, version 24.0
[  3571.181] (II) LoadModule: "nouveau"
[  3571.181] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  3571.181] (II) Module nouveau: vendor="X.Org Foundation"
[  3571.181] 	compiled for 1.20.3, module version = 1.0.16
[  3571.181] 	Module class: X.Org Video Driver
[  3571.181] 	ABI class: X.Org Video Driver, version 24.0
[  3571.181] (II) LoadModule: "qxl"
[  3571.181] (II) Loading /usr/lib/xorg/modules/drivers/qxl_drv.so
[  3571.181] (II) Module qxl: vendor="X.Org Foundation"
[  3571.181] 	compiled for 1.20.0, module version = 0.1.5
[  3571.181] 	Module class: X.Org Video Driver
[  3571.181] 	ABI class: X.Org Video Driver, version 24.0
[  3571.181] (II) LoadModule: "radeon"
[  3571.181] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[  3571.181] (II) Module radeon: vendor="X.Org Foundation"
[  3571.181] 	compiled for 1.20.4, module version = 19.0.1
[  3571.181] 	Module class: X.Org Video Driver
[  3571.181] 	ABI class: X.Org Video Driver, version 24.0
[  3571.181] (II) LoadModule: "vmware"
[  3571.181] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[  3571.216] (II) Module vmware: vendor="X.Org Foundation"
[  3571.216] 	compiled for 1.20.0, module version = 13.3.0
[  3571.216] 	Module class: X.Org Video Driver
[  3571.216] 	ABI class: X.Org Video Driver, version 24.0
[  3571.216] (II) LoadModule: "modesetting"
[  3571.216] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  3571.216] (II) Module modesetting: vendor="X.Org Foundation"
[  3571.216] 	compiled for 1.20.4, module version = 1.20.4
[  3571.216] 	Module class: X.Org Video Driver
[  3571.216] 	ABI class: X.Org Video Driver, version 24.0
[  3571.216] (II) LoadModule: "fbdev"
[  3571.216] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  3571.216] (II) Module fbdev: vendor="X.Org Foundation"
[  3571.216] 	compiled for 1.20.0, module version = 0.5.0
[  3571.216] 	Module class: X.Org Video Driver
[  3571.216] 	ABI class: X.Org Video Driver, version 24.0
[  3571.216] (II) LoadModule: "vesa"
[  3571.216] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  3571.216] (II) Module vesa: vendor="X.Org Foundation"
[  3571.216] 	compiled for 1.20.1, module version = 2.4.0
[  3571.216] 	Module class: X.Org Video Driver
[  3571.216] 	ABI class: X.Org Video Driver, version 24.0
[  3571.216] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  3571.217] (II) intel: Driver for Intel(R) HD Graphics
[  3571.217] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[  3571.217] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[  3571.217] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  3571.217] (II) FBDEV: driver for framebuffer: fbdev
[  3571.217] (II) VESA: driver for VESA chipsets: vesa
[  3571.251] (++) Using config file: "/root/xorg.conf.new"
[  3571.251] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  3571.252] (==) ServerLayout "X.org Configured"
[  3571.252] (**) |-->Screen "Screen0" (0)
[  3571.252] (**) |   |-->Monitor "Monitor0"
[  3571.253] (**) |   |-->Device "Card0"
[  3571.253] (**) |-->Input Device "Mouse0"
[  3571.253] (**) |-->Input Device "Keyboard0"
[  3571.253] (==) Automatically adding devices
[  3571.253] (==) Automatically enabling devices
[  3571.253] (==) Automatically adding GPU devices
[  3571.254] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  3571.254] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  3571.254] 	Entry deleted from font path.
[  3571.254] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  3571.254] 	Entry deleted from font path.
[  3571.254] (**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins,
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	built-ins
[  3571.254] (**) ModulePath set to "/usr/lib/xorg/modules"
[  3571.254] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  3571.254] (WW) Disabling Mouse0
[  3571.254] (WW) Disabling Keyboard0
[  3573.291] intel: waited 2020 ms for i915.ko driver to load
[  3573.299] Number of created screens does not match number of detected devices.
  Configuration failed.
[  3573.299] (EE) Server terminated with error (2). Closing log file.

J’espère avoir donné suffisamment d’informations, désolé si le formatage n’est pas top c’est mon premier post.

Bonjour,

as tu essayer avec un noyau plus récent (dans les backports)?

Je viens d’ajouter
deb http://deb.debian.org/debian buster-backports main contrib non-free

à mon source.list

après aptitude update && aptitude upgrade ça me dit que 0 paquets ont été mis a jour.

De mémoire

Il faut

sudo apt install -t buster-backports linux-image-amd64

Ok ça a fonctionné, merci beaucoup.

Je me sens un peu idiot de ne pas avoir trouvé cette solution plus tôt.

Tu as de l affichage ?

le noyau de ta debian n’etait pas assez reçent pour ton materiel.

Oui, au redémarrage j’ai eu l’affichage.

D’accord merci, je ne pensais pas que Buster pouvait avoir ce genre de problèmes de compatibilité

En stable , le matériel ne doit pas être trop récent mais ça se contourne facilement.

J’aurais peut être du installer Bullseye alors…

comme tu veut, ca dépend de ton usage.

si tu veut des logiciels plus récent avec un minimum de bug tu peut essayer Bullseye .
sinon reste sur stable.

1 J'aime