Noyau 2.6 sur portable Dell D610


#1

Bonjour à tous,
Je craque… Voilà 2 jour que j’essaye de compiler mon noyau correctement pour faire upgrader ma woody toute fraiche vers une sid… Et ça marche pas… Je vous explique:

J’installe la Woody avec son noyau 2.4.18 (c’est le DVD de la r4). Pas de problème, utilisation normale, mais pas de carte réseau et pas de wifi… jusque là, rien d’anormale car le D610 et très récent (j’avais un D600 sur lequelle y’avait aucun problème, mais la config n’est pas la même, il y a eu une grosse évolution).

Je compile le noyau 2.6.11 avec toutes les options qui vont bien… Reboot… Et… pas de clavier… Bref, je recompile, je cherche, … Rien n’y fait, ça marche toujours pas.

Je télécharge le netinstall de la sarge… Et voici le REEL problème: le disque dur n’est pas détecté!!! Pas de partitionnement possible…
D’après mes investigations sur le web (Dell ne précise rien nulle part) il semblerait que ce soit un disque PATA…

Si vous pouviez me donner un truc… même si ça marche pas, juste pour que je retrouve l’espoir :wink:


#2

Je ne sais pas si cela va t’aider mais voila mon experience sur un Dell Inspiron 500m (il a 18 mois mais semble assez proche de ta config).

J’ai galéré plusieurs fois à essayé d’installer des distrib différentes. Généralement cela bloqué au niveau de la carte graphique (limité à 1024x768 alors que j’ai du 1400x1050) ou du Wifi (TrueMobille 1300).
Je ne suis pas un expert mais c’était vraiment trop compliqué …

Jusqu’au jour où j’ai essayé la Debian Ubuntu. L’écran et le Wifi fonctionne correctement. Même l’ACPI est opérationnel.
Et en plus ça reste une "debian’ avec les avantages que l’on connait.

Je ne suis pas sûr que ca va t’aider avec ton pb de PATA mais si tu souhaites reprendre tout à zéro, je te conseille cette distrib.


#3

Tu n’est pas obligé de d’avoir un kernel 2.6 avant d’ugrader en sid.

Le net-install bugge régulièrement. Pars plutôt depuis ta woody et fais un apt-get dist-upgrade dessus …

Tu seras ensuite en bien meilleure condition pour upgrader ton kernel.


#4

Si seulement ma carte réseau fonctionnait sur la woody… … …
Et même la ubuntu ne marche pas!!!

La seule chose qu’il me reste à faire est d’attendre patiemment la release d’un bon tutorial sur le net :cry: :cry:


#5

Un pt’it coup de google et ca repart ! ?
http://www.google.ch/search?hl=fr&q=Wifi+Truemobile+1300+linux+debian&btnG=Rechercher&meta=


#6

Merci de ta réponse Jadda, mais hélas, ma carte WiFi est une intel et pas une broadcom, ils ont changé entre le D600 et le D610… Et Intel (ou autre développeur du monde libre :wink: ) ne fournissent les drivers que pour un 2.6.4 minimum :cry:

Actuellement, j’essaye de compiler mon noyau 2.4.26 patché avec les drivers de la carte broadcom 57xx… Mais j’ai une super erreur de compilation du DRM de la carte vidéo??? C’est très bizarre!!! Enfin bon, je ne désespère pas :confused:


#7

Moi aussi je l’aie eu cette erreur, récemment. Désactive cette option et tu y reviendras plus tard, une chose à la fois …