[ Num Lock ] Num Lock éteint au démarrage


#1

Bonjour les amis, :wink:

Connaissez-vous l’astuce pour que le Num Lock du clavier s’allume automatiquement au démarrage de L’ordi ??

Merci à l’avance de votre aide …


#2

Salut,
Peut-être en installant le paquet numlockx


#3

un déterrage du temps où Ricardo était jeune :slightly_smiling:
numlock-automatique-a-l-ecran-d-accueil-t1654.html


#4

Pour Lightdm:

doc.ubuntu-fr.org/numlockx


#5

Pour XFCE (que tu sembles utiliser, d’après ta signature) :

Menu - Paramètres - Éditeur de paramètres
Canal Keybords - Numlock, et tu coches la case “Valeur”.


#6

[quote=“dannyleconte”]Salut,
Peut-être en installant le paquet numlockx[/quote]

Je viens de l’installé avec Synaptic …

Et cela fonctionne bien , :wink:

Merci mes amis de votre participation …

j’ai trouvé une autre astuce en tapant dans un terminal :

numlockx on

:wink:


#7

[quote=“misaine”]un déterrage du temps où Ricardo était jeune :slightly_smiling:
numlock-automatique-a-l-ecran-d-accueil-t1654.html[/quote]

Rohhhhh tu vas laisser passer ca Ricardo? :open_mouth:


#8

Salut,
Sur Debian Jessie avec:
gdm3 3.14.1-7 Gestionnaire d’écran de connexion de GNOME.

  1. Installer le paquet numlockx

2)Forcer la touche verr num au boot pour pouvoir écrire son mot de passe d’ouverture de session.
Il faut modifier le fichier /etc/gdm3/Init/Default et ajouter avant le exit:

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi

Example

 [i] elif [ -n "$XKBSYMBOLS" ]; then
    $SETXKBMAP -symbols "$XKBSYMBOLS"
  fi
fi

fi
fi
if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi
exit 0
[/i]


#9

[quote=“grandtoubab”]Salut,
Sur Debian Jessie avec:
gdm3 3.14.1-7 Gestionnaire d’écran de connexion de GNOME.

  1. Installer le paquet numlockx

2)Forcer la touche verr num au boot pour pouvoir écrire son mot de passe d’ouverture de session.
Il faut modifier le fichier /etc/gdm3/Init/Default et ajouter avant le exit:

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi

Example

 [i] elif [ -n "$XKBSYMBOLS" ]; then
    $SETXKBMAP -symbols "$XKBSYMBOLS"
  fi
fi

fi
fi
if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi
exit 0
[/i][/quote]
Pour ceux qui n’utilisent que lightdm ça se passe dans /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf

root@desktop:/usr/share/lightdm/lightdm.conf.d# cat 50-greeter-wrapper.conf [SeatDefaults] greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session greeter-setup-script=/usr/bin/numlockx on


Pavé numérique actif au démarrage
#10

[quote=“grandtoubab”][quote=“grandtoubab”]Salut,
Sur Debian Jessie avec:
gdm3 3.14.1-7 Gestionnaire d’écran de connexion de GNOME.

  1. Installer le paquet numlockx

2)Forcer la touche verr num au boot pour pouvoir écrire son mot de passe d’ouverture de session.
Il faut modifier le fichier /etc/gdm3/Init/Default et ajouter avant le exit:

if [ -x /usr/bin/numlockx ]; then /usr/bin/numlockx on fi

Example

 [i] elif [ -n "$XKBSYMBOLS" ]; then
    $SETXKBMAP -symbols "$XKBSYMBOLS"
  fi
fi

fi
fi
if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi
exit 0
[/i][/quote]
Pour ceux qui n’utilisent que lightdm ça se passe dans /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf

root@desktop:/usr/share/lightdm/lightdm.conf.d# cat 50-greeter-wrapper.conf [SeatDefaults] greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session greeter-setup-script=/usr/bin/numlockx on[/quote]

Pour Jessie XFCE c’est ici:

[code]root@desktop:/usr/share/lightdm/lightdm.conf.d# ls
01_debian.conf
root@desktop:/usr/share/lightdm/lightdm.conf.d# cat 01_debian.conf

Debian specific defaults

- use lightdm-greeter session greeter, points to the etc-alternatives managed

greeter

- hide users list by default, we don’t want to expose them

- use Debian specific session wrapper, to gain support for

/etc/X11/Xsession.d scripts

[SeatDefaults]
greeter-session=lightdm-greeter
greeter-hide-users=true
session-wrapper=/etc/X11/Xsession
greeter-setup-script=/usr/bin/numlockx on[/code]


Activer numpad au demarrage
#11

Pour la session gnome ( gnome3 avec x11, pas avec wayland) j’ai mis
on dans /etc/default/numlockx

cat /etc/default/numlockx
# Configuration file for numlockx

# State of numlog on start of X session
# Accepts following options:
#  auto - turns numlock on unless ran on laptop
#  on - turns numlock on
#  off - turns numlock off
#  keep - does not change numlock state
#  toggle - toggles numlock state
NUMLOCK=on

#12

Ça c’est du déterrage.

Pour info, tous les paramètres de Gnome3 peuvent se régler avec dconf dont il existe un éditeur graphique: dconf-editor.

Pour la question du numlock, ça se défini dans les variables numlock-state et remember-numlock-state qui se trouvent dans:

org->gnome->settings-daemon->peripherals->keyboard

Pas besoin de numlockx.


#13

Peut-être si on utilise que Gnome, mais j’utilise aussi XFCE sur ce PC. j’aime bien avoir le choix :grinning: Et j’utilise lightdm et j’aime bien aussi que numlock soit “on” au moment de la saisie de mon mot de passe


#14

Et comme sur mon PC portable, il n’y a pas de led sur la touche VerrNum j’ai installé l’extension

https://extensions.gnome.org/extension/1105/keys-indicator/

Ce qui permet d’être certain que la touche est activée: une touche avec 1 apparaît dans la barre du haut
Et une notification au changement d’état


#15

J’ai un pavé numérique USB branché sur un portable. J‘ai installé numlockx via synaptic, ensuite dans un terminal en mode root j‘ai lancé la commande : numlockx on
Ça fonctionne très même après une reinit.

Debian 10 buster cinnamon