Numlockx ne fonctionne plus sous Buster

buster
Tags: #<Tag:0x00007fdf385851c8>

#1

Bonjour à tous,

Je viens d’installer la Debian Buster avec la dernière version, en remplacement de ma Stretch, tout fonctionne très bien sauf que le pavé numérique n’est plus activé au boot.
Ci-dessous les actions effectuées:
-installation de numlockx
-Ajout des lignes dans /etc/gdm3/Init/Default juste avant la directive “exit 0”

Activation du pave numerique au boot

if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi

L’erreur générée à la commande "numlockx on"est:

“Error opening display!”

A mon avis le problème ne vient pas de numlockx car en login utilisateur la commande s’exécute bien , il n’y a qu’en root que le problème apparaît, probablement due aux nouvelles règles de sécurité dans X11.

Auriez vous une idée pour traiter ce problème s’il vous plaît ?

Merci

Willy


#2

Salut
As tu vérifié?

/etc/default/numlockx

# Configuration file for numlockx

# State of numlog on start of X session
# Accepts following options:
#  auto - turns numlock on unless ran on laptop
#  on - turns numlock on
#  off - turns numlock off
#  keep - does not change numlock state
#  toggle - toggles numlock state
NUMLOCK=on
```

#3

Salut,

Oui, le fichier le fichier /etc/default/numlockx est bien configuré

Willy


#4

j’utilise https://github.com/sddm/ et ça fonctionne très bien avec Buster

cat /etc/sddm.conf
[General]
Numlock=on

c’est un pb spécifique à gdm pas à numlock

Tu peux essayer en forçant les clés gnome

sudo  gsettings set  org.gnome.settings-daemon.peripherals.keyboard numlock-state on

sudo  gsettings set  org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true

Vérification

gsettings get  org.gnome.settings-daemon.peripherals.keyboard numlock-state

gsettings get  org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state

#5

Oui, ce que je disais c’est un problème X11, je sais qu’ils ont fait pas mal de modification au niveau du protocole.
Comme numlockx fonctionnait bien en login utilisateur j’ai ajouté dans le fichier /etc/gdm3/Init/Default la commande:

if [ -x /usr/bin/numlockx ]; then
sudo -u willy /usr/bin/numlockx on
fi
mais le problème persiste.
Comme j’avais d’autres problèmes avec Evolution qui ne récupérait plus les nouveaux mails j’ai restauré mon système, j’attendrai encore un peu avant de basculer sous Buster.

Merci pour ton aide, je vais clôturer le sujet.

Willy