Nvidia, toujours et encore


#1

J’ai eu le malheur d’accepter une MAJ, malgré la mise en garde.
Il était pourtant écrit que le problème se corrigeait en fermant la machine et en rallumant.
Même pas le “graphique de base”, rien.
LSPCI donne ça :

VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 620] (rev a1)

Je n’ai malheureusement plus les facultés pour me démerder seul, et je demande de l’aide.
Merci

PS :
Là, je suis sur une autre machine qui n’a pas dû être mise à jour depuis longtemps
uname -r
4.9.0-3-amd64


#2

Bonjour ricardo,

https://wiki.debian.org/fr/NvidiaGraphicsDrivers

Il y a un chapitre : Revenir en arrière en cas d’incident.

Autrement, il y a moyen de désinstaller un .run (avec --uninstall)
Pour un pilote installé manuellement.
Exemple (en root) : ./NVIDIA-Linux-x86-310.19.run --uninstall


Au chapitre Identification, tu vérifies que ce n’est pas un système hybride Optimus (par principe)
Puis tu as le script nvidia-detect (paquet nvidia-detect dans non-free) qui peut être utilisé pour identifier le processeur graphique et le pilote adapté.

Il devrait être bien nvidia-detect pour dire quelle version installer.

Il y a tout un chapitre pour Stretch. (Pas trop évident par contre)
Tu auras davantage d’aide pour savoir quel pilote choisir pour cette GF108 [GeForce GT 620] (rev a1)


#3

passer en mode console et faire:

apt install nvidia-driver

Je suppose que tu es en stable stretch


#4

Merci à vous deux.
Je répond à minuit et il est un peu tard pour opérer.
Demain je ne suis pas à la maison, mais je pense rentrer assez tôt pour faire ça dans la soirée.
vous êtes sympa car mon cerveau patauge et je ne suis plus capable de me dépanner seul.
Réponse demain soir ou après-demain.


#6

J’ai fait tout ce que vous m’aviez préconisé de faire, mais tout est à jour et rien de mieux :

nvidia-detect  = VGA Compatible controller [0300]  :
NVIDIA Corporation GE108 [GeForce GT 620] [10 de:0f01] (rev a1)

Carte supporte ttes les versions
Nvidia driver derniere version déjà installée 390.116-1


#7

Tu es en console ?
peux tu indiquer ce que donne grep "(EE)" /var/log/Xorg.0.log
Eventuellement, aprés voir lancé startx, pour voir directement les messages d’erreur.


#8

Oui, console puisque pas d’accès à X.
Je passe du DD qui va bien, le présent, qui n’a pas vu de MAJ depuis un bout de temps, pour faire les tests en console sur celui qui va mal.
Donc, réponse à : grep "EE" /var/log/Xorg.0.log
Réponse vide.
Je pense qu’il n’y a pas de EE.
Sur le présent DD, j’ai la même réponse, et pourtant, en graphique, il y a bien des logs.
Je dois m’absenter, retour dans la soirée.


#9

fais aussi voir ton sources.list et le retour de:

apt policy nvidia-driver

#10

Le sources est bon, stretch + backports + contrib et non-free
pour la version du driver :
installé et candidat = 390-116-1
table version = 418.56-2 ~bpo9+1 100


#11

Je viens de voir une alerte qui semble donner la raison du problème :

Plasma  ne peut pas démarrer car il ne peut pas utiliser OpenGL2 correctement. Vérifiez la config
du pilote de la carte graphique.

Est-ce que je ne pourrais pas utiliser gnome en attendant ?


#12

Essaye de forcer la version backports ?
apt install nvidia-driver=418.56-2 ~bpo9+1


#13

Ca ne coute rien, ni d’essayer d’installer un autre wm ou ouvrir une session mini.


#14

J’ai essayé ta commande, il y a des dépendances non conformes, mais il ne peut pas y remédier car certains paquets sont en mode “garder en l’état”.
Là, il faut que j’arrête pour aujourd’hui, car c’est maintenant moi qui fait la soupe, ma femme est très fatiguée.
Demain, je vais déjà essayer de supprimer les paquets bloqués et je reviens vers vous.
Bon appétit à tous et encore merci de l’aide.


#15

non, il faut installer le legacy; nvidia-legacy-390xx-driver.
https://packages.debian.org/stretch-backports/nvidia-legacy-390xx-driver
https://packages.debian.org/buster/nvidia-legacy-390xx-driver


#16

J’ai bien fait avec legacy, mais il me donne la même réponse :
J’ai aussi essayé avec aptitude et il donne une idée de dépannage, mais avant…

"…certains paquets sont en mode “garder en l’état”

Il s’agit certainement de certains paquets que j’avais “pinné” car reconnus par apt-listbugs comme “critical”.
Le problème, c’est que je ne trouve plus le fichier où ces “pinnés” sont rangés.
Avant, il me semble que c’était dans /etc/apt/listbugs, mais ça a dû changer ???
Je dois aller faire les courses et je n’ai pas le temps de fouiller, si qq’un sait, merci…:smiling_face_with_three_hearts:


#17

Soit dans /etc/apt/preferences, soit via la commande :
dpkg --get-selections | grep hold


#18

Malheureusement, les deux renvoient vide.
Sur le present DD, /etc/apt/preferences.d/apt-listbugs contient bien un paquet pinné (firefox d’il y a au moins 3 ans)
Mais sur celui qui déconne, rien.
Dans le temps, j’avais une carte graphique qui ne me posait jamais de problème, mais ce n’était pas NVIDIA.
Si ça continue de me faire … je vais en acheter une.
Avez-vous des noms de CG qui vont bien ???


#19

Bonjour·s,

ricardo, as-tu essayé ce qui est expliqué dans le chapitre : Revenir en arrière en cas d’incident ?

Je ne sais pas si c’est encore applicable de nos jours (même en partie).


#20

Non, j’ai retenté avec aptitude et j’ai tout accepté sans rien vérifier (marre de Nvidia)
Il m’a redonné l’X mais pas très joli, rétréci sur les bords.
En attendant que je trouve une carte graphique qui aime bien Debian.


#21

je ferais un nettoyage complet de tous les fichiers nvidia et retenterais une installation propre. Que contient ton fichier /etc/modprobe.d/nvidia-blacklists-nouveau.conf