[OK] association de dd et de tar


#1

Salutations,

j’essai de faire une commande alliant dd et tar

j’ai essayé :

dd if=/dev/sda | tar -cvzf backup.tgz

dd if=/dev/sda | tar -cvzf backup.tgz -

dd if=/dev/sda | tar -cvzf backup.tgz /dev/stdin

dans les 2 premiers cas j’obtien une erreur, dans le dernier, j’obtien un fichier d’environ 100 octects…

quelqu’un a t-il une idée ?

merci :slightly_smiling:


#2

Pourquoi tu veux faire un tar d’un dd? Tu ne peux pas directement faire un gzip? Le tar n’est utile que lorsque tu veu sauvegarder une structure de fichiers.

Avec ça, tu auras un fichier gzip contenant la sortie de ton dd :
dd if=/dev/sda | gzip > backup.gz


#3

Fais plutôt dans ce cas

dd if=/dev/sda | gzip > sda.img.gz

si j’ai bien compris ce que tu veux faire…


#4

merci :slightly_smiling:
je vais essayer les 2 solutions que vous me proposez :wink:

par contre, est-il possible de faire du multi-volume avec gzip ?

j’avais choisi tar, car je pensais que c’est avec ce soft que j’avais le + de chance d’arriver à mes fins.

pour tout dire, je fais un simili-ghost d’un HDD ntfs sur lequel se trouve win2k3.
j’utilise “dd” pour faire le ghost vers un partage.

tout d’abord, j’ai monté un partage samba sous reiserfs pour réceptionner mon “dd” mais j’ai eu l’erreur “file max size exceeded”. j’ai supposé que c’était du au système de fichier qui ne supportait pas la taille du ghost (sda fait environ 70Go) car j’ai largement la place sur mon partage samba (environ 90 Go de libre).

ensuite, je me suis dis :
“c pô grav, j’va passer par autre HDD en ntfs en montant un partage d’une machine XP Home ayant 120Go de libre…” mais hélas non, j’obtiens la meme erreur arrivé a 2Go :’-(

vous ne trouvez pas ca étrange ??

donc pour m’en sortir, j’ai pensé utiliser “tar” histoire de diminuer sensiblement la taille du fichier, mais si vous me dites que gzip y arrive, alors va pour gzip :smiley:


#5

Les deux solutions qui te sont proposés sont eactement les mêmes, c’ezst juste que fran.b ne lit pas les réponses précédentes :laughing:
Ensuite, tar ne compresse pas, il sert juste à mettre une structure de fichiers dans un seul fichier. D’ailleurs, quand tu utilises l’option z avec tar, le systéme crée d’abord un tar, puis le compresse en utilisant gzip.
Si tu souhaites une compression optimale, je te conseillerait d’utiliser plutôt bzip2 :wink:


#6

je viens de parcourir la manpage de bzip2, il n’y est nul part question de multi-volume…

vu que ca bloque lorsque mon fichier atteint 2 Go, je pense pas que bzip2 soit capable de compresser un HDD de 70 Go en 2 Go :confused:


#7

Et t’as essayé de faire un transfert via ftp ou scp?

Sinon, une fois ton gzip (ou bzip) créé, tu peux toujours utiliser tar pour le découper en plusieurs fichiers. :confused:


#8

euuu, je vois pas comment je peux faire un ftp / scp dans mon cas… pour cela il faudrait que je stock mon fichier de ghost qque part, non ??

si ca bloque en utilisant “dd” sur un smbmount, ca devrait également bloquer via ftp / scp, non ?


#9

Hum, oui, j’ai un peu de mal à intégrer toutes les phrases en même temps aujourd’hui.

Après, la coupure à 2Go, viens soit d’une limitation du filesystem de ton partage sur le serveur windows (ce qui arrive lorsque c’est du fat32), soit d’une limitation de smbfs. Cependant, je n’ai pas le souvenir d’une telle limitation pour smbfs.

Si j’ai bien compris, le premier serveur sur lequel tu as essayé de transférer ton dd est sous linux non?
Dans ce cas, la maniére la plus simple, c’est, depuis ta machine de destination, faire ceci :

ssh ta_machine_a_sauvegarder “dd /dev/sda” | gzip > backup.gz

Ainsi, tu récupéres directement la sortie standard de dd, puis ton compresse ça et tu l’écris sur ton disque en local.


#10

yep :wink:

bonne idée :slightly_smiling:

j’m’y met de suite, résultats… prochainement !


#11

ca a l’air bien parti.
mon fichier ghost.gz fais actuellement + de 2Go et je n’ai pas eu d’erreur jusque la… 8) :laughing:

je vous dirais lundi si “dd” a pu aller au bout.

merci pour tout

ps: je taggerai le topic [OK] quand le dd sera terminé et compressé, hein :slight_smile:


#12

et voila, c’est taggé.

merci bcp messieurs BobX et fran.b.

j’ai un beau fichier de 18 Go sur mon DD ! le sda d’origine est occupé à environ 25 Go, c’est une belle compression tout de meme :slightly_smiling:

je suppose que l’erreur “file max size exceeded” une fois arrivé à 2 Go devait etre due au protocole smbfs…