Où est mon graveur?


#1

Bonjour à tous!

Mon problème se résume à assez peu de choses, mais est tout de même gênant…je ne trouve pas mon graveur!

Ce qui est étrange, c’est que de temps en temps, il apparaît bien (je peux le voir dans mon dmesg ou avec k3b)…mais c’est extrêmement rare…je n’ai pas réussi à trouver la règle d’apparition (je ne l’ai vu que 3 fois en 4 mois!). Par contre, mon lecteur est toujours présent…

Pour info, je suis sous testing avec un kernel 2.4.27-2-386 “d’origine” et mon graveur est un NEC 3500 AG.

Merci d’avance pour votre aide!


#2

en 2.4, il faut que ide-cd soit chargé (ou ide-scsi, je ne sais plus), mais je te conseille fortement de passer en 2.6 si tu fais du gravage.


#3

ps: je conseille même un 2.6.8 ou plus, avec le paquet udev, parc’erque ca simplifie beaucoup la gestion des devices…


#4

J’ai bien essayé de passer en 2.6, le problème, c’est que je me retrouve systématiquement avec un kernel panic…je pense que c’est dû au SATA…mais rien à faire…j’ai testé plusieurs configs et ça ne passe pas :cry:

Je vais de toute façon réessayer…on ne sait jamais!

Quant à ide-cd et ide-scsi, ils apparaissent tous deux quand je fais un lsmod…ce qui est vraiment étrange, c’est qu’il réagit comme si je n’avais pas du tout le matériel…aucune détection!


#5

as tu booté sous win récemment avec la même machine ?
parceque ca meurt un graveur :cry:


#6

plus sérieusement, tu fais bien ta compil noyau avec make-kpkg, et tu passes bien l’option --initrd lors de la compil ?


#7

[quote]as tu booté sous win récemment avec la même machine ?
parceque ca meurt un graveur[/quote]

Oui, je boote régulièrement sous win et mon graveur apparait sans aucun problème :cry:

C’est exactement ce que je fais…mais j’avoue ne pas maîtriser à fond toutes les options de configuration du kernel…c’est peut-être là que ça plante! :blush:


#8

es tu parti d’une config qui marche pour fabriquer ton noyau ?
as tu essayé les kernel-image debian ?


#9

Oui, le kernel-image de debian me fait un kernel panic, et je copie mon config-2.4.27 dans le /usr/src/linux (lien symbolique vers le répertoire des sources du noyau que je veux configurer) en tant que .config…mais rien à faire!!!


#10

ah ouais, ca me rappelle qqchose…
bad trip :confused:
il doit y avoir une différence de nommage des device disk entre le 2.4 et le 2.6
déjà, as tu un paquet udev ?
as tu une knoppix avec un noyau >2.6.8 (knoppix26) qui boote, pour voir comment il nomme les devices pour ton disque en sata (style /dev/sd/… au lieu de /dev/sdbXXX).
ensuite tu te refais ton fstab en 2.6, pour usage avec ton nouveau noyau, puis tu reboote (tu pourras tjs revenir en arrière avec une knoppix).
Et sinon, tu peux aussi essayer de jouer sur ton fstab en utilisant les labels ext, au lieu d’utiliser les devices /dev/hdXXX ou sdXXX…


#11

Oui, j’ai le 0.056-2

[quote]as tu une knoppix avec un noyau >2.6.8 (knoppix26) qui boote, pour voir comment il nomme les devices pour ton disque en sata (style /dev/sd/… au lieu de /dev/sdbXXX).
ensuite tu te refais ton fstab en 2.6, pour usage avec ton nouveau noyau, puis tu reboote (tu pourras tjs revenir en arrière avec une knoppix). [/quote]

Je vais voir si j’ai le temps d’essayer ça ce week-end…je n’y avais pas pensé! :blush:

Là, par contre, j’avoue ne pas suivre! :blush: :blush: :blush:


#12

les labels ?
simple, et pratique. mettons que tu aies une organisation IDE comme suit:[code]

disque linux

/dev/hda1 none swap sw 0 0
/dev/hda2 / ext3 errors=remount-ro 0 1
/dev/hda3 /home ext3 defaults 0 2
[/code]
tu étiquettes alors tes partoches avec tune2fs:

# tune2fs -L "/" /dev/hda2
# tune2fs -l LABEL=/ # pour vérifier qu'on a bien étiqueté, c'est le "Filesystem volume name"
# tune2fs -L "/home" /dev/hda3
# tune2fs -l LABEL=/home 

notes bien que j’aurais pu étiqueter mes partitions “racine” et “utilisateurs”, respectivement, mais je préfère / et /home, personnellement.
Bon, ensuite, tu modifies ton fstab :

# disque linux
/dev/hda1               none            swap    sw                                                              0       0
LABEL=/                 /               ext3    errors=remount-ro                                               0       1
LABEL=/home             /home           ext3    defaults                                                        0       2

et tu rebootes…

ton disque boote maintenant indépendament de l’endroit ou tu le places sur ton IDE. A partir du moment ou tu bootes dessus, il sait retrouver / et /home.
Remarque aussi qu’il va quand même râler, parcequ’il ne trouvera pas le swap (on ne peut pas étiqueter le swap), mais au moins, il bootera.
Je ne sais pas si on peut aussi utiliser les étiquettes windows, et je ne sais pas si ca recherche les LABEL ailleurs que sur le disque de boot, mais bon…


#13

Tu pourrais aussi essayer d’installer les paquets lshw et hwtools pour te sortir un listing hyper detaille de tout le matos detecte sur ta machine.


#14

J’ai installé et lancé lshw, mais ça ne me donne que les caractéristiques de ma carte mère!

Par contre, j’ai modifié mon fstab après compilation du kernel 2.6 (en effet; le kernel 2.6 nomme mon hdd sda alors que le 2.4 le nomme hda), j’ai rebooté et j’obtiens ça:

FATAL: Kernel does not have unload support (plusieurs fois cette ligne) pivot_root: No such file or directory /sbin/init: 431 Cannot open /dev/console: No suche file Kernel panic - Not syncing: attempted to kill init! :cry:

Je n’ai par contre pas encore essayé le labels…est-ce que ç changerait quelque chose?

En tout cas, d’avance merci à vous deux! :wink:


#15

il te manque l’option “kernel modules unloading” dans ton noyau, déjà.
Les labels devraient te permettre d’aprés moi de booter même si la dénomination de ton disque de boot est difficile à trouver.
Tu peux aussi faire des essais en passant toi même des “root=” différents au boot por tester différentes valeurs.