Paquet à moitié configuré


#1

Bonjour,

[debian unstable]
Après un dselect-update / select / install, je me retrouve avec un paquet libpam-runtime à moitié configuré.
Impossible de terminer la configuration
% dpkg --configure libpam-runtime
–> erreur

% dpkg -s libpam-runtime
status: install ok half configured

Ce paquet étant utile à de très nombreux programmes, je ne me vois pas le désinstaller.
Il me semblait que dpkg faisait une sauvegarde avant d’updater un paquet
Comment revenir en arrière :

  • récupérer une sauvegarde
  • réinstaller une version antérieure de libpam-runtime

La suite des opérations (autres installations) est bloquée par ce problème. Quelle démarche adopter ?

Merci d’avance


#2

J’ai le même problème que toi, erreur dans les archives debian ?


#3

J’ai le même problème que toi, erreur dans les archives debian ?


#4

J’ai le même problème que toi, erreur dans les archives debian ?


#5

ooops, petit problème au postage…

En attendant, j’ai résolu le problème en récupérant la version juste précédente dans les archives, pool/main/p/pam/libpam-runtime_0.76-16_all.deb (numéro de paquet 16 à la place de 18) . Ensuite installation avec dpkg -i mon_paquet et ça roule…

Voilà…

eop