Paquetage nvsound-installer, ma première contribution


#1

Salut,

les possesseurs de nForce connaissent bien nvsound, le module propriétaire qui permet davoir un excellent son multi cannal. Seul épine à ce driver, il fallait utiliser un installeur “maison” pour l’installer, et qui ne sentend pas particulièrement avec Debian ( il fonctionne, mais passe outre le système de paquetage et quant à lutilisation avec kernel-package, il fallait bidouiller à fond ). Jai donc crée un paquetage source basé sur fglrx-installer pour avoir un module propre et qui sintègre parfaitement à Debian, le voilou :

http://perso.wanadoo.fr/superdindon/nvsound-deb/

Ceci étant la première version et ne layant testé que sur ma config, je ne peux dire si ça va fonctionner parfaitement sur toutes les machines ( même si théoriquement, ça devrait ). C pour cela dailleurs quil serait intéressant quun maximum de personnes lessaye pour améliorer la portabilité ( et pour ceux qui utilise exclusivement le module et qui recompile courramment un noyau, elles vont pouvoir enfin éradiquer de leur vie linstalleur de nVidia )

Voilà, jespère que ma propagande vous aura convaincu de lessayer, et nhésitez pas pour le feedback, que ça marche ou que ça ne marche pas.

Have fun!


#2

dsl, je n’ai pas de chipset nforce.
Par contre, tu as l’air de hacker un peu, dc est ce que tu aurais une idée sur l’endroit ou je pourrais trouver de l’info sur la prog de modules scsi pour le noyau. J’ai une adaptation d’un module ataraid (ultima - tekram dc200) qui existait sous noyau 2.4, je l’ai fait compiler et se monter sous 2.6, mais pour l’instant, il ne fait rien de sensible, et j’aimerais bien le faire fonctionner.
++


#3

[quote=“MattOTop”]dsl, je n’ai pas de chipset nforce.
Par contre, tu as l’air de hacker un peu, dc est ce que tu aurais une idée sur l’endroit ou je pourrais trouver de l’info sur la prog de modules scsi pour le noyau. J’ai une adaptation d’un module ataraid (ultima - tekram dc200) qui existait sous noyau 2.4, je l’ai fait compiler et se monter sous 2.6, mais pour l’instant, il ne fait rien de sensible, et j’aimerais bien le faire fonctionner.
++[/quote]

euh là aucune idée, je nai jamais jeté un coup doiel sur le code du noyau ( tout ce que jai fait pour nvsound-installer c tripoter les Makefiles ), je ne peux pas te dire si ça risque d’être hot ou pas de modifier un module. Pour ce qui est de la doc, cherches sil ny a pas des URLs dans le code des modules scsi, et si le site officiel ne fournit pas quelques bouts de code comme le fait la Silicon Image. Une petite recherche sur google me donne ces liens :

http://www.t10.org/
http://www.andante.org/scsi.html
http://docsrv.sco.com:8457/en/SCSI-Prog/SCSI-Programming-HOWTO.html

si ça peut t’aider…


#4

thx, je vais lire tout ca ce soir.


#5

Ue nouvelle version de mon paquetage a été uploadé, pour ceux qui veulent le nvmixer