Partition racine peine

Bonsoir à tous
Pendant ma mise à jour le systeme à stopper l’opération. J’ai betement relancer l’opération avec aptitude qui ma virer un tas de truc. Puis j’ai fait un apt-get -f install pour forcer un peu l’histoire. Cela n’a rien changé.
Après réflexion je me rends compte que mon probleme vient du fait que ma partition racine est pleine.
Savez-vous comment on peut régler l’histoire car pas du tout envie de me lancer dans une réinstall juste pour ça.

juded@GGDN:~$ df -l Sys. de fichiers blocks de 1K Utilisé Disponible Uti% Monté sur /dev/sda6 5635188 5618344 0 100% / udev 10240 0 10240 0% /dev tmpfs 207256 460 206796 1% /run tmpfs 5120 0 5120 0% /run/lock tmpfs 1195600 0 1195600 0% /run/shm /dev/sda9 28704764 6376968 20846632 24% /home /dev/sda12 14286320 91344 13446228 1% /mnt/Biwotik /dev/sda10 47929224 21364124 24107348 47% /mnt/Mizik /dev/sda3 15344984 7576768 7768216 50% /mnt/Pivot /dev/sda11 47929224 21042488 24428984 47% /mnt/Video /dev/sda13 32426876 10641764 20114868 35% /mnt/Zion /dev/sda7 5635188 11520 5314372 1% /tmp /dev/sda8 7557288 1781504 5368848 25% /var

[quote=“cobra”]Bonsoir à tous
Pendant ma mise à jour le systeme à stopper l’opération. J’ai betement relancer l’opération avec aptitude qui ma virer un tas de truc. Puis j’ai fait un apt-get -f install pour forcer un peu l’histoire. Cela n’a rien changé.
Après réflexion je me rends compte que mon probleme vient du fait que ma partition racine est pleine.
Savez-vous comment on peut régler l’histoire car pas du tout envie de me lancer dans une réinstall juste pour ça.

juded@GGDN:~$ df -l Sys. de fichiers blocks de 1K Utilisé Disponible Uti% Monté sur /dev/sda6 5635188 5618344 0 100% / udev 10240 0 10240 0% /dev tmpfs 207256 460 206796 1% /run tmpfs 5120 0 5120 0% /run/lock tmpfs 1195600 0 1195600 0% /run/shm /dev/sda9 28704764 6376968 20846632 24% /home /dev/sda12 14286320 91344 13446228 1% /mnt/Biwotik /dev/sda10 47929224 21364124 24107348 47% /mnt/Mizik /dev/sda3 15344984 7576768 7768216 50% /mnt/Pivot /dev/sda11 47929224 21042488 24428984 47% /mnt/Video /dev/sda13 32426876 10641764 20114868 35% /mnt/Zion /dev/sda7 5635188 11520 5314372 1% /tmp /dev/sda8 7557288 1781504 5368848 25% /var[/quote]

Tu es bon pour fouiller ce qu’il te prends de la place et supprimer ce qui ne te sert pas en tmp ainsi que les archives et logs de APT encore présentes et revoir un peu sans doute ta partition racinep our l’avenir ou d’entretenir plus régulièrement les dossier qui peuvent s’engorger assez rapidement.

Un probléme de partition pleine ?
debian-fr à la réponse toute prête:
isalo.org/wiki.debian-fr/Partition-pleine

Salut,

Je rajouterai, un fil parmi tant bien d’autres sur ce forum, dernièrement, Help !!! rootfs full >< doter de précieux conseils.

De plus, Nettoyer sa Debian

On peut voir que /tmp et /var (qui contient les logs et les archives d’APT) sont sur des partitions séparées, donc cela ne libèrera pas d’espace sur la racine.

Bonjour,
Merci pour vos réponses. Cela m’a permis dans un premier temps de virer pas mal de paquets obsolètes, ainsi que certaines dépendances orphelines. Mais cela ne corrige pas l’ensemble du problème. Je vais tenter de virer les anciens noyaux et je vous tiens au jus.
Pour l’instant voila ce que me donne un df -l

juded@GGDN:~$ df -l df: « /media/root/Réservé au système »: Permission non accordée df: « /media/root/70021F6A021F3496 »: Permission non accordée Sys. de fichiers blocks de 1K Utilisé Disponible Uti% Monté sur /dev/sda6 5635188 5603092 0 100% / udev 10240 0 10240 0% /dev tmpfs 207256 460 206796 1% /run tmpfs 5120 0 5120 0% /run/lock tmpfs 1195600 0 1195600 0% /run/shm /dev/sda9 28704764 7099144 20124456 27% /home /dev/sda12 14286320 91344 13446228 1% /mnt/Biwotik /dev/sda10 47929224 21364124 24107348 47% /mnt/Mizik /dev/sda3 15344984 7576768 7768216 50% /mnt/Pivot /dev/sda11 47929224 21042488 24428984 47% /mnt/Video /dev/sda13 32426876 11982592 18774040 39% /mnt/Zion /dev/sda7 5635188 55268 5270624 2% /tmp /dev/sda8 7557288 1780676 5369676 25% /var

Comme vous pouvez le constater le fameux / est toujours full

Après avoir supprimé les anciens noyaux voilà ce que me renvoie df -l

juded@GGDN:~$ df -l df: « /media/root/Réservé au système »: Permission non accordée df: « /media/root/70021F6A021F3496 »: Permission non accordée Sys. de fichiers blocks de 1K Utilisé Disponible Uti% Monté sur /dev/sda6 5635188 4799708 526184 91% / udev 10240 0 10240 0% /dev tmpfs 207256 460 206796 1% /run tmpfs 5120 0 5120 0% /run/lock tmpfs 1195600 0 1195600 0% /run/shm /dev/sda9 28704764 6419904 20803696 24% /home /dev/sda12 14286320 91344 13446228 1% /mnt/Biwotik /dev/sda10 47929224 21364124 24107348 47% /mnt/Mizik /dev/sda3 15344984 7576768 7768216 50% /mnt/Pivot /dev/sda11 47929224 21042488 24428984 47% /mnt/Video /dev/sda13 32426876 13907036 16849596 46% /mnt/Zion /dev/sda7 5635188 11572 5314320 1% /tmp /dev/sda8 7557288 1776140 5374212 25% /var

C’est pas encore parfait donc si vous avez des idées je suis preneur

Regarde en /root.

du -h /root

Option -h comme humain. On n’est pas des machines …
Nous te saurions gré d’user de l’option humaine -h en df à l’instar de

$ df -haT
$ df -hl
$ df -h /

+1
Et également de mettre des blocs [mono][ code ][/mono] autour des grosses sorties console pour les rendre un minimum lisibles. J’ai édité le début du fil en ce sens mais je compte sur toi pour le faire par toi-même à l’avenir. Si tu ne sais pas comment faire, édite un de tes messages précédents pour voir comment j’ai fait.

Essaye aussi localepurge

Tu auras beau faire du nettoyage le problème reviendra à moyen terme. Si tu as de la place sut ton disque il te faut créer une nouvelle partition sur laquelle tu copieras le contenu de ton / actuel. Ensuite tu dois modifier fstab et le bootloader en conséquence pour démarrer sur la nouvelle racine.

Merci pour les conseils et astuces. Voila ce que me renvoie du -h /root

[code]root@GGDN:/home/juded# du -h /root
16K /root/.config
8,0K /root/.dbus/session-bus
12K /root/.dbus
4,0K /root/.pulse
8,0K /root/.kde/share/apps/dolphin/view_properties/global
12K /root/.kde/share/apps/dolphin/view_properties
16K /root/.kde/share/apps/dolphin
8,0K /root/.kde/share/apps/RecentDocuments
12K /root/.kde/share/apps/activitymanager/resources
16K /root/.kde/share/apps/activitymanager/activityranking
32K /root/.kde/share/apps/activitymanager
20K /root/.kde/share/apps/kfileplaces
28K /root/.kde/share/apps/kconf_update/log
32K /root/.kde/share/apps/kconf_update
112K /root/.kde/share/apps
4,0K /root/.kde/share/kde4/services
8,0K /root/.kde/share/kde4
264K /root/.kde/share/config
388K /root/.kde/share
392K /root/.kde
16K /root/.aptitude
4,0K /root/.local/share/Trash/info
4,0K /root/.local/share/Trash/files
12K /root/.local/share/Trash
16K /root/.local/share
20K /root/.local
492K /root

les dossiers kde sont les plus lourds…est-ce normal?

Ok merci pour les astuces,

Quand je fais du -h /root, voilà ce que me renvoie la console.

root@GGDN:/home/juded# du -h /root 16K /root/.config 8,0K /root/.dbus/session-bus 12K /root/.dbus 4,0K /root/.pulse 8,0K /root/.kde/share/apps/dolphin/view_properties/global 12K /root/.kde/share/apps/dolphin/view_properties 16K /root/.kde/share/apps/dolphin 8,0K /root/.kde/share/apps/RecentDocuments 12K /root/.kde/share/apps/activitymanager/resources 16K /root/.kde/share/apps/activitymanager/activityranking 32K /root/.kde/share/apps/activitymanager 20K /root/.kde/share/apps/kfileplaces 28K /root/.kde/share/apps/kconf_update/log 32K /root/.kde/share/apps/kconf_update 112K /root/.kde/share/apps 4,0K /root/.kde/share/kde4/services 8,0K /root/.kde/share/kde4 264K /root/.kde/share/config 388K /root/.kde/share 392K /root/.kde 16K /root/.aptitude 4,0K /root/.local/share/Trash/info 4,0K /root/.local/share/Trash/files 12K /root/.local/share/Trash 16K /root/.local/share 20K /root/.local 492K /root

Les dossiers kde sont les plus volumineux… est-ce normal???

Ce n’est pas ici que tu gagneras de l’espace disque, regarde plutôt comment ça se présente sous /usr.

pour commencer, puis 

[code]# du -m --max-depth=1 /usr[/code]

et ainsi de suite...

ou encore

[code]# du --max-depth=1 / | sort -g[/code]

Si tu as désinstallé des paquets (avec apt-get remove) essaye aussi de purger les fichiers restants (dont des logs volumineux) avec apt-get purge pour le même nom de paquet.

pour commencer, puis

et ainsi de suite…

ou encore

Si tu as désinstallé des paquets (avec apt-get remove) essaye aussi de purger les fichiers restants (dont des logs volumineux) avec apt-get purge pour le même nom de paquet.

Salut,

Plus précisément en : [mono]# du -sh /usr/lib/[/mono] et voir également [mono]# du -sh /var/lib/[/mono] seront de bons indicateurs des paquets les plus gourmands [strike]et pas nécessairement les plus utiles[/strike] … :033 [strike]je pense au Gnome.[/strike] :005

Je conseillerai plutôt d’activer tmpfs, de virer la partition sda7 et d’utiliser les 5Go libérés pour étendre sda6.

Re,

help-rootfs-full-t42903-25.html#p433099

help-rootfs-full-t42903-25.html#p433101

Bonjour,
Je viens de prendre connaissance de vos contributions mais je ne comprends pas vraiment ou vous voulez en venir.
Dans l’ordre apt-get clean aptitude autoclean, j’ai fait tourner deborphan, j’ai viré les ancien kernel. Tout cela m’a permis de gagner 10% d’espace libre mais pas vraiment de résultat probant.
Ce matin j’ai pu terminer mes mises à jour mais l’occupation est repasser à 92%.

Pour info mes partitions lors de l’installation sont organiser de cette manière:
/ fait 5,6 Go
/temp fait 5,6 Go
/var fait 7,4 Go
/home fait 27,9 Go

[quote=“cobra”]Bonjour,
Je viens de prendre connaissance de vos contributions mais je ne comprends pas vraiment ou vous voulez en venir.
Dans l’ordre apt-get clean aptitude autoclean, j’ai fait tourner deborphan, j’ai viré les ancien kernel. Tout cela m’a permis de gagner 10% d’espace libre mais pas vraiment de résultat probant.
Ce matin j’ai pu terminer mes mises à jour mais l’occupation est repasser à 92%.

Pour info mes partitions lors de l’installation sont organiser de cette manière:
/ fait 5,6 Go
/temp fait 5,6 Go
/var fait 7,4 Go
/home fait 27,9 Go[/quote]

Il y a pas de recettes miracles il te faut regarder de près l’utilisation de ta partition racine … :whistle:

5,6Go si tu n’a rien installé d’inutile dans /usr alors la seule chose et de redimensionner ta partition racine, quelqu’un t’a proposé une manipulation plus haut à toi de voir et étudier ça.

Honte sur moi j’avais pas vue la découpe de tes partitions, merci Pascal pour m’avoir fais ouvrir les yeux :blush: