Pas de son, Debian 11 sur matériel neuf

Tags: #<Tag:0x00007fb99913cb30>

Bonjour!
Malgré toute mon expérience linux j’ai très peu d’expérience Debian. Je suis né et j’ai grandi sur le continent Mandrake|Mandriva|Mageia et je débarque sur le continent Debian après en avoir visité quelques autres.
Mon problème est que je n’ai pas de son.
Alsa et pulseaudio sont bien installés et je peux même voir les VUmètres de pulsaudio et de ALSA danser au rythme de ce que je leur envoie. Le problème est donc au niveau de la carte de son.
La carte matérielle fonctionne car la machine est arrivée avec un OS que j’ai payé trop cher pour ce que j’en ferai. :frowning_face:

Les vérifications de base:

  • je suis membre du groupe audio.
  • pas de message particulier dans dmesg ou journalctl
  • lshw -c sound m’indique que le matériel est « Tiger Lake-LP Smart Sound Technology Audio controler » et que le pilote configuré est « snd_hda_intel »
  • lsmod |grep snd m’indique une grand nombre de modules qui pointent vers snd_hda_intel (ce qui est normal) ou vers snd_sof_pci (ce qui est nouveau pour moi)

Ce qui me semble anormal:

  • je n’ai pas de /dev/dsp
  • il n’y a pas de modprobe.conf sur cette machine

Sauriez-vous m’aider?

Peut-être installer :
https://packages.debian.org/bullseye/firmware-sof-signed
L’idée m’est venue du forum (voir vers la fin) :
https://bbs.archlinux.org/viewtopic.php?id=260139

Bonjour,

j’ai eu un soucis similaire après une MàJ (je n’ai plus les détails de la màj, mais je crois que le noyau / pilote son Intel) avait changé.
J’avais résolu en effectuant les mises à jour du firmware UEFI du PC, donc ça fait une piste supplémentaire à explorer.

Merci @jweber de m’avoir fourni une piste.
Je n’avais aucun fichier ‹ /dev/dsp › et aucun ‹ pcm › dans ‹ /dev/snd › (il n’y avait que 3 ‹ control ›).
J’ai installé sof-firmware-signed.
Il y a maintenant des fichiers ‹ pcm › dans ‹ /dev/snd › mais toujour pas de son ni de ‹ dev/dsp ›.
J’ai fait une tentative avec une suggestion trouvée dans le fil de discussion sur archlinux. J’ai créé un fichier alsa.conf dans /etc/modprobe.d et j’y ai mis: options snd-intel-dspcfg dsp_driver=1 Mais cela n’a eu aucun effet et je n’en suis pas surpris car, comme indiqué précédemment, je n’ai aucun ‹ /etc/modprobe.conf › et c’est lui qui est normalement responsable de lire /etc/modprobe.d.

Suis-je le seul à ne pas avoir de /etc/modprobe.conf?

En conclusion, j’aurais besoin d’une autre piste.

@Sputnick93 Merci pour ta suggestion mais je suis un peu hésitant parce qu’il s’agit d’une machine neuve.
Pour le moment je ne sais pas encore si le problème vient de Debian11 ou du kernel 5.10.0.9.

Connaitrais-tu une distrib ‹ live › qui utiliserait Debian11 et me permettrait de tester le son?

ici
https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/11.1.0-live+nonfree/amd64/iso-hybrid/

Et pour chercher l’erreur, dans un terminal :
sudo dmesg |grep snd_hda_intel