Pas de son sur Lenovo 100S-11lBY

Tags: #<Tag:0x00007efeddab3f28>

Bonjour,
Je n’ai pas de son sur un portable Lenovo 100S avec debian 10.11
Merci d’avance pour votre aide.

Bonjour et bienvenue sur le forum,

Depuis combien de temps as-tu cette machine ?
Combien de temps ça fait que tu as installé Debian sur cette machine ?
As-tu eu ce problème de son depuis que tu as installé Debian sur cette machine ?
Peux-tu nous donner les retours des commandes suivantes :

  • lspci -nvv
  • uname -r

Peux-tu aussi nous préciser quel environnement de bureau tu utilises ?

Bonjour,

lspci -nvv
00:00.0 0600: 8086:0f00 (rev 0f)
        Subsystem: 17aa:390c
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Kernel driver in use: iosf_mbi_pci

00:02.0 0300: 8086:0f31 (rev 0f) (prog-if 00 [VGA controller])
        Subsystem: 17aa:390c
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 33
        Region 0: Memory at 90000000 (32-bit, non-prefetchable) [size=4M]
        Region 2: Memory at 80000000 (32-bit, prefetchable) [size=256M]
        Region 4: I/O ports at 1000 [size=8]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

00:14.0 0c03: 8086:0f35 (rev 0f) (prog-if 30 [XHCI])
        Subsystem: 17aa:390c
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 30
        Region 0: Memory at 90800000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci

00:1a.0 1080: 8086:0f18 (rev 0f)
        Subsystem: 17aa:390c
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 255
        Region 0: Memory at 90700000 (32-bit, non-prefetchable) [size=1M]
        Region 1: Memory at 90600000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>

00:1f.0 0601: 8086:0f1c (rev 0f)
        Subsystem: 17aa:390c
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Capabilities: <access denied>
        Kernel driver in use: lpc_ich
        Kernel modules: lpc_ich
uname -r :
4.19.0-18-amd64

C’est une machine que j’ai depuis quelques années.
J’ai installé une ancienne version de Debian et j’ai été obligé de mettre un dongle audio usb au départ.
Lorsque j’ai fait une mise à jour , l’audio interne c’est remis à fonctionner.
Récemment, j’ai refait une nouvelle installation avec une Debian 10.11 et bureau LXQT, l’icône du haut-parleur est visible mais pas de son.

Ah, pourquoi je t’ai mis l’option -n, ça n’aide pas.
Tu n’as que cinq périphériques PCI sur cette machine ?

Alors, je ne connais pas LXQT, mais est-ce que tu as regardé le paramétrages des périphériques audio.
Que retourne la commande pactl info ?

salut
parfois un pulseaudio -k suffit

ca peut aider :
https://dindoun.lautre.net/spip.php?article59

Oui, ça peut aider, mais pulseaudio est quand même assez stable maintenant.

Erreur 503 : service non disponible.

En fait je l’ai fait la semaine dernière sur un bullseye qui auparavant avait du son, et, contre toute attente, ça a marché.

quelques commandes

cat /proc/asound/version
cat /proc/asound/cards
cat /proc/asound/devices
cat /proc/asound/oss/devices
cat /proc/asound/timers
cat /proc/asound/pcm
alsactl init
lshw -C sound
             configuration: driver=snd_hda_intel latency=0
             configuration: driver=snd_hda_intel latency=0
lsof /dev/dsp
lsof /dev/snd/*
fuser /dev/snd/pcmC0D0p
fuser /dev/snd/pcm*
lspci |grep -i audio
for DomBusFun in $(lspci |grep -i audio|sed "s/\ .*//g");do lspci -s "$DomBusFun" -nnvvv ;done

dmesg  |egrep 'sound|snd'
ps aux |egrep "pulse|alsa" |grep -v grep
cat /home/*/.asoundrc /root/.asoundrc

Ah oui, elles sont bien ces commandes. Note bien que les commandes lsof, lspci et lshw ne sont pas forcément installées et que dmesg a peut-être besoin des droit super-utilisateur.