Pas de son sur une MintBox 2

Bonjour,

J’ai fait l’acquisition d’une Mintbox 2 il y a peu (monumentale erreur) et voici le souci que j’ai actuellement.

Que ce soit sur Linux Mint (Cinnamon ), Manjaro (XFCE) ou Debian-testing (Gnome 3.8.4), le topo est le même : à l’install, j’ai du son, mais si jamais je vais sur le module de réglage du son de sortie (onglet “Sortie” des paramètres de son dans Gnome 3), après être allé sur un autre onglet, alors je n’ai plus de son (si je ne suis jamais allé sur aucun onglet avant, alors aucun périphérique de sortie n’est sélectionné mais ça marche, même si ça semble hoqueter).

Je précise que la MintBox 2 n’a pas de sortie VGA et que donc je connecte mon écran VGA avec un adaptateur HDMI VGA - il semble qu’il y ait pas mal de problème avec ça. Je précise aussi que le seul périphérique reconnu par Gnome est justement cet HDMI. J’ai l’impression que Gnome a donc deux situations :
au début : il sait pas donc il envoie dans la nature et ça atterri dans mes haut-parleurs
après : il a trouvé un HDMI (je pense seulement, car c’est écrit “Digital Output (S/PDIF)”), donc il l’envoie là - il envois le son à mon écran.

J’ai réinstallé Linux Mint (qui vient avec la Mintbox, puis installé Manjaro, puis installé Debian-testing… toujours le même problème. Mon matériel fonctionne parfaitement aussi. Enfin, j’ai constaté que, si je crée un nouvel utilisateur, le nouvel utilisateur a bien le son - jusqu’à ce qu’on clique sur l’onglet de paramétrage du son !
J’ai lu ailleurs sur un forum Ubuntu que passer de digital à analogique aide, mais Gnome 3 ne le permet pas

Quelques informations que j’ai obtenu qui peuvent aider
lspci
Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)

cat /proc/asound/pcm
00-00: ALC888 Analog : ALC888 Analog : playback 1 : capture 1
00-01: ALC888 Digital : ALC888 Digital : playback 1 : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
01-00: USB Audio : USB Audio : capture 1

grep “Codec:” /proc/asound/card*/codec*:
/proc/asound/card0/codec#0:Codec: Realtek ALC888
/proc/asound/card0/codec#3:Codec: Intel PantherPoint HDMI

alsamixer
soundcard:pulsaudio
chipset:pulseaudio

BIOS mis sur les paramètres par défaut, les mêmes que quand ça marchait (nota : j’ai cette machine depuis deux semaines, je n’ai jamais eu de moment où ça marchait, sauf avant que je clique sur les paramètres de son)

plus.google.com/+DavidLatapie/posts/GaHrUZvknvV:
sudo nano /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=generic
ça, ça marche pour Manjaro mais pas pour Debian ou Linux Mint - probablement que c’est dû à une implémentation différente chez Arch de chez Debian

Je ne sais pas trop quoi faire, je dois dire… Je vais acheter demain une clé 8Go pour pouvoir installer Windows sur une clé USB (il faut 8 Go pour Windows 8, le seul qui semble accepter l’install sur une GPT et non sur un MBR), voir si ça marche (quelque chose me dit que oui). J’aimerai vraiment ne pas me retrouver dans un situation où le seul OS qui marche sur ma machine, c’est Windows…

Merci pour vos réactions que j’espère nombreuses (et constructives, mais cela va sans dire sur un forum Debian :slightly_smiling:)

Bonjour,
il semblerai que ce soit un probléme de définition de sortie par défaut.
Tuas 2 “cartes sons” d’installées:

  • la carte “HDMI” sur ta carte graphique
  • la sortie sur ta carte mère.

Pour t’aider dans le diagnostique: isalo.org/wiki.debian-fr/Di … %A8me_alsa

Il faut que tu imposes la sortie sur la carte mère par défaut.