Passage à Xorg 6.9 avec le driver propriétaire ATI


#1

Bonsoir à tous !

J’ai une ATI Radeon 9700 SE Mobility et j’utilise le driver fglrx proprio d’ATI. Tout fonctionnait bien sur ma debian sid jusqu’à ce qu’un upgrade me fasse passer à Xorg 6.9… En effet, fglrx ne semble pas avoir de version pour le dernier Xorg.

Je voudrais savoir si il y a tout de même moyen de les faire fonctionner (La mandriva 2006 utilise 6.9, et je serais curieux de savoir comment les utilisateurs de carte ATI se débrouillent…).

De plus, j’ai entendu parler du très prometteur XGL qui permet d’avoir des effets 3D sympatiques en tout genre sur le desktop qui ne servent à rien mais qui impressionnent :smiley: :laughing:
Mais pour cela il faut Xorg 7.0 donc je me demande également comment les possesseurs d’ATI s’en sortent…

Merci d’avance


#2

j’ai pas d’ATI, donc je n’ai pas de bonnes réfèrences debian, mais ce lien ubuntu peut te donner une piste sur comment faire (en adaptant les noms de paquets):
doc.ubuntu-fr.org/materiel/ati
en particulier:

emeraude:~$ apt-cache search fglrx fglrx-control - Control panel for the ATI graphics accelerators fglrx-driver - Video driver for the ATI graphics accelerators fglrx-driver-dev - Video driver for the ATI graphics accelerators (development files) fglrx-kernel-src - Kernel module source for the ATI graphics accelerators

sinon, debian n’a de version xorg qu’en 6.9:emeraude:~$ apt-cache policy xserver-xorg xserver-xorg: Installé : 6.9.0.dfsg.1-4 Candidat : 6.9.0.dfsg.1-4 Table de version : *** 6.9.0.dfsg.1-4 0 990 http://ftp2.fr.debian.org etch/main Packages 93 http://ftp2.fr.debian.org sid/main Packages 100 /var/lib/dpkg/status


#3

Salut,
Personnellement, j’ai été obligé d’installer les drivers sur xfree86 ou xorg 6.8.2 maximum… Ca ne tourne pas sur xorg 6.9 !!!
A+
Joel


#4

Ben ouais il a fallu que je retourne à Xorg 6.8.2 en lui mettant un petit hold sur ses paquets…