Patch AGP pour VIA KT400 sur Debian


#1

Bonjour.

Je viens d’acquérir une carte VIA KT400 (A7V8X-X) et me suis rendu compte de mauvaises performances 3D. Recherches faites, mon kernel actuel, le 2.4.20, n’a pas l’AGP pour le VIA KT400. J’ai
donc voulu installer un kernel 2.4.21rc2.

Pour se faire, j’ai décompressé le kernel 2.4.20 dans le repertoire /usr/src/kernel-source-2.4.21
ensuite j’ai décompressé le patch-2.4.21-rc2 dans /usr/src, me suis rendu dans /usr/src/kernel-source-2.4.21 et aie appliqué le patch avec la commande patch -Np1 -i /usr/src/patch-2.4.21-rc2 (ou bunzip2 -c …/patch-2.4.21-rc2.bz2 | patch -p1 j’ai aussi essayé)
alors une grande liste d’opération de patch s’affiche, visiblement sans problèmes.

Mais quand je fais make xconfig avec le kernel patché ça ne marche pas. ça fait:

$:/usr/src/kernel-source-2.4.21# make xconfig
rm -f include/asm
( cd include ; ln -sf asm-i386 asm)
make -C scripts kconfig.tk
make[1]: Entering directory /usr/src/kernel-source-2.4.21/scripts' cat header.tk >> ./kconfig.tk ./tkparse < ../arch/i386/config.in >> kconfig.tk drivers/ide/Config.in: 46: can't handle dep_bool/dep_mbool/dep_tristate condition make[1]: *** [kconfig.tk] Erreur 1 make[1]: Leaving directory/usr/src/kernel-source-2.4.21/scripts’
make: *** [xconfig] Erreur 2

Que faire? J’ai supposé que le kernel 2.4.20 fourni par apt-get avait quelques modification, et aie donc refait la même manoueuvre avec le 2.4.20 téléchargé depuis kernel.org mais toujours sans succès!

Le plus simple pour moi serait peut-être d’avoir uniquement le patch KT400 mais où le trouver?

Merci.


#2

teste make menuconfig ?


#3

Problème résolu!

Le make xconfig ne marche toujours pas, mais grâce à menuconfig j’ai pu charger mes préférences pour le kernel et donc compiler un kernel 2.4.21-rc2
Après installation j’ai testé mes performances et effectivement je suis passé de 93fps à 130 sur mon test de référence! Bon c’est un peu décevant je trouve par rapport aux perfs du KT133A, je faisait 103 sans régler et 118 en réglant à mort, mais j’avais une KT7A et ces trucs étaient vraiment customisable.

Merci pour votre aide :salut:


#4

euh, 130 fps c’est pas enorme, c’est ta carte vidéo qui limite a mon humble avis :astonished:P


#5

c’est une GF4 TI4600 128mo et mon proco est un XP1800.

Le bench est une demo de Q3 Team Arena (plus lourd que Q3) en 1024*768 tout à fond.


#6

teste un glxgears


#7

[quote=“kyo”]c’est une GF4 TI4600 128mo et mon proco est un XP1800.

Le bench est une demo de Q3 Team Arena (plus lourd que Q3) en 1024*768 tout à fond.[/quote]

oué c’est donc bien la vidéo qui limite :astonished:P


#8

les scores varient beaucoup, allant de 4500 à 15000


#9

[quote=“ed”][quote=“kyo”]c’est une GF4 TI4600 128mo et mon proco est un XP1800.

Le bench est une demo de Q3 Team Arena (plus lourd que Q3) en 1024*768 tout à fond.[/quote]

oué c’est donc bien la vidéo qui limite :astonished:P[/quote]
une GF4 4600? :open_mouth:


#10

les scores varient beaucoup, allant de 4500 à 15000[/quote]

oué donc c’est un score tout a fait normal :slightly_smiling: