Patch


#1

Réponse à MatToTop :
Pas grand chose qui me “cause” ds ‘apt-cache search kernel-patch’ mais des questions :
Qu’apporte le suivant, ça a l’air généraliste car rien n’est précisé :

Cet autre sembleamener un logo au chargement et j’aimerais bien le tenter pour savoir au moins comment ajouter un patch.


#2

le premier, tu ne t’en occupes pas, c’est les patchs à appliquer à des sources “kernel.org” pour les rendre “debian” (entre autres, la gestion du cramfs).

Le deuxieme est effectivement celui qu’on utilise pour tester, il fait apparaitre un logo au boot. Mais il necessite un framebuffer en console.

un truc que je n’ai pas eu le courage de tester jusqu’au bout et qui nécessite un patch aussi, c’est bootsplash. mais il y a aussi plusieurs paquets à installer, et ca modifie aussi les scripts de boot.


#3

Donc, je lmaisse tt ça de côté :wink:


#4

Pour le logo, si tu compile un noyau 2.10 ou plus tu n’as pas besoin de ce patch, car tu l’as déjà installé dans les sources du noyau.


#5

Merci Bonze, je suis sur une base de 2.6.10 mais comment le mettre en évidence ?
Il est possible que je n’aie pas mis ce qu’il fallait à la config ?
De quel côté de ‘config’ ça se trouve ?


#6

bej@luciole:~$ grep LOGO /boot/config-uname -r

CONFIG_LOGO is not set

bej@luciole:~$


#7

Merci.
Chz moi, il est bien configuré et en ‘dur’ mais je ne vois rien au boot ?


#8

Et le framebuffer ?

bej@luciole:~$ grep FRAMEBUFFER /boot/config-`uname -r`
CONFIG_FRAMEBUFFER_CONSOLE=m
bej@luciole:~$

Il y a aussi quelque chose à faire de ce côté mais je ne m’y suis jamais intéressé, alors je ne peux guère t’aider plus
:frowning:


#9

Oui, c’est surement parce-que tu n’a pas activé le frame buffer aux options de boot.

Sur la config de ton boot (lilo ou grub) rajoute dans ton option noyau l’option :
vga=788


#10

Oui, il est en module et je suppose qu’il doit falloir le placer en dur puisque c’est au boot qu’il ,agit ?
je ferai ça à ma prochaine config


#11

Pas nécessairement, si tu utilises initrd ca devrait passer, je pense ?


#12

Par contre il faut mettre en dur le driver vesa dans ta compil noyau, sinon écran noir!


#13

Il est en module :cry:

ricardo7@debian:~$ grep VESA /boot/config-`uname -r` CONFIG_FB_VESA=m ricardo7@debian:~$
je ferai ça à la prochaine config.
Merci[/code]


#14

[quote]Sur la config de ton boot (lilo ou grub) rajoute dans ton option noyau l’option :
vga=788[/quote]
Qu’entends-tu par ‘config de ton grub’ ?
Je ne trouve pas cette ligne ds .config


#15

si ton menu.lst est mis à jour automatiquement par update-grub, tu le rajoutes sur la ligne kopt=, et tu refais un 'update-grub’
sinon, si c’est une config manuelle, c’est sur la ligne ‘kernel …’ de ton entrée de boot


#16

title Debian GNU/Linux, kernel 2.6.10-ric.28.3 root (hd0,5) kernel /boot/vmlinuz-2.6.10-ric.28.3 root=/dev/hda6 ro initrd /boot/initrd.img-2.6.10-ric.28.3 savedefault boot
Où exactement ? à la suite de …/dev/hda6 ro
comme ça :
kernel /boot/vmlinuz-2.6.10-ric.28.3 root=/dev/hda6 ro vga=788
?


#17

si tu édites ton fichier menu.lst à la main, c’est ça.
mais je te conseille de regarder le fonctionnement de update-grub, et si tu fonctionnes avec, de rajouter cet argument vga=788 sur la ligne qui commence par ‘# kopt=…’ (c’est la liste des arguments rajoutés automatiquement à la ligne ‘kernel’ de chaque entrée de noyau lors de l’update-grub).


#18

Mon problème, c’est que je fais tjrs mes tests sur hda6 et la mise-à-jour de grub se fait automatiquement sur ce m^ hda6.
Mais : quand j’allume ma bécane, le menu grub qui se présente est celui qui est ds la Debian fonctionnelle, càd hda7.
Je suis donc obligé de modifier ce dernier à la main.


#19

Fais update-grub et ça fonctionne auto pour le hda6 et pour le hda7 du début mais pas pour ceux de hda6, à partir de hda7.
J’ai donc modifié à la main : vga=788
Maintenant, j’ai un écran noir et donc il me reste à pplcer en dur le FB_VESA ds la config.
Demain, peut-être :wink:


#20

C’est bon alors, la fin est proche ! :smiley:
Tu pouras avoir tes petits manchos au démarage!